LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Networking (http://www.linuxquestions.org/questions/forumdisplay.php?f=3)
-   -   setting up wireless trying to execute this .conf script to connect using WPA (http://www.linuxquestions.org/questions/showthread.php?t=4175443045)

DavidLee1A 12-26-2012 06:39 PM

setting up wireless trying to execute this .conf script to connect using WPA
 
I typed as per these directions in vi but I need to run the file now, cmod 0755 works for .sh files what do I use for .conf files?

"On a Linux client, install wpa_supplicant and create a configuration file, wpa_supplicant.conf (in Debian, installed in /etc/wpa_supplicant/) like the following:



update_config=1
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

network={
ssid="My_Secure_WLAN"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
group=CCMP
psk="PASSPHRASE"
priority=5
}
Again replace the parts in italics to match your setup and run wpa_supplicant -i eth1 -D wext -c /etc/wpa_supplicant/wpa_supplicant.conf (replacing eth1 with your wlan interface name and wext with the appropriate driver for your card; run wpa_supplicant without any options for more information). This command starts wpa_supplicant in the foreground and tries to connect to the WAP"
I need to (1) run this as a .conf file and (2) use the proper syntax to execute this script.

Peacedog 12-26-2012 10:01 PM

Hi DavidLee1A, Welcome to LQ. You don't run the conf file, you run wpa_supplicant with the options per the instructions and wpa_supplicant should read from the conf file. When you run the following you are telling wpa_supplicant where the conf file lives.

Code:

wpa_supplicant -i eth1 -D wext -c /etc/wpa_supplicant/wpa_supplicant.conf
The path to the conf file is in red. Hope that clears it up for you.

Good luck. ;-)


All times are GMT -5. The time now is 05:51 AM.