LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-25-2005, 02:27 PM   #1
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Setting up Apache HTTP server


I think I'm almost there in terms of setting up a HTTPd server with Apache, but I don't know the details. Here is what I have done basically:

1) I got the Apache server running
2) I setup a hostname at www.dyndns.org (micro420.mine.nu)
3) I changed my router configuration to forward port 80 to my server, 192.168.2.2

Now what do I do? Going to http://micro420.mine.nu doesn't do anything. I can, however, access http://192.168.2.2 internally.

I tried reading the official documentation for the Apache HTTPd server, but it's confusing! It's more like "Good luck finding what you need in this massive documentation" rather than "Okay, here's what you do step-by-step".
 
Old 02-25-2005, 03:04 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 79
Your router probably doesn't support natting back to the lan. Try from a web proxy like:
http://www,proxify.com

You will also need to wait a few minutes for the dns address to become active.
 
Old 02-25-2005, 09:17 PM   #3
mikeheggy
Member
 
Registered: Jan 2005
Posts: 37

Rep: Reputation: 15
I know for sure my router doesn't support "natting back to the lan" (I'm pretty sure it's called loopback?)

Anyway, ask a friend to visit the website. If not, try something like Webscale. That would connect to your server and give you details about your website.
 
Old 02-25-2005, 10:37 PM   #4
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Original Poster
Rep: Reputation: 45
I went to www.proxify.com and entered my website, but nothing came up. That's because I can't connect to micro420.mine.nu, yet.

I also checked out the webscale website, and again, it could not find the website. That's because my website isn't out on the internet yet. So that is my problem: how do I get my website exposed out on the internet???? It can ONLY be access internally.
 
Old 02-25-2005, 10:55 PM   #5
mikeheggy
Member
 
Registered: Jan 2005
Posts: 37

Rep: Reputation: 15
maybe your ISP blocks port 80?
 
Old 02-26-2005, 12:32 AM   #6
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Original Poster
Rep: Reputation: 45
Quote:
Originally posted by mikeheggy
maybe your ISP blocks port 80?
is there a way I can find out if this port 80 is blocked? Is there a way around this?
 
Old 02-26-2005, 10:05 AM   #7
mikeheggy
Member
 
Registered: Jan 2005
Posts: 37

Rep: Reputation: 15
What ISP do you have? If your ISP does block port 80, it probably says somewhere in their TOS that running a server is not allowed.

You can check it by changing the port that apache listens on from 80 to 81 or 88 - something that's not already in use. Don't forget to change the configuration in your router to foward to the new port.

Afterwards, do a portscan at www.grc.com, and that will tell you whether the new port is open or not. If it is, then it's likely that your ISP is blocking port 80.

Last edited by mikeheggy; 02-26-2005 at 02:28 PM.
 
Old 02-26-2005, 01:56 PM   #8
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 79
If you gave your true domain name above then it isn't set up right. I can't resolve an IP for it:
rossy - trigger - Sat Feb 26 19:59:18
~> dig +short micro420.mine.nu
rossy - trigger - Sat Feb 26 19:59:56
~>
 
Old 02-26-2005, 04:17 PM   #9
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Original Poster
Rep: Reputation: 45
Quote:
Originally posted by david_ross
If you gave your true domain name above then it isn't set up right. I can't resolve an IP for it:
rossy - trigger - Sat Feb 26 19:59:18
~> dig +short micro420.mine.nu
rossy - trigger - Sat Feb 26 19:59:56
~>
Yes, it is a false address because the REAL website is actually myrealname.mine.nu and I didn't want to post it.
 
Old 02-26-2005, 04:20 PM   #10
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Original Poster
Rep: Reputation: 45
Quote:
Originally posted by mikeheggy
What ISP do you have? If your ISP does block port 80, it probably says somewhere in their TOS that running a server is not allowed.

You can check it by changing the port that apache listens on from 80 to 81 or 88 - something that's not already in use. Don't forget to change the configuration in your router to foward to the new port.

Afterwards, do a portscan at www.grc.com, and that will tell you whether the new port is open or not. If it is, then it's likely that your ISP is blocking port 80.
Good news is that port 80 is OPEN, however GRC detects that as a security threat, but that's okay with me.

I'm thinking it's either now a www.dyndns.org configuration problem or an Apache configuration problem.
 
Old 02-26-2005, 05:07 PM   #11
sarin
Member
 
Registered: May 2001
Location: India, Kerala, Thrissur
Distribution: FC 7-10
Posts: 354
Blog Entries: 2

Rep: Reputation: 34
Do an nslookup/dig on your hostname and that should tell you if the dyndns is fine or not. I have worked with httpd long back.

(Edited)Sorry, I had mentioned about acl. But ACL comes in Squid and not in httpd. So removing it.

--Sarin

Last edited by sarin; 02-26-2005 at 05:22 PM.
 
Old 02-26-2005, 05:44 PM   #12
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Original Poster
Rep: Reputation: 45
Quote:
Originally posted by sarin
Do an nslookup/dig on your hostname and that should tell you if the dyndns is fine or not. I have worked with httpd long back.

(Edited)Sorry, I had mentioned about acl. But ACL comes in Squid and not in httpd. So removing it.

--Sarin
nslookup myrealname.mine.nu

Server: DHC1TF31
Address: 192.168.2.1 <--- This is my second router gateway address, which the server is NOT connected to. Very weird

Name: myrealname.mine.nu
Address: 67.180.140.102 <--- this is my correct Comcast IP address.

Last edited by Micro420; 02-26-2005 at 05:46 PM.
 
Old 02-26-2005, 06:36 PM   #13
lennysokol
Member
 
Registered: Feb 2005
Posts: 65

Rep: Reputation: 16
Apache

Is this running on Linux? If so, did you start the service?

go to the terminal and type in:

service httpd start


then go to http://localhost in firefox. If you receive a page, your in the right direction!
 
Old 02-26-2005, 06:38 PM   #14
lennysokol
Member
 
Registered: Feb 2005
Posts: 65

Rep: Reputation: 16
BTW:

did you enable chkconfig for Apache for bootup?

you said you can get to internally, but not externally?

Try to go to websitepulse and enter your URL and see if it hits a response.

Also -

what's your public IP? it should be on the router somewhere. try to enter that...?

that limits down whether it's dyndns...
 
Old 02-26-2005, 08:00 PM   #15
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Original Poster
Rep: Reputation: 45
Re: Apache

Quote:
Originally posted by lennysokol
Is this running on Linux? If so, did you start the service?

go to the terminal and type in:

service httpd start


then go to http://localhost in firefox. If you receive a page, your in the right direction!
No, I am running Apache in Windows 2000. The Service is running as I see it in the tray. When I do http://127.0.0.1, or 192.168.2.2, I can see the webpage. But, when I do http://myrealname.mine.nu, it says the connection was refused.

As for the websitepulse, it would not matter since people outside my network cannot see my server or webpage. It would just think that I typed in some non-existent website.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Two Apache http server problems... eyebrowsoffire Linux - Networking 2 02-17-2005 10:38 PM
[apache http server] directory hylke Linux - Software 8 08-02-2004 02:02 AM
Setting up HTTP server squirellplaying Linux - Newbie 8 05-02-2004 06:57 PM
problem setting up router in linux http server mkepler1 Linux - Networking 1 12-18-2003 12:42 PM
Setting up Apache HTTP Webserver darklord75 Linux - Networking 6 04-19-2003 05:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration