LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   setting up a fileserver (https://www.linuxquestions.org/questions/linux-networking-3/setting-up-a-fileserver-343863/)

DAChristen29 07-16-2005 08:43 PM

setting up a fileserver
 
for a while, mepis has been able to setup samba all by itself and let me see computers running windows xp and 98 and share files between them.

i no longer have mepis installed, and i cant get this network working. i have an ubuntu machine, mandrake 10 machine, and 2 windows computers running 98 and xp.

what i want to do is turn the mandrake 10 machine into a fileserver. ive been searching and reading around that NFS is what i want. i want to make a hard drive on the fileserver act as if it were a folder on my ubuntu home folder.

ubuntu can see the other networks, but i cant see any of the computers, as it says "Sorry, couldn't display all the contents of "Windows Network: homenet"."

on the mandrake 10 fileserver, i have everything setup properly AFAIK. file sharing is on, symlinks are in order, and my home folder is shared to the entire network. yet, it doesnt work.

muppski 07-17-2005 03:29 AM

Uuhh
It sounds like what you want is Samba
not NFS

EDIT: Sorry maybe NFS can do the same.
but what I know windows dont have NFS support so you would need a software or whatever for that

"Samba allows for interoperability between Linux/Unix servers and Windows-based clients."

RanDrake10 07-17-2005 08:04 AM

Samba will work with your win boxes. On linux go to your home dir and add a short cut to the folder you want to share, use "smb://mandrake/folder/here". You might have to edit your /etc/samba/smb.conf file to allow sharing on the folders. If you got the addresses in your /etc/hosts file you can just enter the machine name. You could also use ssh to make adjustments on your server without having to be at it.

DAChristen29 07-18-2005 06:56 PM

okay, so im using samba.

on ubuntu, i can see the windows box, but as soon as i go to browse it, i cant. why?

demoncheese 07-20-2005 07:40 AM

* EDIT *
Have just noticed that it's the windows not the Mandrake box - sorry. It still sounds like it might be down to user issues though - does the same user exist on the target windows machine?

* Orig Reply *
Have you setup the user that you are using to browse as a Samba user on the Mandrake machine. Samba users aren't the same as normal machine users - have a look in /etc/samba/smbusers and make sure that the user exists in there.

Sorry it's a bit brief, I'm no expert but I have been caught out by this myself before so it might be worth checking.

motub 07-21-2005 07:56 AM

demoncheese, it might have been a bit brief, but that about covers it:
Quote:

Have you setup the user that you are using to browse as a Samba user on the Mandrake machine.
But in this case, just replace the word "Mandrake" with the word "Windows".

If you've locked your door to keep possibly dangerous people out, you wouldn't open it just because someone you didn't know stood outside and said "Open your door"--- and Samba, under either Windows or Linux, is essentially a lock on the door, intended to protect your shared files from unauthorized access.

What that means is that the file will not be accessible to anyone either Samba does not "know"-- and that means that the user who wants to access the files shared on either computer must be a user known to the computer serving them.

Under Linux's Samba server (if you're sharing files from a Linux box), this means adding the other users to your regular Unix userlist (adduser or superadduser can create the users without a home directory if desired), and then adding them to smbpassword so that Samba recognizes them (it won't accept a user who is not listed as a regular user).

Under Windows' Samba server (if you're sharing files from a Windows box), this means that the Administrator must add the other users to the list of known users using the Users and Passwords control panel applet. And. of course, the added users must be authorized to access individual shares, if you don't use the default setting of "Everybody" when creating a share under Windows.

Hope this helps.


All times are GMT -5. The time now is 06:06 AM.