-   Linux - Networking (
-   -   Setting tc qdisc to "pfifo_fast" fails (

cycledick 01-30-2013 09:43 PM

Setting tc qdisc to "pfifo_fast" fails
Been lurking this site for a long time. It's gotten me out of many jams. This time I need to make sure I'm correct before moving on. I've been trying to find a similar post, but am not having any luck.

I have some software being installed on RedHat Release 2.6.32-131.0.15.el6.i686. The software is "complaining" that "The system should not have NON DEFAULT Traffic Control rules".

This server was installed from scratch from a version purchased directly from RedHat. When I look at the TC rule that is there directly after install, it looks like this;

qdisc mq 0: dev eth0 root

The software I'm installing wants it to look like this;

qdisc pfifo_fast 0: dev eth0 bands 3 priomap 1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1

The closest I can get is this, but I don't think it's the same thing.

qdisc prio 8008: dev eth0 root refcnt 9 bands 3 priomap 1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1

I've read that pfifo_fast cannot be set using tc and that it's the default qdisc. I've been researching this all day and I've run across a lot of people having the same problem, but not a real solution. I've run the application's installation program and it finishes, but it does complain.

Can anyone tell me if my rule is the default and their rule isn't? Or, is there a config file I can alter to change the tc setting at boot time?

Thanks in advance!!!

All times are GMT -5. The time now is 11:12 PM.