LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-14-2009, 09:05 AM   #1
eRJe
Member
 
Registered: May 2005
Location: Netherlands
Distribution: Slackware 14.1 Kernel 3.12.1
Posts: 103

Rep: Reputation: 16
Setting static IP without hostname in dhcpd.conf


Hi,

Currently all my network devices are getting their IP through dhcp from my Slackware server. Now I would like to change things a little bit and have some devices get a static IP leased by their MAC address.

I've managed to setup most of the devices but I'm having problems with the VOIP phone. It doesn't seem to have a hostname. I've tried to leave out the entry host and I've tried entering any name. In both cases the phone did get the right IP assigned and I was able to login to the phone's web configuration tool. However the phone did not get the right dns server assigned and therefore did not connect to the internet.

any suggestions would be greatly appreciated! Can I enter a static IP address for a device with no hostname?

Robbert


My dhcpd.conf file

Code:
# dhcpd.conf
#
# Configuration file for ISC dhcpd (see 'man dhcpd.conf')
#
#

ddns-update-style interim;
ignore client-updates;

subnet 192.168.0.0 netmask 255.255.255.0 {

### DYNAMIC IP LEASES ###

   range 192.168.0.10 192.168.0.200;
      option subnet-mask             255.255.255.0;
      option broadcast-address       192.168.0.255;
      option routers                 192.168.0.1;
      option nis-domain              "homeServer";
      option domain-name             "homeServer";
      option domain-name-servers     dns1.com, dns2.com, dns3.com, dns4.com, 192.168.0.1 ;
      option time-offset             +3600;              # Central Europe (GTM+1)
      default-lease-time             86400;              # 24 hours
      max-lease-time                 86400;              # 24 hours



### STATIC IP LEASES ###

   # Switch
   host GSW-1676
      {
      hardware ethernet 00:11:6b:d6:a9:80;
      fixed-address 192.168.0.2;
      }

   # WiFi Accesspoin
   host wifi
      {
      hardware ethernet 00:23:69:04:41:0C;
      fixed-address 192.168.0.3;
      }

   # Printer
   host MC5550
      {
      hardware ethernet 00:20:6B:C7:9B:E4;
      fixed-address 192.168.0.5;
      }

   # VOIP
   host
      {
      hardware ethernet 00:01:E3:79:EF:EE;
      fixed-address 192.168.0.6;
      }
}
 
Old 04-15-2009, 01:46 PM   #2
kentyler
Member
 
Registered: Dec 2008
Location: Newark Ohio
Distribution: Fedora Core
Posts: 270

Rep: Reputation: 38
You are required to put host in the configuration. DHCP does not care what you put here, you could easily put anything unless you run dns local or there are actual dns entries somewhere that these addresses resolv to and ip.

The problem sounds like it's a config the phone is using or checking against host/domain name.

You have homeserver setup as domain, it should be the same in the phone or it's possible it may not accept the dns entries from the homeserver network.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to re-invoke dhcpd after changes were made to dhcpd.conf file. Azazwa Linux - Newbie 3 03-30-2009 04:44 AM
dhcpd.conf - static route prvnrk Linux - Server 2 08-13-2007 03:36 AM
/etc/dhcpd.conf or /ltsp/dhcpd.conf ? maxsanders Ubuntu 1 07-07-2007 06:32 AM
dhcpd subnet declaration problems in dhcpd.conf vcrispo Linux - Networking 6 07-15-2005 10:32 AM
setting up static IP - hostname?? michaeltweak Linux - Networking 6 01-27-2004 07:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration