-   Linux - Networking (
-   -   Setting Printer Path in CUPS(IPP) and turbo print (

gimmee 08-16-2006 07:49 PM

Setting Printer Path in CUPS(IPP) and turbo print
Hi all

I have a desktop computer with network card and a Canon IP4000R printer hooked directly to desktop network card. The USB port from the printer I use to plug into my Laptop which is running Ubuntu Dapper. Obviously a very tiny network. This works good in windows for me and the laptop with Ubuntu and Turbo print driver everything works fine.

I am trying to setp my CUPS (IPP) with Turboprint driver but I don't know what to put in Path.

My Desktop IP adress is
My printer IP address is
My printer Canon IP4000R

I can ping printer IP address no problems

ping -c 4
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=5.70 ms
64 bytes from icmp_seq=2 ttl=64 time=1.04 ms
64 bytes from icmp_seq=3 ttl=64 time=1.02 ms
64 bytes from icmp_seq=4 ttl=64 time=1.03 ms

I seem to be able to set printer up fine but when I come to print it keeps saying printer is busy.

I have tried using xtpsetup to add printer, the webbrowser and going to cups administration set up with localhost:631, and also Add printer under Fedora KDE printer setup. I always get to print test page and it says printer busy.

With everything I am reading I seem to have conflicting views in what I should put in for the ipp printer path. I'm sure I am not putting this in correctly.

I have tried

ipp:// (I dont know what I am meant to put there for printer name? /printer/canon or where do I get that path or queue from).

When I use cups administration on localhost 631 and add printer I dont know what to add for Location and I always end up with a URI like below with the 631 port attached.Which doesnt work at all.

Canon_PIXMA_iP4000R TurboPrint
Printer State: idle, accepting jobs.
Device URI:

Any help muchly appreciated for this newbie in getting my very simple network printer to run.

New Zealand

rojak 08-16-2006 08:03 PM

You sure that in Windows this port no 631 is working?
The default port is normally 9100 for network printing.
That's all I can say...

gimmee 08-16-2006 09:17 PM

Hi there

I found the post below.

Using the web interface of CUPS, I’ve added a new printer, with the following specs :
Name : whatever you want, mine is IP4000R (how original)
Location and Description : optional, whatever you want
Device : I chose “Appsocket / Jetdirect“, and then for URI I use : socket://
Drivers : Canon, then Pixus i860
w00t ! Remote ethernet Canon iP4000R printer now working \o/"

I was wondering why this guy had 9100 for ports.

The 631 port I describe above is what Cups listens on I think for managing cups and printers. So i type in my webpage and I can manage cups and printers.

The post above is using Appsocket / Jetdirect. How is that different to CUPS (IPP)? Also for his URI he uses, would that be the address of the cups print server. In my case (desktop network card)?



gimmee 08-16-2006 09:36 PM

Hey there

I got it to print a test page and printing fine.

For Connection I selected

other (CUPS URI)

For URI i put



Gimmee :):)

All times are GMT -5. The time now is 03:29 AM.