LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Sendmail not working at all. (https://www.linuxquestions.org/questions/linux-networking-3/sendmail-not-working-at-all-56563/)

EL3CTRO 04-24-2003 09:45 AM

Sendmail not working at all.
 
I can't figure out how to do this, I have no experience with sendmail, it's configured from guides, etc.

Basically, sendmail doesnt work, I can start it as a daemon, but I can send mail to local users or external addresses..

The os is RH 7.3, sendmail version... umm not sure how to get that, i've tried sendmail -v, -V, --Version and --version. I know it's a recent version because I updated it to fix the security vunerability.. im sorry im just useless at this, and it's pissing me off.

Help would be GREATLY appreciated.

jharris 04-24-2003 10:07 AM

How have you tried to call it? What happens when you using the mail command? e.g. cat /etc/lilo.conf | mail root

cheers

Jamie...

kenulla 04-24-2003 11:46 AM

use the command

sendmail -d0.1 -bt < /dev/null

to get the v ersion :)

-d sets debug level

-bt puts in address test mode

and te redirect from /dev/null gives it no address to test

EL3CTRO 04-24-2003 01:43 PM

Ok, the version is 8.12.8

The way I tried to send mail was using Webmin, an online admin thingy, im not exatly sure of the command to send mail from the command line.

When I type mail, it tells me there is no mail for root, and when i type cat /etc/lilo.conf | mail root it says:

[root@you root]# cat /etc/lilo.conf | mail root
No message, no subject; hope that's ok
[root@you root]# collect: Cannot write ./dfh3OHgUd2005933 (bfcommit, uid=520, gid=508): Permission denied
queueup: cannot create queue temp file ./tfh3OHgUd2005933, uid=520: Permission denied

EL3CTRO 04-25-2003 12:04 PM

Anyone have any ideaS?

jharris 04-25-2003 01:52 PM

What user were you running sendmail as? It sounds to me like sendmail it trying to write temporary files to a location that the user it's running as isn't able to write to. Can you see what user sendmail is running as?

cheers

Jamie...

EL3CTRO 04-28-2003 11:36 AM

Thanks for replying, the user was uid 520, 'smmsp'.

bimble 04-29-2003 03:13 AM

dump it, use qmail!

EL3CTRO 04-29-2003 03:29 AM

Eehehehe right, i'm actually dumping QMail and using sendmail :P

jharris 04-29-2003 04:08 AM

Quote:

Originally posted by EL3CTRO
Eehehehe right, i'm actually dumping QMail and using sendmail :P
I can't say I blame you, all my boxes are qmail'd up now.

cheers

Jamie...

EL3CTRO 05-01-2003 04:58 PM

*bump*

So, should I set certain permissions on the user sendmail runs as? If so, what permissions?

jharris 05-02-2003 04:34 AM

Sorry, I didn't reply sooner as I'm not that upto speed on how qmail uses its smmsp user to deliver mail, and I don't have any boxes runnig sendmail to have a look on either.

cheers

Jamie...

EL3CTRO 05-03-2003 03:31 AM

Thanks for trying anyway, just one more question..

I've got sendmail working, but now when I try to run it as a daemon, with the command: /usr/sbin/sendmail -bd -q10m it runs for about 30s to 1m then just stops... is there a log or something that sendmail writes to, that I could look at to see whats up? I've tried appending >/root/mailerror (A file I created) to the command, but the file just stays blank.

jharris 05-03-2003 07:06 AM

Typically sendmail logs through syslogd so you'll probably find something in /var/log/mail or /var/log/maillog or /var/log/message depending how syslogd is configures (/etc/syslogd.conf)

cheers

Jamie...


All times are GMT -5. The time now is 12:12 AM.