LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-11-2004, 06:24 PM   #1
housemusic42
Member
 
Registered: Dec 2003
Location: St. Louis
Distribution: redhat 9
Posts: 31

Rep: Reputation: 15
Send Mail, unknown mailer error 255


Greetings,

as i'm in my quest to invoke some fun scripts, i've run across and error that seems to go all directions. a search on this board yielded nothing so i thought i'd post the question to everyone.

Basically what i'm doing is getting PHP to read emails and submit them as they come along to a database. [refrence: Incoming Mail and PHP]
i've haven't gotten very far, just to the part where i see the mail come across the log, smrsh attempts to open the file but it says stat failed. I've tried a couple other things and now the error i run into states: unknown mailer error 255.

i googled it and some people's fix went as far as opening up send mail to run any program it wished.

i've sym'd my smrsh dir and have tried some other work arounds...now i'm stuck.

ideas anyone?
 
Old 03-12-2004, 11:09 AM   #2
housemusic42
Member
 
Registered: Dec 2003
Location: St. Louis
Distribution: redhat 9
Posts: 31

Original Poster
Rep: Reputation: 15
sorry, i should have posted a bit more info...

i'm running:

rh9 with a current kernel
send mail 8
apache 2.0
php4.0

i have all the configure options set as the article describes as far as cgi being complied and running as a seperate mod... I tried a different setup by removing some lines out of my alias file and now i'm getting that the (stat failed)...here's a look at the maillog:


Mar 12 10:00:22 MailServer sendmail[23526]: 2CG0Lxw023526: from=<Housemusic42@email.com>, size=700, class=0, nrcpts=1, msgid=<14A64316.051FBE48.230E1A13@email.com>, proto=ESMTP, daemon=MTA, relay=imo-m28.mx.email.com [64.2.137.9]
Mar 12 10:00:22 MailServer smrsh: uid 47: attempt to use "emailtester.php" (stat failed)
Mar 12 10:00:22 MailServer sendmail[23527]: 2CG0Lxw023526: to="|/home/testscript/emailtester.php", ctladdr=<testscript@emailaddress.com> (47/0), delay=00:00:01, xdelay=00:00:00, mailer=prog, pri=60977, dsn=5.0.0, stat=Service unavailable
Mar 12 10:00:22 MailServer sendmail[23527]: 2CG0Lxw023526: to=another@emailaddress.com, delay=00:00:01, xdelay=00:00:00, mailer=local, pri=60977, dsn=2.0.0, stat=Sent
Mar 12 10:00:22 MailServer sendmail[23527]: 2CG0Lxw023526: 2CG0Mxw023527: DSN: Service unavailable
Mar 12 10:00:22 MailServer sendmail[23527]: 2CG0Mxw023527: to=<Housemusic42@email.com>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=32001, relay=mailin-04.mx.email.com. [64.2.137.184], dsn=2.0.0, stat=Sent (OK)




i'm bangin my head here....
 
Old 03-12-2004, 12:09 PM   #3
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
What are the permissions for /home/testscript and /home/testscript/emailtester.php?
 
Old 03-12-2004, 01:03 PM   #4
housemusic42
Member
 
Registered: Dec 2003
Location: St. Louis
Distribution: redhat 9
Posts: 31

Original Poster
Rep: Reputation: 15
/home/testscript drwx------ 3 testscript testscript

/home/testscript/emailtester.php -rwxrwxrwx 1 testscript testscript


i moved the emailtester.php to the /etc/smrsh directory and the sendmail error went away. i don't understand why so i don't know... now i'm not getting anything submitted to the database nor can i find corresponding errors to tell me why it's not...


why did i sign up for this?...
 
Old 03-12-2004, 05:03 PM   #5
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Well your original problem was because the Sendmail process couldn't read your home directory. You need to set the permissions to 711 at least (shouldn't need 755). The script itself should be 755, not 777!!! You sure don't want anyone being able to rewrite the script.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Unknown error code 255" trying to burn CD with K3B 0.11.2cvs BertBert Linux - Software 0 03-12-2004 09:19 PM
Logs full of hits to 255.255.255.255; how to stop logging? mac_phil Mandriva 2 02-23-2004 11:25 AM
security breach: send mail to unknown address? graffitici Linux - Security 4 01-29-2004 06:27 PM
UDP broadcast 255.255.255.255 java8964 Linux - Networking 0 10-29-2003 03:05 PM
configuring RH 7 for a subnet mask of 255.255.255.224 CDPL Linux - Networking 2 04-20-2002 10:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration