LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   SCP and Telnet(127.0.0.1) Not Working (https://www.linuxquestions.org/questions/linux-networking-3/scp-and-telnet-127-0-0-1-not-working-909169/)

rajes4india 10-20-2011 10:15 AM

SCP and Telnet(127.0.0.1) Not Working
 
Hi geeks,
First Thanks for analyzing my problem.i am having 2 issues

1.SCP Not Working on my Linux Box (Fedora release 7 (Moonshine))to Fedora fc11.i686 running box.

please find my -v verbose output.

[root@RajesH switch1]# scp -v w rajeshkumarv@172.31.112.85:
Executing: program /usr/bin/ssh host 172.31.112.85, user rajeshkumarv, command scp -v -t .
OpenSSH_4.5p1, OpenSSL 0.9.8b 04 May 2006
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to 172.31.112.85 [172.31.112.85] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/identity type -1
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.2
debug1: match: OpenSSH_5.2 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.5
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '172.31.112.85' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:25
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Next authentication method: gssapi-with-mic
debug1: Unspecified GSS failure. Minor code may provide more information
No credentials cache found

debug1: Unspecified GSS failure. Minor code may provide more information
No credentials cache found

debug1: Unspecified GSS failure. Minor code may provide more information
No credentials cache found

debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/identity
debug1: Trying private key: /root/.ssh/id_rsa
debug1: Trying private key: /root/.ssh/id_dsa
debug1: Next authentication method: password
rajeshkumarv@172.31.112.85's password:
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
debug1: Sending command: scp -v -t .
Welcome rajeshkumarv to the World of Linux
[root@RajesH switch1]# debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: channel 0: free: client-session, nchannels 1
debug1: fd 0 clearing O_NONBLOCK
debug1: fd 1 clearing O_NONBLOCK
debug1: Transferred: stdin 0, stdout 0, stderr 0 bytes in 0.1 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 0.0
debug1: Exit status 0

====>Its getting hang with return 0 .

please note that -->SSH,FTP working fine.;)



2.My second issue is telnet for localhost (127.0.0.1) not working.

please look on my output while trying

:confused:
[root@localhost ~]# telnet 127.0.0.1
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused
[root@localhost ~]#

RPM output :banghead:
[root@localhost ~]# rpm -qa | grep -rin telnet
213:telnet-0.17-38.fc7
[root@localhost ~]#

is i want to install telnet server for this case ?:Pengy: or its inside the box .

please explain the concept of how to debug ?

Please not that Telnet to another machine working fine.

Thanks a lot
Rajesh Kumar V

rajes4india 10-24-2011 02:42 AM

Anybody Help me on this

XavierP 10-28-2011 10:32 AM

Moved: This thread is more suitable in Linux-Networking and has been moved accordingly to help your thread/question get the exposure it deserves.

rajes4india 10-31-2011 04:00 AM

Help Me on this please ?

rajes4india 11-09-2011 11:47 AM

Any one please help me on this ?

rajes4india 01-01-2012 11:44 PM

any suggestion pls

getdev 01-02-2012 05:29 AM

It seems your scp command ad work fine. The error you get in debug mode are on a try with an authentication method that is not supported.

If I'm right you want to copy local file "w" to server 172.31.112.85. But have you had a look if the file is there after your copy ? Can't you specify the path where you want to copy to be sure it is at the path like you want.

For telnet, have you install the server, did it work (the process is executing) ?

rajes4india 01-03-2012 05:23 AM

Quote:

Originally Posted by getdev (Post 4563654)
It seems your scp command ad work fine. The error you get in debug mode are on a try with an authentication method that is not supported.

If I'm right you want to copy local file "w" to server 172.31.112.85. But have you had a look if the file is there after your copy ? Can't you specify the path where you want to copy to be sure it is at the path like you want.

For telnet, have you install the server, did it work (the process is executing) ?

No,when i am scp from other machine to 172.31.112.85 its working fine.PS:from my machine to other machine also working fine.i dont know why it is not working for 172.31.112.85 alone.any idea.?

scp -v w rajeshkumarv@172.31.112.85: ==>File "w" will store in rajeshkumarv/ dir.no need to mention exact path.i guess this is not an issue.

getdev 01-04-2012 08:14 AM

I told you to specify the path because I already have had some troubles with environment variable HOME which were not been set.
So giving the path where you want to copy permit to be sure where it is. I'm OK with you it may not be an issue, but I ask you this to be sure it isn't.

agentbuzz 01-04-2012 08:39 AM

rajes4india,
Try this:
Code:

scp -v textfile rajeshkumarv@172.31.112.85:/home/rajeshkumarv/
As getdev said, your environment has to be set up properly, so use this as a test.

Also, do you have SELinux enabled? If you do, SSHD may not be allowed to write to "/home/rajeshkumarv". Use "sestatus" to check if SELinux is enabled or disabled and in enforcing or permissive mode.

If it's in enforcing mode, check your audit log.

Code:

grep sshd_t /var/log/audit/audit.log
Then, maybe create a module that you can install after inspecting it to see if you like it:

Code:

grep sshd_t /var/log/audit/audit.log | audit2allow -m sshd > sshd.te
Build the module:

semodule -i sshd.pp

Make sure it ends up here:

Code:

/etc/selinux/targeted/modules/active/modules/sshd.pp


All times are GMT -5. The time now is 01:49 AM.