LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-28-2005, 11:22 AM   #1
floog
Member
 
Registered: Oct 2004
Distribution: gentoo & slackware
Posts: 59

Rep: Reputation: 15
SBC DSL, Static IP's, and My Routerbox


Issue: Cannot ping primary/secondary nameservers and/or access any websites from the routerbox.

Background and Troubleshooting:

1. Not worried about LAN clients right now, just want to get routerbox connected to SBC ADSL. SBC tech. support will not discuss anything related to linux.

2. I have a series of static IP's:

*.128 - *.135

SBC indicated that *.134 is the Gateway IP, and *.135 is Broadcast IP. For now, all I can confirm is that when I connect a commercial router product like a Linksys or Netgear dsl router, the only IP address I see is *.134, and the IP is functional and provides access to the web.

3. I have tried several different ways to connect eth0 on the gentoo routerbox to my ADSL modem to connect to the internet:

a) Set /etc/conf.d/net to ifconfig_eth0="*.134 broadcast *.134 netmask 255.255.255.0". This fails. Ping results: Destination Host Unreachable.

b) Same as a) but changed the netmask to 255.255.255.248 -- saw this in some notes I took in a tech. support call I previously made to SBC. This failed too. Ping results: Destination Host Unreachable.

c) Took the routerbox to another working internet connection and emerged roaring penguin pppoe software to give that a try -- SBC tech. support confirmed the connection protocol is pppoe.

d) Ran the rp-pppoe setup script, plugging in the Account ID, Password, Static IP *.134, Primary DNS, Secondary DNS, etc. I run adsl-start and rp-pppoe says the routerbox is "Connected!"; however, all pings to DNS nameservers fail. Ping results: Destination Host Unreachable. I tried changing the MTU settings for eth0 to 1492, then 1460, then 1452. All attempts fail.

There are no issues with the routerbox --- I used the onboard 10/100 port to install gentoo over the net and everything worked fine using the via_rhine module.

Desperate Request and Conclusion:

I am open to any/all suggestions regarding how to successfully connect a linux router to an adsl modem on an account using Static IP addresses.

Thank you for reading the long post. Apologies for alot of chatter, just trying to show I've been organized and methodical in my attempts.

Thanks,

Mike
 
Old 04-28-2005, 11:53 AM   #2
cowanrl
Member
 
Registered: Dec 2004
Location: Western Pennsylvania, USA
Distribution: Red Hat
Posts: 150

Rep: Reputation: 15
What are setting up as the default gateway on the Linux box? Somehow, you need a default gateway so it knows where to send packets that aren't on the same IP subnet.
To see what default gateway is set on the Linux box, execute route -n. Post the results here.
 
Old 04-28-2005, 12:59 PM   #3
floog
Member
 
Registered: Oct 2004
Distribution: gentoo & slackware
Posts: 59

Original Poster
Rep: Reputation: 15
Hi Cowan,

Always good to see you around the boards.
Thanks for your reply.

Okay, right now I can't post the route -n results because I can't shutdown the network to re-install this new routerbox for testing. I have a bunch of people here in the office using the internet all day for work.

I set the eth0 IP address, gateway address, and broadcast address, all to *.134. My instincts tell me this setup isn't right, but it seemed like there's no other way. All data in/out of the LAN's that are going to be local subnets from static ip on eth0. I couldn't see setting up eth0 with and ip address of *.128, a gateway address of *.134, and then a broadcast address of *.135. Can you actually designate 3 different ip's to one NIC like so?

Thanks again for taking the time to help.

Mike
 
Old 04-28-2005, 01:03 PM   #4
floog
Member
 
Registered: Oct 2004
Distribution: gentoo & slackware
Posts: 59

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by floog

All data in/out of the LAN's that are going to be local subnets from static ip on eth0.

Mike
errr...........this should have said:

All data going in/out of the LAN will be from the two local subnets that will branch off from eth1 and eth2.

lack of sleep, sorry.

mike
 
Old 04-28-2005, 04:46 PM   #5
cowanrl
Member
 
Registered: Dec 2004
Location: Western Pennsylvania, USA
Distribution: Red Hat
Posts: 150

Rep: Reputation: 15
In an IP address range of 128-135, more than likely 128 would be the network address so you couldn't assign it to a host. There are only 6 useable addresses, 129-134.

Maybe you should use IP addresses between 129-133 and assign 134 as the default gateway. Maybe 134 is actually being used on their end. That's usually not the way it works though.

Is there any way you can get IP information from whatever device you are using now? Info such as IP address, netmask and gateway. That would sure help a lot.
 
Old 04-28-2005, 05:05 PM   #6
floog
Member
 
Registered: Oct 2004
Distribution: gentoo & slackware
Posts: 59

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by cowanrl
Is there any way you can get IP information from whatever device you are using now? Info such as IP address, netmask and gateway. That would sure help a lot.
Okay, this is reported from the commercial Netgear DSL Router currently in use (I've fictionalized the IP address):

WAN Port :
IP Address : 111.111.111.134 DHCP : None
IP Subnet Mask : 255.255.255.255

LAN Port :
IP Address : 192.168.0.1 DHCP : Server
IP Subnet Mask : 255.255.255.0

-----------------
Looks like the WAN port is using .134 as the IP address.


Mike
 
Old 04-29-2005, 06:59 AM   #7
cowanrl
Member
 
Registered: Dec 2004
Location: Western Pennsylvania, USA
Distribution: Red Hat
Posts: 150

Rep: Reputation: 15
I take it that you have statically assigned the WAN port an address of .134? Since SBC said you had a range of IP addresses from 128-135, did you try assigning the WAN port an address other than .134? Is there anywhere in the Netgear router you had to assign a default gateway?
 
Old 05-03-2005, 04:57 PM   #8
floog
Member
 
Registered: Oct 2004
Distribution: gentoo & slackware
Posts: 59

Original Poster
Rep: Reputation: 15
SOLVED.
STABLE CONNECTION ACHIEVED.
ROUTING ESTABLISHED.
FIREWALL ESTABLISHED.

Well I finally got the linux box working alone (with no Netgear in front of it). It's working which makes May feel like Christmas, but it's kinda weird if you ask me.

Check it out-----

Here's the final report for anyone that comes after me and might benefit from my trials and errors.

# /etc/conf.d/net:
$Header: /home/cvsroot/gentoo-src/rc-scripts/etc/conf.d/net,v 1.7 2002/11/18 19:39:22 azarah Exp $
# Global config file for net.* rc-scripts

# This is basically the ifconfig argument without the ifconfig $iface
#
# ADDRESS 111.111.111.134 IS WHAT SBC STATED AS THE
# "GATEWAY" ADDRESS FOR ALL MY STATIC IP'S.
# THE NETMASK WAS ALSO STATED BY SBC, AS USED IN
# EXAMPLE HERE.

iface_eth0="111.111.111.134 broadcast 111.111.111.134 netmask 255.255.255.248"
iface_eth1="199.199.169.1 broadcast 199.199.169.255 netmask 255.255.255.0"
iface_eth2="199.199.170.1 broadcast 199.199.170.255 netmask 255.255.255.0"

# I WAS ABLE TO GET THIS "ADSL" SETUP TO WORK TOO.
# BUT I WANTED TO FILL IN THE STATIC VALUES IN ORDER
# TO MAKE NETMOUNT WORK PROPERLY UPON BOOTING GENTOO.
#
#ifconfig_eth0="adsl"
#

# For setting the default gateway
#
gateway="eth0/111.111.111.1"
_________________

I don't know why using 111.111.111.1 works, as it is definitely NOT in my block of static ip's: *.128 - *.135
But certainly try it in your setup; it is working for me.

The following to be used in conjunction with rp-pppoe software -
/etc/ppp/pppoe.conf:

ETH='eth0'

USER='full_username@sbcglobal.net'

DEMAND=no

# YOU COULD PROBABLY SET DNS MANUALLY TOO.
# HAVEN'T TRIED IT YET.
DNSTYPE=SERVER

PEERDNS=no

# Make the PPPoE connection your default route. Set to
# DEFAULTROUTE=no if you don't want this.
DEFAULTROUTE=yes

# - If you have a computer acting as a gateway for a LAN, choose "1412".
# The setting of 1412 is safe for either setup, but uses slightly more
# CPU power.
CLAMPMSS=1412
____________________________

/etc/ppp/pap-secrets:
"full_username@sbcglobal.net" * "password"
_____________________________

While testing all of the above, make sure your iptables firewall is NOT running.
In Gentoo, as root: /etc/init.d/iptables stop

If you are using eth0 as your WAN device (internet-facing NIC for routers), then you must change every mention of "eth0" in your iptables firewall to "ppp0". Once the rp-pppoe software is started, the connected NIC becomes ppp0 and takes the static ip address you placed in /etc/conf.d/net.
________________________________

To finish off, I put the command /usr/sbin/adsl-start into /etc/conf.d/local.start, so the routerbox boots, NIC modules get loaded, NIC devices are assigned ip addresses, firewall starts, ip forwarding starts, and finally the dsl connection is commenced with the adsl-start command.

_______________________________
Now that I've had a little time to take some looks at the connection, I do find this pppoe system a little strange.

The results of route -n:
Code:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
204.60.4.34 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
111.111.111.128 0.0.0.0 255.255.255.248 U 0 0 0 eth0
199.199.170.0 0.0.0.0 255.255.255.0 U 0 0 0 eth2
199.199.169.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
127.0.0.0 127.0.0.1 255.0.0.0 UG 0 0 0 lo
0.0.0.0 204.60.4.34 0.0.0.0 UG 0 0 0 ppp0

The "Destination" and "Gateway" for my ppp0 device are now set at 204.60.4.34. A super-cool fella over in the http://www.dslreports.com forums made it clear that this address represents the next hop up the ISP chain of routers.

Here's the results of ifconfig:

ppp0
Link encap:Point-to-Point Protocol
inet addr:111.111.111.134 P-t-P:204.60.4.34 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:764708 errors:0 dropped:0 overruns:0 frame:0
TX packets:758450 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:137166037 (130.8 Mb) TX bytes:51826617 (49.4 Mb)

eth0
Link encap:Ethernet HWaddr 00:11:3P:A9:G3:37
inet addr:111.111.111.134 Bcast:111.111.111.134 Mask:255.255.255.248
Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:766749 errors:0 dropped:0 overruns:0 frame:0
TX packets:760509 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:154116739 (146.9 Mb) TX bytes:68584026 (65.4 Mb)
Interrupt:11 Base address:0xe000

So the only mind-bending questions left are why does eth0 get switched to *.128 when I have manually set it to *.134, and why does setting eth0 gateway to *.1 work even though it's not within my block of static ip's.

For now, it's just nice to have it working. I'll try to answer these questions later.

Peace,

Floog
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
static ip's with hub? heinola Linux - Networking 2 10-24-2005 10:17 PM
Sbc Dsl davesbedroom Linux - Networking 2 08-23-2005 09:12 PM
Configuring domain names on static IP addresses from SBC DSL redbasin Linux - Networking 4 02-10-2004 11:06 AM
can i have both dhcp and static ip's ? mjenkins Linux - Networking 1 09-22-2003 10:29 AM
Static Ip's and Routing Sarcha Linux - Networking 5 02-28-2003 09:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration