-   Linux - Networking (
-   -   Samba - Windows XP Problem (//Samba is not accessible) (

Covenent 08-28-2004 05:14 PM

Samba - Windows XP Problem (//Samba is not accessible)
I'm a newbie to Linux (just installed Fedora 2 a few days ago) so go easy on me. :)

I have a laptop with Windows XP Home on it, and a PC with Fedora 2 installed on it. They both have network cards and are connected via a crossover cable (the cable definitely works btw). The XP machines name is HAL and its workgroup is HOME, and the Fedora machines name is QUEEG. HAL's IP is and QUEEG's IP is, and both machines Subnet Mask are

For now I want to share the files between the two machines, and then later I hope to share my laptops wireless internet connection with the Fedora box via the crossover cable.

Samba is installed on my Fedora box, and I have gone through several tutorials on setting it up (e.g. samba netfirms guide). Now when I go to 'My Network Places' on the XP machine I can see my Samba server (its named "Samba 3.0.3-5 (Queeg)"), but when I try to access it I get the following error:


//Queeg is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you access permissions.

The network path was not found.
I have checked the file permissions in Fedora for the shares and they are set correctly. The XP user's name and password match those of the Samba user I created. I am not sure what the problem is. :confused:

QUEEG can ping HAL by IP and by name, where as HAL can ping QUEEG by IP but not by name - is this problem?

Thanks for any help, I have spent days searching for the answer and I desperatly need help. :scratch:

Netizen 08-28-2004 08:39 PM

How did you setup the samba user?

What are the file permissions on the share?

Did you add the user to the smbpasswd file?

It sounds as if you missed a step.

Covenent 08-30-2004 01:15 PM

Yup I did all of those 3 things. The tutorial I followed is the samba netfirms tutorial (1st google search result for "samba setup guide" - this forum won't allow me post a link due to my low post count).

I'm 99% certain that my problem is that the XP machine (HAL) can't ping my Fedora machine (QUEEG) by name. I know it's more of a Windows question, but would anyone know how I can tell XP to map QUEEG to In Fedora I can simply edit the /etc/hosts file to map a name to an IP but I don't know how to do this in Windows. I have searched several websites and Windows help for an answer but can't find one.

Any help is appreciated. :)

Covenent 09-02-2004 02:28 PM

My bad, I had to open up some ports on the firewall for it to work (I presumed when I installed Samba with Fedora this would be done automatically).

Thanks for the help,

Amir 09-06-2004 04:55 PM

What ports?
I have the same problem, can you post the syntax for opening the samba ports?


Nuclear_Kitten 09-08-2004 08:27 AM

net-bios ports 137, 139 AFAIK

careful tho' cos this can open you up to some pretty basic attacks if samba's on the same box as your firewall

kmfan 09-11-2004 03:37 PM

I have the same error while trying to access the Samba server from my Windows XP box. Same situation. I would like to open those ports but I am afraid I am a newbie and not sure how to do this in Linux. Red Hat 8.0 to be more percise. Could someone please help me out here.


aroop 09-11-2004 04:03 PM

The problem is most probably of the firewall. I had faced this problem in the past. If ipchains is running on the Linux machine, please add this line to /etc/sysconfig/iptables

-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 139 --syn -j ACCEPT

This will open port 139 to accept samba requests. This should work.

jbenz 09-16-2004 08:02 AM

Similar problem - please help
I have a problem similar to the one described above - also a relative newbie, lots of Unix experience, but I'm new to Fedora. I've been trying to set up Samba for days now, so my 2 XP machines on the same inhouse net can share filesystems. All three machines are connected to a NetGear router, which is itself connected via DSL to the outside. I have gotten one of the XP boxes to 'see' the Samba connection, but when I try to open the Samba, I get this:

//Mule is not accessible. You might not have permission to use this network resource. Contact the administrator of
this server to find out if you have access permissions.
Configuration information could not be read from the domain controller, either because the machine is unavailable, or
access has been denied.

The Fedora machine is Mule. The two XP machines can talk to each other just fine. The machines can ping each other. The XP machine can see the Samba server, it just can't open it. From the error, I suspect the problem is in the router (domain controller???) but I'm not as familiar with network terminology as I'd like to be. Can anyone point me in the direction I need to go? All the many reams of documentation I've read haven't helped.

captain-cat 09-16-2004 01:56 PM

greetings, this topic has been discussed quite a bit in this forum as well as in fedora forum. from what i have read u need to give access udp to ports 137 and 138 and tcp to 139 and 445 (which is the default windows port).

jbenz 09-16-2004 02:46 PM

Thanks for answering so quickly - but could you be a bit more specific? I'm not at all sure what you mean by giving access to ports... how does one go about doing this? I've looked into /etc/services at the configs for the ports you mention, and I see:

netbios-ns 137/udp
netbios-ns 137/tcp
netbios-dgm 138/udp
netbios-dgm 138/tcp

microsoft-ds 445/udp
micorsoft-ds 445/tcp

Thanks again

captain-cat 09-16-2004 03:24 PM

yup thats correct, u also need 139. 137-139 are the netbios ports for win2000/98 etc. 445 is for xp. check the following thread:

alternatively use firestarter which a gui firewall.

dont knwo what distro u are using but it may have yum or apt installed. for yum just type as su
yum install firestarter

ootherwise just google firestarter

run firestarter as root and select public access to samba.

jbenz 09-21-2004 04:25 PM

Hmmm.... Having installed firestarter, and run it through the wizard... and enabling SMB and a bunch of other things through the wizard - the Windows XP *still* can't see the shared directories on the Linux machine. I'm getting a bit frustrated here. Is there perhaps something on the Windows side I have to do, to get this to work? All I want is for the XP machine to be able to use the Samba exported path as a 'map network drive', and for the Linux machine to be able to 'see' the exported paths from the XP machine. Firestarter is quite nice, by the way, it got me a lot further than I was before, but... still not able to do what I want.


trebek 05-07-2006 02:06 AM

Better get used to Samba not working man. I managed to get it to work at work using FC4 and windows 2000. But here at home, i got it to work once and that's it.

So far, i can see the computer and the shared folder but it tells me i don't have permissions. Here's my smb.conf file:
workgroup = MYGROUP
netbios name = laptop
server string = st_laptop
security = share
hosts allow =

comment = SharedInfo
path = /home/punisher/Shares
read only = No
guest ok = Yes
public = yes

Simple huh? Doesn't work.

I cleaned the hosts.allow and hosts.deny files, because according to all the trashy tutorials, if you don't put anything there, access is allowed for everyone. Now, I did the port thing on the iptables file, restarted smb and network services, still doesn't work. I uninstalled and reinstalled samba (thing i thought i would never had to do with Linux), didn't work. I tried configuring with SWAT, didn't work. I disabled the firewall on linux under 'System Settings>Security Level', still doesn't work.

In other words, i am either too stupid or the tutorials aren't telling us something. I had to share the CDROM on my brother's XP box to copy some files to this new computer because SAMBA decided not to work.

Btw, haven't you noticed that every single linux application manual tells like %80 of what you have to do, and let's you figure out the rest for yourself? This is not good because i need linux to work, not spend 3 weeks researching and be sitting on my behind wasting time.

Shawnmav 05-09-2006 12:47 PM

I am a very novice user of Linux and was attempting to configure a setup at work and having the same problem between an XP laptop and a SUSE linux machine. I could see the computer and the shared drives but would get the error "//[folder name] is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions"

I found the problem was caused when in the Create Shared Directory in the SWAT program I was using the / in front of the directory name. (I.E. /Filename). When I created the next directory and dropped the / I no longer had any issues. The path option, found after the directory has been created, should be the only place that you use the / to direct it to the correct directory

I agree with the statement that Linux is about 80% how to and 20% of your on your own, that actually may be a little generous I think it's more like 60/40.

All times are GMT -5. The time now is 08:42 AM.