-   Linux - Networking (
-   -   Samba win9x niggles (

acid_kewpie 08-27-2001 06:18 PM

Samba win9x niggles
Hi, can someone shed some light on my samba problem.

I can mount samba shares perfectly under win98, and i can rename, delete, move files on the share. My problems arise when i want to copy files onto it like in file manager or such like. I always get an error of 'access denied... make sure it is not write protected....yada yada yada'. BUT i CAN rip mp3's, save *most* files directly to it without a problem. Photoshop doesn't complain, but Word does....

any ideas?

the directory on the remote system is fully writeable...

"drwxrwxrwx 217 root root 32768 Aug 28 00:09 mp3"

and the bit in smb.conf...

comment = Da Choons!
path = /mp3
writeable = yes

erm.. what else... share level rights, all users mapped to root (i know it's bad officially.. but it's really not an issue!)

Can't think of anything else relevant... so any ideas?

drjimstuckinwin 08-27-2001 06:32 PM

I had similar problems. Turned out that I'd forgotten to officially add my linux user account to the samba users. The windoze accounts worked fine, but I forgot that the account on the linux box was slightly different. I tried to use linneighborhood (US spelling) and kept getting password probs. It was only when I installed RH7 on my laptop and tried to access my shares that I figured it.

acid_kewpie 08-28-2001 05:15 AM

Nope... no joy.

The problem seems to be because it's a vfat drive i'm trying to share, as the equivalent rights in smb.conf let me access ext2 shares perfectly.

But i've done everything i can think of, and have foudn out, to make the drive writeable.

I thought it worked fine from linux, but actually it's just the same.
ls -l from a remote machine to the mounted share gives rights of drwxr-xr-x for EVERYTHING includeing the directory itself.

i also chaged my fstab on teh remote machine to..
/dev/hdb1 /mp3 vfat defaults,uid=0,gid=0,umask=000 0 0

but the drive works fine locally, and also by remote linux access... it's just copying files to it (and *SOME* (!!) save operations) from win98 that dont work... ARGH!
but the rights change via samba...

drjimstuckinwin 08-28-2001 04:08 PM

Look in your smb.conf there's an entry for create mask, or create directory mask. Set this to the 0777 and see what gives.

acid_kewpie 08-28-2001 04:44 PM


well the masks were already set to 0777

'force directory mask' and 'force create mask' had no effect. 'inherit permissions' didn't seem that interested either.

the mask don't seem to affect anything, setting it to 0000 doesn't change anything! still stuck in the default mode 0755

nrgggggg!! Is there nothing sitting on top of this that is preventing it changing them? Like i said before they're set to 777 on the local machine...

10 minutes later.....
hmmm yeah there was somethign sitting on them, the options in /etc/fstab as far as linux was concerned. OK, so now under linux i can copy any file to the share as any user. the same problem still occurs under windows... so i presume this means that my smb.conf must be ok if linux likes it now. But copying to ext2 works perfectly.... I also can't copy to the shared directory when it is simply mounted as a sub dir in a share of teh eintire system...

/ <--shared ext2
--- home
--- mp3 <-- shared vfat
-- public

but the directory has umask 777!! argh! Maybe i should stop repeating myself.

All times are GMT -5. The time now is 02:00 PM.