LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Samba: W2K client OK, XP client hangs (https://www.linuxquestions.org/questions/linux-networking-3/samba-w2k-client-ok-xp-client-hangs-215256/)

Tim Green 08-09-2004 02:46 AM

Samba: W2K client OK, XP client hangs
 
I've just set up a Debian-based system as a VDR (Klaus Schmiedinger's Video Disk Recorder) and I'm having trouble accessing it from XP clients via Samba. Windows 2000 clients can access the system on the same network without any problems, but when I access xvdr (the Linux VDR box) from an XP client the following happens:

1) Enter user name and password: OK
2) Display shares: OK
3) Access a share: Explorer hangs permanently with an hourglass, so badly that the only solution is to log off and reboot XP.

My smb.conf file is pretty basic. I've turned off wins and local master because I don't want the VDR box to ever be the browse master on this network. Just to be sure, however, I switched them on for a while but got the same results. I also tried switching from user to share security but also no cigar.

When I look at the log for the access attempts from XP all I get is this message (from the client obiwanxp):

obiwanxp (192.168.0.103) couldn't find service obiwanxp

I know that some of the recent XP patches (I've installed everything up to date) had networking relevance. Is it possible that something has changed in XP's network behavior with relevance to Samba so that configuration changes are necessary? I had a similar system running a few months ago and had no problems accessing it from XP clients then.

Here's the current smb.conf:

Code:

[global]
workgroup = FRAME37
server string = %h server
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
netbios name = xvdr
encrypt passwords = yes
security = user
socket options = TCP_NODELAY
local master = no
wins support = no

[homes]
read only = yes
browseable = no

[video]
path = /video
comment = VDR Video Directory
read only = no
browseable = yes
create mask = 0775
directory mask = 0775


Thoreau 08-09-2004 03:15 AM

Make sure you are using the newest Samba client. Make sure windows XP has Netbios over TCP/IP enabled. By default, it does not in network settings.

Tim Green 08-09-2004 03:39 AM

Quote:

Originally posted by Thoreau
Make sure you are using the newest Samba client. Make sure windows XP has Netbios over TCP/IP enabled. By default, it does not in network settings.
Thanks, but it's not the netbios. The computers are connected via an SMC Barricade 7008ABR router that assigns parameters automatically per DHCP and activates Netbios over TCP/IP when relevant. I experimented with activating Netbios over TCP/IP manually but it didn't make any difference, same problem as before, and the W2K box still has no problems accessing the Linux box...

I just checked the Samba version and it's 2.2.3a-13, which apt-get reports as the newest version with the sources list provided with the VDR package -- is it possible that that's still the problem with XP?

Tim Green 08-09-2004 09:02 AM

SOLVED: The problem is caused by the webclient service, which is enabled by default in XP. If you disable it the problem goes away... ;))

Thoreau 08-10-2004 01:55 AM

That's good to know. I think this is the first time I've learned something in a week.


All times are GMT -5. The time now is 06:39 AM.