LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-12-2004, 06:42 AM   #1
gottin
Member
 
Registered: May 2004
Location: Sofia / Bulgaria
Distribution: Fedora Core 5
Posts: 38

Rep: Reputation: 15
Exclamation samba through pppoe problem


hi U all, since more than week I'm testing and reading about samba. However there's still one problem which I can't solve. First I'll introduce my network.

WinXP ip 10.10.4.44 on pppoe gateway 10.10.0.1
Fedora1 ip 10.10.4.45 on eth1
on the Linux: route add -net 10.10.0.0 gw 10.10.0.1

#tracert 10.10.4.45
1. 10.10.0.1
2. 10.10.4.45
----------
| Win XP |
----------
10.10.4.44
|
|
---------- -----------------------------
| switch |<--->10.10.0.1| PPPoE server Concentrator |
---------- -----------------------------
|
|
10.10.4.45
----------------
| Samba Server |
----------------

#traceroute 10.10.4.44
1. 10.10.0.1
2. 10.10.4.44

Betweeb the Win box and 10.10.0.1 there's a pppoe connection.

smb.conf
[global]
workgroup = ATLANTIS
netbios name = server
encrypt passwords = yes
interfaces = eth*
wins support = yes
prefered master = yes
local master = yes
remote announce = 10.10.4.255/ATLANTIS

All firewall rules on the PPPoE server are disabled.
The problem is that with this scenario on the Win XP I can't see the samba server. If I set an static ip addr on Win XP on the same subnet with SambaS. - no problems, but trying it through the PPPoE conection -> nothing. The idea is that I want only authenticated users to use my Samba Server.

Please Help me or give me an idea how to achieve my goals. 10x
 
Old 07-12-2004, 10:20 AM   #2
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,556

Rep: Reputation: 659Reputation: 659Reputation: 659Reputation: 659Reputation: 659Reputation: 659
After looking at your post, there are two issues I see. First of all, the routing. You did not say what sub-net mask you are using. 10. is a class A private networking IP address. The last three bytes are host address unless you use a mask to specify other than 255.0.0.0. Have you checked all IP interfaces are using the same mask? What is your mask?

The second issue you raise is authentication. As I see it that has little to do with the routing. So to make along story short, why not have them all on the same sub-net? Only reason I can think of is you have too many machines for say a private 192.168 class c network. Not sure at all if that is the case, ( you mention just 2 ) just a thought. Authentication is looked after by the Samba server. You are using encrypted passwords, and you have to setup the users. I used SWAT, that was the easy way.

Are you concerned with security form outside connections on the 10.10.0.1 side?
 
Old 07-12-2004, 11:21 AM   #3
gottin
Member
 
Registered: May 2004
Location: Sofia / Bulgaria
Distribution: Fedora Core 5
Posts: 38

Original Poster
Rep: Reputation: 15
well, all the masks are 255.255.0.0
It isn't only one user. There's more users and the idea is to share a ftp server files and the authenticated users who use windows to be able to watch the Movies and listen to the mp3s without downloading it. There will have only one user and pass for all of them to connect to the samba server. All the users has other passwords for connecting to the PPPOE server.

my current smb.conf is:

[global]
workgroup = FREE
netbios name = FREE2
server string = server
encrypt passwords = yes
read only = yes
security = user
socket options = TCP_NODELAY IPTOS_LOWDELAY
guest account = free
allow hosts = 10.10.
os level = 1
interfaces = 10.10.10.10/16 10.20.0.2/16 127.0.0.1
remote announce = 192.168.2.255/OFFICE 10.20.255.255/Workgroup
remote browse sync = 10.20.0.1


the addresses from 10.20.255.255 are given to the users by an DHCP server (10.20.0.1 is a Local/Domain Master Browser). I want only users who's connected (and reseived address like 10.10.*.* ) to be able to use the samba server. In the above config if I add 10.20. to the the 'allow hosts' I have everithing I want. , but as soon as I again try with allow hosts = 10.10. (without 10.20.) -> again no access to the machine. I just see it's workgroup, but can't access it.
 
Old 07-13-2004, 01:42 AM   #4
gottin
Member
 
Registered: May 2004
Location: Sofia / Bulgaria
Distribution: Fedora Core 5
Posts: 38

Original Poster
Rep: Reputation: 15
isn't there somebody to help

I think that I found the problem but still can't solve it. It's that windows machines use only their primary ip address to browse the LAN. However, when they connect with their account on the PPPOE server it's there second ip address that they receive and can't browse the LAN with it (only with their DHCP ip address).

Is there an issue for this problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PPPoE problem. hmtbooster Slackware 1 11-21-2005 04:23 PM
PPPoE problem satimis Linux From Scratch 2 09-04-2005 10:02 PM
PPPoE Serious Problem Fordor Linux - Networking 0 07-14-2005 02:31 AM
pppoe problem morrisset Linux - Networking 14 06-05-2004 05:39 PM
adsl-status can't read pppoe PID file with rp-pppoe program setup Smarvy Linux - Newbie 2 03-13-2004 11:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration