LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-04-2003, 12:47 PM   #1
mdkelly069
Member
 
Registered: Oct 2003
Posts: 43

Rep: Reputation: 15
Samba server only reachable by IP address, not showing in Network Neighbourhood


I have a recent install, yesterday, of Samba 3.0.0 on RH9 and there is only one system in my office, the one at my desk ofcourse, that the samba server shows in Network Neighbourhood. The server is reachable from others by typing the IP address into the Map Network Drive dialog box, and from then works as expected. Any ideas?

Also, I am trying set up a share on the same server that a user does not have to type in a user or password, basically all people can access the same share with full read/write, just like a "Guest" account on Windows. I know this is a bad idea in terms of security, but we are behind a firewall and I am still in the process of convincing my boss that we should change this scheme.

All systems trying to connect are running Win2000 Pro

Thanks for any help

mdkelly
 
Old 11-04-2003, 01:13 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
For the name problem check to see if you have any firewall rules blocking ports 137&138 UDP and that nmbd is running. Post the output of this if you are unsure:
iptables -L
netstat -nlp

For a public share just put this in your share definition:
public = yes
 
Old 11-04-2003, 01:25 PM   #3
Sohni
Member
 
Registered: Sep 2003
Location: Planet Earth
Distribution: SuSE Linux 9.0
Posts: 83

Rep: Reputation: 15
Doesn't W2K use DNS even for local network name resolution, does it? So you'll need an internal DNS server for proper name resolution. (may be not).

You can still resolve the problem manually. Just add your Samba host to W2K hosts file - c:\winnt\system32\drivers\etc\hosts. Then everyone finds your Samba server by host name.
 
Old 11-04-2003, 02:46 PM   #4
mdkelly069
Member
 
Registered: Oct 2003
Posts: 43

Original Poster
Rep: Reputation: 15
Thanks for the replies

Here is the output of iptables -L

[root@localhost root]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Here is the output of netstat -nlp

[root@localhost root]# netstat -nlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Progr
am name
tcp 0 0 0.0.0.0:32768 0.0.0.0:* LISTEN 1601/rpc.
statd
tcp 0 0 127.0.0.1:32769 0.0.0.0:* LISTEN 1719/xine
td
tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN 2513/smbd

tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1582/port
map
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN 1895/X

tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1705/sshd

tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 1748/cups
d
tcp 0 0 0.0.0.0:445 0.0.0.0:* LISTEN 2513/smbd

udp 0 0 0.0.0.0:32769 0.0.0.0:* 1601/rpc.
statd
udp 0 0 192.168.0.197:137 0.0.0.0:* 2515/nmbd

udp 0 0 0.0.0.0:137 0.0.0.0:* 2515/nmbd

udp 0 0 192.168.0.197:138 0.0.0.0:* 2515/nmbd

udp 0 0 0.0.0.0:138 0.0.0.0:* 2515/nmbd

udp 0 0 0.0.0.0:929 0.0.0.0:* 1601/rpc.
statd
udp 0 0 127.0.0.1:32935 0.0.0.0:* 2516/smbd

udp 0 0 0.0.0.0:111 0.0.0.0:* 1582/port
map
udp 0 0 0.0.0.0:631 0.0.0.0:* 1748/cups
d
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node PID/Program name Path
unix 2 [ ACC ] STREAM LISTENING 2135 1728/gpm /dev/gpmctl
unix 2 [ ACC ] STREAM LISTENING 3379 2060/gconfd-2 /tmp/orbit-r oot/linc-80c-0-71aecbd12b601
unix 2 [ ACC ] STREAM LISTENING 3218 2035/kdeinit: ksmse /tmp/.ICE-un ix/2035
unix 2 [ ACC ] STREAM LISTENING 3395 2056/eggcups /tmp/orbit-r oot/linc-808-0-3d05859b8f99
unix 2 [ ACC ] STREAM LISTENING 3487 2055/python /tmp/orbit-r oot/linc-807-0-1e1971e1af025
unix 2 [ ACC ] STREAM LISTENING 2246 1807/xfs /tmp/.font-u nix/fs7100
unix 2 [ ACC ] STREAM LISTENING 2385 1895/X /tmp/.X11-un ix/X0
unix 2 [ ACC ] STREAM LISTENING 2485 1964/ssh-agent /tmp/ssh-XXr 4fimK/agent.1906
unix 2 [ ACC ] STREAM LISTENING 2375 1851/gdm-binary /tmp/.gdm_so cket
unix 2 [ ACC ] STREAM LISTENING 2909 2003/kdeinit: Runni /tmp/ksocket -root/kdeinit-:0
unix 2 [ ACC ] STREAM LISTENING 2913 2006/kdeinit: dcops /tmp/.ICE-un ix/dcop2006-1067963161
unix 2 [ ACC ] STREAM LISTENING 2936 2009/kdeinit: klaun /tmp/ksocket -root/klauncherrSBEda.slave-socket
unix 2 [ ACC ] STREAM LISTENING 3035 2023/artsd /tmp/mcop-ro ot/localhost_localdomain-07e7-3fa7d326


I ran into the iptables issue yesterday and solved it by killing the service. It is not needed as the machine will (is) behind a firewall.

To me it appears that ports 137&138 are open. Really not sure what is going on since the one machine that sees the server in Network Neighbourhood took no coaxing whatsoever, it was just there.

I tried the public=yes but it stills asks for a password. I will post my conf file later if needed.

thanks again for the help
mdkelly

I added the server name to the hosts file and the server is now accessible through its name when I go through the Map Network Drive dialog box, It still does not appear in Network Neighbourhood

Last edited by mdkelly069; 11-04-2003 at 02:50 PM.
 
Old 11-04-2003, 03:03 PM   #5
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
Can you post smb.conf - all the services look ok.
 
Old 11-04-2003, 03:27 PM   #6
mdkelly069
Member
 
Registered: Oct 2003
Posts: 43

Original Poster
Rep: Reputation: 15
Sure I can. I stripped out the lines that I was not using. I started with the example .conf file that came with samba 3.0.0

[global]

netbios name = server2
workgroup = KOMEX
server string = Samba Server
security = user
hosts allow = 192.168.0. 127.0.0.1
log file = /usr/samba/var/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no
ldap ssl = no
encrypt passwords = yes

#============================ Share Definitions ==============================

;[public]
; path = /mnt/win_data
; public = yes
; only guest = yes
; writable = yes
; printable = no


;[server]
; comment = File Server
; path = /mnt/win_data/server
; valid users = victoria
; guest ok = no
; writeable = yes
; create mode = 0666
; directory mode = 0777

[testserver]
comment = testing
path = /mnt/win_data/server
browseable = yes
public = yes
writable = yes

The only firewall in the office is our proxy/firewall that leads out to the net and it should have no effect on the file server as it comes nowhere near it

Thanks a lot for looking at it
 
Old 11-04-2003, 03:32 PM   #7
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
It sounds like your master browser isn't picking up the machine - try making linux become the master browser - add this to the global section:
local master = yes
os level = 65
preferred master = yes

Then restart the samba services - give it a minute or two to kick in.
 
Old 11-04-2003, 04:52 PM   #8
Neo23x0
LQ Newbie
 
Registered: Nov 2003
Posts: 1

Rep: Reputation: 0
services running

is the nmb running?

search in init-scripts

after changing the smb.conf, restart them

for my SUSE 8.2

/etc/rc.d/nmb restart
/etc/rc.d/smb restart
(^as root)

CYA
 
Old 11-04-2003, 05:08 PM   #9
mdkelly069
Member
 
Registered: Oct 2003
Posts: 43

Original Poster
Rep: Reputation: 15
Hi all,

Tried the changes to the smb.conf file, actually I changed them about an hour ago, and there is still no difference.

I restarted both smbd and nmbd and let everything just sit, no change. All machines I have sat down at will still allow me to connect when I map a drive and use the IP address. The only machine that sees the server in Network Neighbourhood is still the machine sitting on my desk. Basically there is no change whatsoever.

Thank you all for your suggetions and I hope you have more as I really need to get this sorted out.

Cheers
mdkelly

The other thing is that my share "testserver" as listed above in my .conf file is not allowing "guest" access, it is still requiring a username and password.

Thanks again

Last edited by mdkelly069; 11-04-2003 at 05:18 PM.
 
Old 11-04-2003, 06:06 PM   #10
zaphodiv
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
>Doesn't W2K use DNS even for local network name resolution, does it?
AFAIK it uses both domain names and NETBIOS names. Network
neighbourhood shows NETBIOS names.

>So you'll need an internal DNS server for proper name resolution.
No, lots of places use windows networking without an internet nameserver
or with one that only resolves internet addresses not the addresses of LAN machines.

>You can still resolve the problem manually. Just add your Samba host >to W2K hosts file - c:\winnt\system32\drivers\etc\hosts. Then everyone >finds your Samba server by host name.

Or in the lmhosts.sam file which provides fixed mapping of NETBIOS names.

Regarding the problem of the machine not appearing in network
neighborhood, are all the machines in the same ip subnet?
They are probably doing NETBIOS over tcp so if they are using different broadcast addresses they may not find each other.
 
Old 11-04-2003, 06:08 PM   #11
mdkelly
LQ Newbie
 
Registered: Jan 2003
Posts: 15

Rep: Reputation: 0
The Latest,

Well I have made it worse. On the only machine that could see the server in Network Neighbourhood I decided to change the login so it matched a username I had as a samba user. Well as soon as I did that and restarted, the Samba server was no longer visible, but, I was able to log right in to share I has set up without having to enter a username and password.

I guess you have to take 2 steps back to take one forward

Going to go play more and see what happens, maybe three steps back

Cheers

Last edited by mdkelly; 11-04-2003 at 06:27 PM.
 
Old 11-04-2003, 07:20 PM   #12
mdkelly069
Member
 
Registered: Oct 2003
Posts: 43

Original Poster
Rep: Reputation: 15
Okay here is the latest:

If I go into Win Explorer and in the address bar I type
\\192.168.0.197\ (server IP)

I get the server share in the left hand pane, but it is showing the server as part of the workgroup "Unknown". However, on the one machine that does see it it is part of the correct workgroup "Komex"

Also, and probably a big one, the internal network uses the IPX/SPX protocol and, please correct me if I am wrong, Samba uses NetBIOS over TCP/IP.

zaphodiv:

As far as I now all the machines are using the same IP subnet 255.255.255.0. I only say as far as I know because the only ones I can say for sure are the ones I have looked at in the last couple of days. Some users may have changed theirs, but I doubt it very much.

That is all for now
Thanks again
mdkelly
 
Old 11-05-2003, 11:06 AM   #13
mdkelly
LQ Newbie
 
Registered: Jan 2003
Posts: 15

Rep: Reputation: 0
Okay morning update:

I, and a co-worker, discovered this morning that the reason none of the machines, except the one I work at, could see the Samba server was that in Internet Protocol (TCP/IP) >> Properties >> Advanced >> Wins >> NetBIOS over TCP/IP had been disabled. Once I re-enabled it on a couple of machines the server popped right up and my test shares were accessible.


I'm sure I will be back soon with more issues

Thanks for your help
mdkelly
 
Old 11-09-2003, 08:43 PM   #14
scorpatron
Member
 
Registered: Nov 2003
Location: New Zealand
Distribution: Redhat 9 2.4.20-8 Athlon, Windows 2000 Professional, FreeBSD
Posts: 122

Rep: Reputation: 15
Ok, that didn't help me....

Basiacally I'm using SWAT, and both services are running, I can even login to it using smbclient... weird huh?

As far as I know SAMBA is working, cept NONE of the windows clients see any new domains

By the way, we use a domain at my office

Thanks in advance
 
Old 11-10-2003, 08:41 AM   #15
zaphodiv
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
>NONE of the windows clients see any new domains

Samba normally acts as a peer in a workgroup not a domain.

Have you read the samba HOWTO and configured it as a domain controller?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
samba server not showing up from any other comps in my network chuky152 Linux - Networking 2 02-23-2005 11:35 AM
Can't See Samba server in network neighbourhood tapanga Linux - Networking 15 02-20-2004 11:11 AM
Samba Server Not Reachable from WinNTClient joelin Linux - Networking 9 01-15-2004 06:24 AM
Samba/Network Neighbourhood Problem moetjojo Linux - Networking 6 09-18-2002 01:49 PM
Samba and Network Neighbourhood 2 TriniMan Linux - Networking 30 08-26-2002 10:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration