LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-14-2005, 07:58 AM   #1
ekasteng
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Samba Problems - SuSE 9.2 AMD64 w/config


First off let me start with my hardware:

AMD 64 3200+
DFI LanParty UT nF3 250Gb Mainboard w/ onboard LAN
1GB PC3200 Ram
Western Digital 200GB IDE Hard drive
SuSE 9.2 Professional kernel 2.6.8 AMD64
Samba 3.0.9-2.3 SuSE

Ages ago when I still could remember what I was doing I had set up a simple Samba Server in my office network because I did not want to pay the extra $600 they were wanting at that time for Windows Server. I had managed to install SuSE 8.2 with Samba 2.2.7 on it, and configured it with SWAT. The behavior I had gotten out of it was what the office had wanted (and I know you security people will cringe) just appeared to be an open share, available to any computer plugged into the network at the time. The smb.conf for the old setup is as follows:

Code:
# Samba config file created using SWAT
# from localhost (127.0.0.1)
# Date: 2003/07/31 13:08:15

# Global parameters
[global]
	workgroup = MA
	netbios name = SAMBA
	server string = Samba Server 2.2.7a-SuSE
	encrypt passwords = Yes
	map to guest = Bad User
	log level = 1
	syslog = 0
	time server = Yes
	unix extensions = Yes
	socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
	printcap name = CUPS
	os level = 60
	printing = cups
	veto files = /*.eml/*.nws/riched20.dll/*.{*}/

[homes]
	comment = Home Directories
	read only = No
	create mask = 0640
	directory mask = 0750
	guest ok = Yes

[printers]
	comment = All Printers
	path = /var/tmp
	create mask = 0600
	printable = Yes
	browseable = No

[accounting]
	comment = accounting
	path = /var/lib/accounting
	read only = No
	create mask = 0640
	directory mask = 0750
	guest ok = Yes
In the Admin guide for SuSE it goes into how to enable SWAT. I went and edited /etc/services to activate it, but the other step they had in there was to enable SWAT in /etc/xinetd.d/samba. That file does not exist for some reason so I could never get SWAT to work. Also editing it via YaST was a total pain and did me no good. So as a last resort I had thought that I might take the old config, and put it in the new server they had bought to get the same behavior out of it.

It opens the shares on the network, but asks for username and password, and I can access nothing. What they have asked for is no user authentication, just let them plug the machine in , see it, and let it work just like an open share on a windows peer to peer network (which is the type they have). If anyone can help me with this I would be most appreciative.

Sorry for the long post.
 
Old 02-14-2005, 08:12 AM   #2
cowanrl
Member
 
Registered: Dec 2004
Location: Western Pennsylvania, USA
Distribution: Red Hat
Posts: 150

Rep: Reputation: 15
Try adding the line security = share to the global section of your smb.conf file. I'm not sure when Samba made the switch from the default being security = share to security = user. I know in the latest versions, the default is security = user.
 
Old 02-14-2005, 08:37 AM   #3
ekasteng
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the reply. That worked up to a point

The share is seen on the network now, and it can be opened. The only thing left is to set up write access to it so they can add or edit files in here at will.
I slimmed down the smb.conf file in the new machine to get id of the stuff they will never use, and it looks as follows:

Code:
[global]
	workgroup = MA
	netbios name = SAMBA2
	server string = New File Server
	encrypt passwords = yes
	map to guest = Bad User
	log level = 1
	syslog = 0
	time server = Yes
	unix extentions = Yes
	socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
	printcap name = cups
	os level = 30
	printing = cups
	security = share


[masters]
	comment = masters
	path = /var/lib/masters
	writeable = yes
	create mask = 0640
	directory mask = 0750
	guest ok = yes
Do I have the "masks" set wrong? Or is there something else I am missing??

Thanks again for all the help.
 
Old 02-14-2005, 09:09 AM   #4
ekasteng
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Original Poster
Rep: Reputation: 0
O.K I figured it out. Needed to create a user, then force anonymous to that user, and change the directory permissions.

Thanks for all the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FreeBSD 5.3 current for AMD64 Mouse Config for X EnderWiggin1337 Linux - Newbie 1 01-24-2005 04:19 PM
Samba Config Problems AngryKeebler Linux - Networking 6 06-12-2004 02:28 PM
Problems with Samba Config Mojojo Linux - Networking 1 05-03-2004 10:30 AM
SAMBA config problems danoj Linux - Networking 1 10-20-2003 12:57 PM
SMC 2632W card and SAMBA config problems weblion Linux - Software 3 03-04-2002 06:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration