-   Linux - Networking (
-   -   Samba printing to CUPS printer (

kris.kj.jacobs 11-01-2001 04:28 PM

Samba printing to CUPS printer
All printjobs sent from my Windows to my CUPS printer on Mandrake 8.1 seem to disappear.

I can print from within my Linux machine to the CUPS printer, but when I'm trying the Windows test page it disappears.

I can connect to the printer from Window, I can send a print job, the job appears on the Windows spooler and is sent further to the CUPS spooler without giving any error. But nothing happens.

I've removed the -r in the cups-lpr command (smb.conf), and the job appears in /var/spool/samba. When I then execute cups-lpr manual, nothing.

Please help.

Many thanks,

Kris Jacobs


workgroup = MDKGROUP
server string = Samba Server %v
encrypt passwords = Yes
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = lpstat
dns proxy = No
printing = cups
print command = /usr/bin/lp -d%p -oraw %s; rm %s
lpq command = /usr/bin/lpstat -o%p
lprm command = /usr/bin/cancel %p-%j
queuepause command = /usr/bin/disable %p
queueresume command = /usr/bin/enable %p

comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p -o raw %s -r # using client side printer drivers.
lpq command = lpstat -o %p
lprm command = cancel %p-%j
browseable = No

kris.kj.jacobs 11-02-2001 04:42 PM

Solved problem myself.

Got an Epson Stylus Color 600. Installed wrong printerdriver under Linux. Changed to the recommended driver and now it works.

All times are GMT -5. The time now is 11:02 AM.