Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 11-04-2003, 08:28 PM   #1
Registered: Oct 2003
Location: Austin,TX
Distribution: Debian SID-->fully content-->Love APT,kernel 2.6.4
Posts: 327

Rep: Reputation: 30
Samba printer help(can see and have access to printer but nothign prints out)

I have recently joined a company and i was asked to correct their smb.conf(we are using Red Hat 9.0) file since the printer they have is being seen in Win 2K and it does not even say that permssion is denied but when i try to print a test does not print out anything. The windows machines shows the document as gone to the printer but nothign is being printed out. also when i open up the printer queue in the win 2k shows as access denied. I have not added the win 2k user to my samba users list but since i have set my printer to have guess access...i dont think this should be a problem...however i also do not know if there is a guest account in smbpasswd.
now i read a few howtos and noticed that the spool directory in smb.conf and /etc/printcap should be the same, however when i open /etc/printcap i only see "lp: " and nothing else so i added sd:, and mx to it. i put the same directory as that in smb.conf for sd: however the printing still does not work....i forgot to say somethign though....the printer works fine from other linux machines and also the other shares from windows to the linux box work fine...i can read and write both to and from the linux box according to my share specification.
i have attached my printers part of smb.conf below...please see and let me know what changes i shud make to get this to work...also plz let me know if i shud rather attach the printer to the windows machine and then use samba to access it from the linux boxes...will that be easier to setup?
# NOTE: If you have a BSD-style print system there is no need to
# specifically define each individual printer
comment = All Printers
# security = server
path = /var/spool/samba
# path = lp:
browseable = no
public = yes
# Set public = yes to allow user 'guest account' to print
printable = yes
# guest ok = yes
create mode = 0700
writable = no
#added by BGH
# use client driver = yes
# disable spools=no

# security = server
comment = lp
path = /var/spool/samba
# path = lp:
printer name = lp
#This section added by BGH from SMB HowTo
# browseable = yes
# available = yes
public = yes
# guest ok = no
writeable = yes
printable = yes
print command = lpr -r -h -P %p %s

i have tried both printcap names..../etc/printcap as well as cups.
i could really use some help here so please do let me know if you know anything about fixing this...also plz let me know if you need some more information.
thank you
Old 11-05-2003, 06:54 AM   #2
Registered: Jul 2003
Distribution: Debian
Posts: 31

Rep: Reputation: 15
the only way i was able to setup printer sharing with 2k was to set the global securtity variable:
in my smb.conf

i know there's other ways, but that is how i got it to work. it still shows as 'permission denied' on the printer status box in windows, but it will print.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Printer prints only the first page zupermanz Linux - Hardware 3 05-31-2005 05:24 AM
Printer only prints first page! zhangmaike Linux - Hardware 0 12-05-2004 03:38 PM
samba printer access problem Tinku Linux - Networking 5 09-28-2004 01:04 PM
Printer prints too light sofasurfer Linux - Hardware 2 12-31-2003 09:44 AM
Samba cannot access Windows Printer ZhiYi Linux - Networking 1 02-26-2003 12:01 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:04 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration