Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 07-18-2004, 05:20 PM   #1
LQ Newbie
Registered: Jul 2004
Posts: 28

Rep: Reputation: 15
Samba - port already in use

Hi all, here's my config:
redhat 9, samba comes preinstalled.

nmdb is working, because I can see the linux computer on my workgroup, I just can't access it or the shares.


log level = 2
workgroup = MILKYWAY
comment = For testing only, please
path = /mnt/tmp
read only = no
guest ok = yes

smbd log:

[2004/07/18 22:57:33, 0] smbd/server.c:main(707)
smbd version 2.2.7a started.
Copyright Andrew Tridgell and the Samba Team 1992-2002
[2004/07/18 22:57:33, 1] lib/debug.c:debug_message(258)
INFO: Debug class all level = 2 (pid 3974 from pid 3974)
[2004/07/18 22:57:33, 2] param/loadparm.c:do_section(3055)
Processing section "[test]"
[2004/07/18 22:57:33, 2] lib/interface.c:add_interface(81)
added interface ip= bcast= nmask=
[2004/07/18 22:57:34, 0] lib/util_sock.cpen_socket_in(804)
bind failed on port 139 socket_addr =
Error = Address already in use

I found out that I can use: fuser -n tcp 139
and then use the number it gives me with: ps auxw | grep 3988
and that gives me the (seemingly) unhelpful:
root 4269 0.0 0.2 3576 616 pts/0 S 23:11 0:00 grep 3988

I'm lost and don't know where to go with this.
Any help would REALLY be appreciated.
Old 07-18-2004, 05:36 PM   #2
Registered: Sep 2002
Location: .at
Distribution: SuSE, Knoppix
Posts: 532

Rep: Reputation: 31
check /etc/inetd.conf or /etc/xinetd.conf for possible samba services
Old 07-18-2004, 07:43 PM   #3
LQ Newbie
Registered: Jun 2004
Location: UK
Distribution: Fedora-C2
Posts: 27

Rep: Reputation: 15
hi, dont know if this will make sense, but could it be a problem with your iptables if you are using a firewall?
Old 07-19-2004, 01:52 AM   #4
LQ Newbie
Registered: Jul 2004
Posts: 28

Original Poster
Rep: Reputation: 15
I've disabled my firewall for this test.

I opened /etc/xinetd.conf, but nothing of any use was in there or services or servers in /etc/xinetd.d/.
Old 07-19-2004, 02:18 AM   #5
Senior Member
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
netstat -pl should give you a list of open ports.
Old 07-19-2004, 05:00 AM   #6
LQ Newbie
Registered: Jul 2004
Posts: 28

Original Poster
Rep: Reputation: 15
Ok thanks for that... it turned out to be vmware, which by default installs it's own samba for it's emulated windows OS.
So I reinstalled without that particular feature.

Thanks all who answered.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba Port Requirements jtshaw Linux - Networking 2 01-19-2005 09:23 PM
samba port winchester169 Linux - Networking 4 03-13-2004 10:46 AM
Samba port clarification Apollo77 Linux - Networking 4 02-09-2004 10:03 AM
Samba 3 & port 445 Anibal Slackware 0 10-24-2003 12:22 PM
SAMBA Port Failure byersjlpa Linux - Networking 7 06-05-2002 03:16 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:09 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration