LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-15-2004, 01:17 AM   #1
i80lvl8
LQ Newbie
 
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0
Question samba on suse 9.2


recently switched to suse 9.2 from 9.1. I did a clean install, everything works fine except samba. When i try to search the samba network it comes up with an error message: "Unable to find any workgroups in your local network." Now, on suse 9.1 i had no problem. Also when i boot it says: "Skipped services in runlevel 5: smbfs nfs"
 
Old 01-10-2005, 05:43 PM   #2
bergie91
LQ Newbie
 
Registered: Jan 2005
Posts: 2

Rep: Reputation: 0
Hi,

I had the same problem, and ended up having to turn off the suse firewall to get it to work. There is probably a way to configure the firewall without having to turn it off completely, but i didn't mess with it. Hope that helps.
 
Old 01-10-2005, 05:54 PM   #3
bergie91
LQ Newbie
 
Registered: Jan 2005
Posts: 2

Rep: Reputation: 0
hey, i found some info for ya. You need to open ports TCP: 137, 138, 139 and UDP: 137. You can open these ports in expert mode of firewall config utility. It worked for me
 
Old 01-23-2005, 12:01 PM   #4
tgosnell
LQ Newbie
 
Registered: Jan 2005
Location: Stillwater, OK
Posts: 1

Rep: Reputation: 0
Opening ports does not work for me

I too am having trouble with Samba and the firewall. I tried opening the suggested ports and it did not help. Any other ideas?
 
Old 01-29-2005, 09:08 PM   #5
johnlb
LQ Newbie
 
Registered: Feb 2003
Posts: 12

Rep: Reputation: 0
Samba on SuSE 9.2

I get the same errors part of the time.
If I reboot Linux, it will work for a few hours. It then quits working and giving me the "no workgroups found" message.
I have opened the ports mentioned and currently have the firewall (supposibly) turned off. Yast said that it would turn it off and remove the startup code used on reboot. Does it?

Or is the problem somewhere else?

I have used Yast to configure Samba - no difference.
I used the web page setup utility with Samba - no difference.
And I have reverted back to origional smb.conf, done manual edits, and still will not work reliably.
 
Old 02-04-2005, 09:14 AM   #6
FritsP
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Rep: Reputation: 0
There is even more wrong than that. ..

I observed exactly the same behaviour. After installing samba (with YAST) I had to shut down the firewall to make it work.

Before shutting down the firewall I noticed that another service (http on port 80) was also not available anymore (although I checked it). Then I performed the following test:
- Uncheck the http serivce
- Restart the firewall
- Check the http service
- Restart the firewall
and the http service was available again! Still Samba was not working properly.

Now when I change the configuration of samba the only thing I do is editing /etc/samba/smb.conf and next I restart samba manually: /etc/init.d/smb restart

to be continued ....
This weekend I will try to make the firewall working again.
 
Old 02-05-2005, 03:29 PM   #7
FritsP
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Rep: Reputation: 0
After some experimenting I found out the following:

Stop the firewall -> I could use the samba share
Start the firewall -> Samba shares could not be used anymore

In advanced settings (or edit it straight in /etc/sysconfig/SuSEfirewalll2) open all ports:
FW_SERVICES_EXT_TCP = 1:2048
FW_SERVICES_EXT_UDP = 1:2048
and start the firewall:
# SuSEfirewalll2 start

Again I cannot use samba

According to the help of the firewall it should be possible to see (in /var/log/messages) what is blocked when using the test mode. The firewall will not block anything but log in the logfile what would have been blocked by the filterrules. So let's try:
# SuSEfirewalll2 test

I tried to open the samba shares on my machine and ... nothing in the log file and again I could not reach the share.
# SuSEfirewalll2 stop

and ... I could use the share! So the firewall was blocking something after all although it should not have according to the help file!

A small note: I tried to use the shares from a Windows 98 machine and rebooted the machine between every step of my experiments.

I give up.
Since I am behind a hardware firewall I do not care much about this one and decided not using it until someone finds a solution to this problem.
 
Old 02-05-2005, 04:05 PM   #8
FritsP
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Rep: Reputation: 0
Sorry Guys, do I feel stupid.

After giving blowing the wistle and giving up I gave it a final try on Google and found the solution:

(see http://lists.samba.org/archive/samba...ry/098121.html)

Put the following lines in the /etc/sysconfig/SuSEfirewall2 configuration file:
FW_SERVICES_EXT_TCP="microsoft-ds netbios-dgm netbios-ns netbios-ssn"
FW_SERVICES_EXT_UDP="netbios-dgm netbios-ns"

This opens the following ports
TCP: 137, 138, 139, 445
UDP: 137, 138

This is not enough, as I experienced before . The killer is this one:
FW_ALLOW_FW_BROADCAST="yes"

I just tried it and it works!
 
Old 02-06-2005, 10:17 PM   #9
metzen
LQ Newbie
 
Registered: Feb 2005
Posts: 3

Rep: Reputation: 0
Just turned the firewall off

Hey just wanted to thank you.. Turning off the Firewall allowed me to see my Windows XP Files. Thanks for the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba in SuSE 8.0? rodda Linux - Networking 1 02-12-2005 12:10 PM
Samba in Suse John_Emad Linux - Networking 9 01-28-2005 07:37 AM
Samba: /etc/samba/dhcp.conf on SuSE 9.1 sskt74 Linux - Networking 0 01-05-2005 06:03 AM
Samba and Suse 9.0 uranologist Linux - Networking 13 02-28-2004 07:16 PM
samba in suse 9.0 misophist Linux - Networking 1 12-18-2003 05:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration