-   Linux - Networking (
-   -   Samba on Fedora19, 64-bit "times out" quickly when attempting to connect to workgroup (

ZTagr 08-02-2013 11:01 PM

Samba on Fedora19, 64-bit "times out" quickly when attempting to connect to workgroup
Hi all!

I have only recently installed Fedora 19, 64-bit on my notebook pc, and need to communicate with it using Samba. I found out that Samba was not installed by default, so I installed in with the yum command:
"yum install samba"

I then made my normal modifications to the smb.conf file, and started and enabled both smbd and nmbd.

At first, I was not able to communicate in either direction (from my other networked pc's, or to them from Fedora), so I went online to see if I could find some answers.

I made a few adjustments:

A) I disabled SELinux (if only for a short time, just until I can establish a networked connection to my workgroup...)

B) I made the following iptables entries:
iptables -A INPUT -s -p udp -m udp --dport 137 -j ACCEPT

iptables -A INPUT -s -p udp -m udp --dport 138 -j ACCEPT

iptables -A INPUT -s -p tcp -m tcp --dport 139 -j ACCEPT

iptables -A INPUT -s -p tcp -m tcp --dport 445 -j ACCEPT

I also opened up ports 137-139 and 445 with the GUI interface to firewalld.

Now, I can connect to the Fedora 19 system from any pc within my workgroup, but can NOT connect to "workgroup" (the actual NAME of my workgroup) from Fedora 19! I keep getting "timeout connecting to workgoup" errors. These error notices appear almost immediately after I double-click on the "workgroup" icon; however, I have set my connect-to-server timeout to over one minute! (actually, it's set to a minute and a half...)

Does this issue sound familiar to anyone? This is the first time I have ever used Samba 4, and I understand it differs substantially from Samba 3; could this be an issue?

Or, is there an iptables / firewalld step I've missed?

Please help if you can!

Thanks in advance,
- ZTagr.

ZTagr 08-03-2013 06:40 AM

Solved at last...
Thanks for all who took time to read my question!

As I stated in the original posting, I am new to Fedora 19, 64-bit (having just switched from Ubuntu 64-bit after some two years...). I had never needed to deal with SELinux to any large degree and had never encountered the likes of firewalld before! It turns out that THAT was where my problem ultimately lay!

I only "stumbled on" the firewalld GUI setup by accident while sifting through the Fedora KDE4 menu, looking for anything that I thought might be helpful in solving my problem. When I ran it (the GUI interface app) I found it quite intuitive, and really didn't need any help in doing what I believed needed to be done with it to allow Samba to communicate through it. I decided to make the default ZONE "Home" at that time, and configured the ports for Samba in THAT zone. Once I had done so, I was able to communicate from any of the pc's on my LAN to my Fedora machine, and so I was pretty sure I had been successful in setting it up correctly. I was of course unable to communicate OUT from Fedora to the rest of my workgroup (thus, my posted question).

Here was where I made a small error! The NetworkManager in Ubuntu looks very similiar to that in Fedora w/KDE4 DTE. There is ONE MAJOR DIFFERENCE in the two versions - the Fedora version has a setting for the wired network called "Firewall zone" which I had NOTICED, but didn't think much of at the time. Now, later on, once I had "stumbled" on to firewalld's GUI app, I did not recall having even SEEN that setting! I of course never realized that in NetworkManager, the firewall zone was set to "Trusted" zone! And I had NOT made any modifications to that zone! Thus my problem...

Needless to say, once I had realized my mistake, and set the current firewall zone to "Home" within NetworkManager, Samba performed flawlessly!

Guess I need to hit the manuals for Fedora, eh?

But, you would think that, because you can SET the default zone in the firewalld GUI, that any apps. working with the firewall (such as Samba) would simply USE the selected default zone! Instead I need to both SET the default zone, and then tell Samba what zone I want it to use...(not entirely logical, and one step too many!). If Samba had indeed used the DEFAULT ZONE, I would have had the problem solved a day earlier... - sigh...

Thanks again!

All times are GMT -5. The time now is 05:08 PM.