-   Linux - Networking (
-   -   Samba on FC5: Some Files and Directories Missing (

jpence 08-09-2006 08:11 PM

Samba on FC5: Some Files and Directories Missing
I just installed FC5, and configured Samba to share some files with my XP computer.

I first tried to share /home/jeff. The share was visible, but when I tried to open it, it said that access was denied. The samba log file said that the directory might not exist. I checked both existence and file permissions, and they are correct.

Then I tried to share / and /tmp. I can see the shares, and can open them. However, some files and folders are mysteriously not displayed. Here are a few that I cannot see:

Anything that is not a directory in /tmp

On the other hand, /etc and /lib appear with all contents, both directories and files.

I checked to make sure that smb.conf didn't have any veto files configured.

Any other configuration files that I need to check to make sure that all contents are made visible?


amitsharma_26 08-09-2006 09:27 PM

A query
: Wat is the security mode you have set for samba ?

Permissions could be a possibility. Can you please revert back with your testparmed 'smb.conf' ?

amitsharma_26 08-09-2006 09:38 PM

@ my own setup : With the two below mentioned configuration lines;


path = /
read only = yes
I was able to share it properly without any problems.
Though i was not able to surf into many folders because there were'nt enough rights/permissions available for 'others'.

jpence 08-10-2006 11:53 AM

Thanks for your responses. Here's the output of testparm:

workgroup = NA
server string = Jeff Pence's Linux
username map = /etc/samba/smbusers
log file = /var/log/samba/%m.log
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = /etc/printcap
local master = No
wins server =
remote announce =
guest ok = Yes
cups options = raw

comment = Home Directories
read only = No
browseable = No

comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

comment = Temporary file space
path = /tmp
read only = No

comment = File system root
path = /
valid users = jeff, jpence
read only = No

jpence 08-10-2006 12:02 PM

One other mystery. I created a new directory, /jptest. The permissions on this are exactly the same as /home:

drwxr-xr-x 3 root root 4096 Aug 9 18:16 /home
drwxr-xr-x 2 root root 4096 Aug 10 09:55 /jptest

When I open the share from XP, I can see /jptest and its contents, but not /home.

amitsharma_26 08-10-2006 08:07 PM

Ok. Try out this way & revert if it works or not ?

Type the below mentiond in any window & then press enter

& the same time... do check what does your samba logs say.
If you dont get success, post the portion of your samba logs here.

jamiebriant 09-27-2006 12:10 AM

SE Linux is screwing with you. By default, SELinux is preventing the smb daemon from accessing those files. Google for SELinux and Samba - can't post links yet.


All times are GMT -5. The time now is 04:28 AM.