LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-04-2003, 09:01 PM   #1
seanlinux
LQ Newbie
 
Registered: Sep 2003
Posts: 23

Rep: Reputation: 15
samba on debian


Hey,

I am running a Debain box with Samba. I have configured it with a some shares and I can view the linux computer from my windows xp computer in the network neighborhood, but it shows none of the shares. it lets me click the workgroup name but once i am in the workgroup name it does not display any of the shares that i setup in the samba config file... Got any ideas?
 
Old 11-04-2003, 09:18 PM   #2
maddogdelta
Member
 
Registered: Nov 2003
Location: tonawanda, NY
Posts: 32

Rep: Reputation: 15
can you post the [shares] portion of the smb.conf? there might be something there.
 
Old 11-04-2003, 09:26 PM   #3
seanlinux
LQ Newbie
 
Registered: Sep 2003
Posts: 23

Original Poster
Rep: Reputation: 15
Here is my smb.conf file...


; smb.conf's global parameters section
[global]
; set the netbios machine name for the server
netbios name = EAGLE
; set the workgroup membership
workgroup = WORKGROUP
; set Samba to authenticate in user mode security
security = user
; share name
[boss1]
; text to list when browsing the share from a client
comment = Shared directory for group boss1
; absolute path to the disk directory
path = /export/smb/boss1
; should the share be writeable?
writeable = yes
;user allowed to connect to the share
valid users = @boss1
;enforce file locking?
locking = yes
;default file creation permission mask
create mode - 0660
;default directory creation permission mask
directory mode = 0770
; share name
[homes]
commment = Unix home directory space
path = %H
writeable = yes
valid users = %S
create mode = 0600
direcotry mode = 0700
locking = no
 
Old 11-04-2003, 10:07 PM   #4
jdolluc
Member
 
Registered: Jul 2003
Distribution: Debian
Posts: 31

Rep: Reputation: 15
if you are only going to be sharing with one win xp box, you can try changing the "security=user" to:
security=share

this will allow any user to access the files...of course only do this if you are comfortable with it.
 
Old 11-04-2003, 10:09 PM   #5
seanlinux
LQ Newbie
 
Registered: Sep 2003
Posts: 23

Original Poster
Rep: Reputation: 15
i was hoping to share with many windows computers....any other ideas?
 
Old 11-04-2003, 10:11 PM   #6
jdolluc
Member
 
Registered: Jul 2003
Distribution: Debian
Posts: 31

Rep: Reputation: 15
do you have swat installed?
on debian simply do an apt-get update
apt-get install swat

then open a browser window and type:
localhost:901
then your root password

this is a great utility for setting up samba.
 
Old 11-04-2003, 10:13 PM   #7
seanlinux
LQ Newbie
 
Registered: Sep 2003
Posts: 23

Original Poster
Rep: Reputation: 15
yes, i have swat installed also... i dunno what else to try... does my smb.conf config look correct? is there a permission thing i am missing?
 
Old 11-04-2003, 10:14 PM   #8
maddogdelta
Member
 
Registered: Nov 2003
Location: tonawanda, NY
Posts: 32

Rep: Reputation: 15
It's not showing you the shares because you haven't authenticated to the samba machine yet.

To get it to show you the shares, (from windows) you need to do one of two things..
either
Have your samba box be a Primary Domain Controller, and configure your Windows XP machine to connect to that domain (this is a longer procedure than I can describe quickly here.)
For the domain controller, Carla Schroders Explanation of PDC's is a good reference.

For the penultimate reference, try the Samba PDC howto here , and for the ultimate answer, check out Using Samba .

There are a few issues with XP though. First, it has to be XP Professioinal. Second, there are some registry settings that have to change. I'll look them up and post them in a follow up to this. (or you can google for XP samba and you may be able to dig the answer out of the massive list that comes up)

OR
Right click on my computer, click map network drive, type in the share that you want to see in the \\servername\sharename format, click on the underline which says 'connect with a different user name'. At this point you need to connect witha username and password that samba recognises. Shroder shows how to do that in her article (smbpasswd -a linuxusername).

I think the key is that you have specified that security is USER so samba is expecting a logon of some sort. When you just browse the network, you are not connecting as a recognised user, so it doesn't show you any available shares. If you specified security=share then it would show the shares.

I know this isn't complete, but let me know if I'm getting warmer.
(I might not be able to get back to this until tomorrow morning, however. It's getting late and I'm turning back into a pumpkin. )
 
Old 11-05-2003, 03:40 AM   #9
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 48
I don't see browseable = yes in that share list...
or encrypt passwords = yes

An easy Samba Tutorial to read..

Last edited by peter_robb; 11-05-2003 at 03:48 AM.
 
Old 11-05-2003, 06:17 AM   #10
maddogdelta
Member
 
Registered: Nov 2003
Location: tonawanda, NY
Posts: 32

Rep: Reputation: 15
I think the biggest issue is authentication.

Windows NT/2K/2K3, although it has security issues, is not necessarily as insecure as some people think. In order to see/browse the shares on one of these machines, you must authenticate, ie tell the server who you are, with a valid password. When you set 'Security = user' you are, in effect, emulating these more secure versions of windows.

Which means that you need to be logged in to see/use these shares.

IMHO, your best bet is to make the Samba server a Primary Domain Controller. The article by Carla Shroder that I pointed out earlier will give you a step by step for a simple setup. Samba Tutorial that peter robb mentioned (great link, pete!) looks to be excellent also, and it goes into the issue in a little more depth, and it also has the XP registry hacks.

In order for the XP machines to participate, you then need to connect to the Samba domain. Dave Lechnyr in the above article mentions how to connect your XP boxes to the domain.

What this will do is that now, everytime you log in to the windows machine, it authenticates to the samba server. At that point you will not only get the shared directories you initially set up, but everyone also has access to their home directories on the linux server. (the server has to be running, though!)
 
Old 11-05-2003, 12:26 PM   #11
seanlinux
LQ Newbie
 
Registered: Sep 2003
Posts: 23

Original Poster
Rep: Reputation: 15
do windows xp home computers have difficulty connecting? I read that xp home was more difficult to get connected. Both of my computers are windows xp home, so i was wondering what I needed to do or if it does not really matter. I also have a windows 98 computer that i can test with the samba box... thanks for the links and let me know if there is anything else i might want to check into...

thanks again.
 
Old 11-05-2003, 06:28 PM   #12
maddogdelta
Member
 
Registered: Nov 2003
Location: tonawanda, NY
Posts: 32

Rep: Reputation: 15
Microsoft deliberately cripples windows XP home so that it cannot become a member of a domain. (This is the issue which allows the domain controller's authentication to be valid on the local machine)

In a small environment, you can emulate the functionality with xp home by putting the same usernames and passwords on all machines (in other words, if JOE has a password of 'imjoe', then 'JOE' and 'imjoe' need to be on every computer in your environment. After this, you will be able to connect. What will happen is that joe will logon to any computer, and as soon as joe browses the network to the samba server, joes computer will send the username and password to the server to have the server check it's user database.

This is what makes XP home harder. It still connects, but you don't get the advantage of a centralized user database, profiles, login scripts etc.

The windows 98 computer should not be a problem. Make sure you have the DOMAIN LOGONS = YES line in your [globals] section, ENCRYPTED PASSWORDS = YES, and you should be in like flint.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't copy file to debian using samba walterbyrd Linux - Networking 3 02-25-2005 08:52 AM
Samba - Connecting from WinXP Pro to Samba running on Debian critical Linux - Networking 1 02-03-2005 10:36 AM
Print from Debian to Win XP through samba lttlstrwbrr Debian 1 08-09-2004 11:03 AM
Debian and samba Sark Linux - Newbie 2 04-07-2004 11:00 AM
debian sarge samba-2 Tero Debian 1 03-11-2004 02:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration