LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-11-2006, 06:54 PM   #1
Xerop
Member
 
Registered: Jan 2004
Distribution: Suse, Red Hat
Posts: 129

Rep: Reputation: 15
samba maximum clients? <SOLVED>


I have a windows home edition machine running with 22 shares I wrote a script that auto mounts al of these but once it gets throught about 6 of them it stops with access_denied_messages. I also (at this point cannot get a share listing with smbclient) Until I unmount at least one share no other shares can mount.

Any thing I can do to fix this. I need to be able to mount at least 10 of these folder I can mount only 6...

Any help would be apreciated. Also i tried mounting them through fstab but that requires passwords which I DO NOT HAVE!!! (I did not set a username or password on any of the shares)
Any suggestions?

PS I am running gentoo 2006.0 I do not want to use fstab to mount... Its harder to setup... (particularaly because I do not want to type out 20 lines for shares (which change all the time, so I would have to retype them all the time) I would like to stick with mount by "smbmount")

Last edited by Xerop; 05-13-2006 at 12:12 AM.
 
Old 05-11-2006, 07:31 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,455

Rep: Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826
Windows desktop versions only permit 10 simultaneous connections. Do you have any other PCs connected to this computer?

http://support.microsoft.com/?kbid=314882
 
Old 05-11-2006, 07:47 PM   #3
Xerop
Member
 
Registered: Jan 2004
Distribution: Suse, Red Hat
Posts: 129

Original Poster
Rep: Reputation: 15
I have another computer on... But since windows is windows I do not know whether it is connected....

is there anyway to change this? maybe a registry key? maybey that link you gave me... thank you
 
Old 05-11-2006, 10:31 PM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,455

Rep: Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826Reputation: 5826
AFAIK no. I saw something awhile ago about changing a registor setting on connection times. So in theory you could have more then 10 connections but I tried googling again without success. The link was just stating the fact about the max of 10 connections for desktop windows.

Just curious on why you need 22 shares?
 
Old 05-11-2006, 11:14 PM   #5
BrianK
Senior Member
 
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Rep: Reputation: 51
I'll second what michaelk said - AFAIK, only 10 connections. If you want more than that, you have to use Win2K(3) server.
 
Old 05-12-2006, 12:01 AM   #6
Xerop
Member
 
Registered: Jan 2004
Distribution: Suse, Red Hat
Posts: 129

Original Poster
Rep: Reputation: 15
It my dads computer, I use it a server and it has about 6 partions which have 22 folders shared and depending on when I need access to all of them. Thats the why. Also I just remembered that article at the beggining the timeout on the windows side is 15 minutes, isn't it? so why not reduce it to 1 minute and use autofs to mount the proper share when I need it? I have already configured autofs to do all the mounting however it gets stuck on the sixth directory (also note I am using home edition, so the connections are limmited to 5 NOT 10)

As an example I will show what "ls" gives me on the sixth directory I mount (ie enter because autofs takes care of mounting)
Code:
ls: inc_report.xls : No such file or directory
ls: nano.txt : No such file or directory
I am not yet sure whose fault this is (linux side or windows side) but I will keep digging further
 
Old 05-12-2006, 02:01 AM   #7
Xerop
Member
 
Registered: Jan 2004
Distribution: Suse, Red Hat
Posts: 129

Original Poster
Rep: Reputation: 15
Hmm... it seems to be a bug... in autofs I cannot view the contents of half the folders although immediatly after checking (using autofs) I mount the share manualy with smbmount and it works! Any ideas? its 1am here so i need to get to bed...

Just tested again and one of non-working folders worked. The I tried to open it KDEs filemanager and it couldn't. Then i tried ls again it worked the n KDEs filemanager started working. But some of the folders that worked before stopped.

This might be due to the windows' machines timeout settings will try on another machine later. Hopefully I can get to bottom of this...

Any ideas, anyone?
anything may help so please suggest what you can.

Last edited by Xerop; 05-12-2006 at 02:10 AM.
 
Old 05-12-2006, 11:56 PM   #8
Xerop
Member
 
Registered: Jan 2004
Distribution: Suse, Red Hat
Posts: 129

Original Poster
Rep: Reputation: 15
just changed the password in the credentials to a blank and I can now see 7 of 10 shares 3 are still off line... I can't seem to figure this out... Maybe a reinstall will help... But wow I do not want to reinstall gentoo that is a great pain.
One of the shares seems to say no such directory when I "ls" in it.
 
Old 05-13-2006, 12:17 AM   #9
Xerop
Member
 
Registered: Jan 2004
Distribution: Suse, Red Hat
Posts: 129

Original Poster
Rep: Reputation: 15
I finally got it. Its, as usual my-microsofts fault. I have had problems before where I try to access my dads comp from other windows computers and some of the shares would ask for a user name and password but there was not one. THIS IS THE BUG (microsofts fault). I have figured out how to solve this now. When the username and pass are asked for I can plug in a username on the target computer and it will retrieve the share. So all I had to do to solve my problem was to change my cdredentials to
Code:
username=USER_ON_TARGET_COMPUTER
password=
password is nothing (no charachters, ie no spaces or letters)

hopefully this will help someone!!! ^_^

You can't imagine how happy I am!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Maximum Share size + Samba hendrixbart Linux - Software 1 11-11-2010 01:10 PM
samba clients ziox Linux - Networking 0 10-13-2005 04:25 PM
samba - maximum login kvri Linux - Networking 1 02-10-2004 05:27 PM
Samba: Authenticate Linux-Clients in Samba Domain & Mount mule Linux - Software 0 12-10-2003 02:21 AM
Samba 2.2.1a on RH 7.2 w/Win98 clients earthur Linux - Networking 2 11-07-2002 09:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration