LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-08-2003, 10:51 AM   #1
lflores
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Rep: Reputation: 0
Question Samba Issues


I have been trying to get all 7 of my Windows XP home machines to see my RedHat 9.0 Samba Server securuty here is not an issue I just need a shared drive that everyone cann see and access. I have stripped my Samba.conf file down to the bare bones and I still get the same error. \\samba is not accessible. You might not have permissions to use this network resource. Contact the administrator of this server to findout if you have access permissions. netowork path not found.

I know that with the Home edition of windows XP I have to use Samba as a stand alone server and I am but nothing I do gets me anywhere but that message. Im hoping someone has a copy of a SMB.Conf file that shows the easy way to the promised land. Just a big shared drive in the sky.
 
Old 08-08-2003, 11:49 AM   #2
sorrodos
Member
 
Registered: Jul 2003
Location: Salt Lake City, UT and Spokane, WA
Distribution: Mandrake 10.0, Gentoo, FreeSBIE 1.0
Posts: 345

Rep: Reputation: 30
What are you trying to log into the RH machine as? You may need to add Samba accounts and/or allow certain local accounts to also be used as Samba accounts for remote access.
 
Old 08-08-2003, 12:30 PM   #3
linylion
LQ Newbie
 
Registered: Jul 2003
Location: Lahore (Pakistan)
Distribution: Red Hat Linux
Posts: 9

Rep: Reputation: 0
Check for ur network connectivity using ping command.

Have ur Xp machines joined Samba server, which may be working as PDC most probably?

If yes then proceede

Check for any firewall configured...
If no firewall then

Just post ur smb.conf file configurtion for more deep dive into the problem.
 
Old 08-08-2003, 02:24 PM   #4
lflores
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
server string = samba
security = SHARE
encrypt passwords = yes
guest ok = yes
guest account = lflores
workgroup = arista
writeable = yes
comment = shrdrv
guest ok = yes
path = /data/everyone/


This is my .conf file

Forrest I do have all users entered as users on the RH Linux but all of my clients are XP home users which means they cannot join a domain would this stop me from just making a shared drive with no user names and passwords for anyone to access on the network?

Liny lion I was thinking less is better let me know if there is something I ned to change.
 
Old 08-08-2003, 02:39 PM   #5
sorrodos
Member
 
Registered: Jul 2003
Location: Salt Lake City, UT and Spokane, WA
Distribution: Mandrake 10.0, Gentoo, FreeSBIE 1.0
Posts: 345

Rep: Reputation: 30
I am not sure you can create a share that doesn't require any user name. What you could do is enable the guest account for a public share and tell everyone the name of the guest account. You may have to set a password for a guest account too, I am not sure as I don't use a guest account for my shares.
 
Old 08-08-2003, 02:58 PM   #6
lflores
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
I can ping it I can see it in the network but when I click on it I get the error.

\\samba is not accessible. You might not have permissions to use this network resource. Contact the administrator of this server to find out if you have access permissions.
Network path not found.
 
Old 08-08-2003, 03:17 PM   #7
hakcenter
Member
 
Registered: Apr 2003
Location: Not to far from the computer screen
Distribution: RedHat 9.0
Posts: 324

Rep: Reputation: 30
try from the command prompt

net view IP

where IP is the ip address of the machine.

I got a samba working on my winxp network.. most likely you need to disable the firewall... cause a packaged up rpm installation works right out of the box.
 
Old 08-08-2003, 04:01 PM   #8
JimKyle
Member
 
Registered: Dec 2001
Location: Oklahoma City, OK, USA
Distribution: Xubuntu 16.04 LTS
Posts: 214
Blog Entries: 1

Rep: Reputation: 39
Did you get it working on XP Home, or XP Pro? I've never been able to get XP Home to connect to a samba server; always get that no-permission error regardless of user or password. I finally found a passage in Microsoft's "Windows XP Power Toolkit" book that said XP Home could not connect to a system that had shares such as IPC$ on it -- and samba requires such shares!

Since I have 5 static IPs from my ISP and was only using one of them, I simply cobbled an old hub in between my DSL modem and my switch (using a crossover cable between hub and switch), and put the XP machine on the hub with its own static IP. It's not on my network, but I can FTP between it and the rest of my network by way of the Internet, and can get Email on it -- which meets my needs. That beats giving Microsoft another $200 for a system I don't really want to mess with, just to make it work on my LAN!

I considered reformatting the drive and installing Win98SE in place of XP home, but was afraid that some of the hardware drivers might not work since the XP box is very new. If drivers are not a problem, going to 98SE is what I would recommend in order to live nicely with samba...
 
Old 08-08-2003, 04:05 PM   #9
hakcenter
Member
 
Registered: Apr 2003
Location: Not to far from the computer screen
Distribution: RedHat 9.0
Posts: 324

Rep: Reputation: 30
98.. thats just freaking lame bro.

I AM using home edition...
heres my .conf

[global]
log file = /var/log/samba/%m.log
smb passwd file = /etc/samba/smbpasswd
load printers = yes
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
obey pam restrictions = yes
encrypt passwords = yes
passwd program = /usr/bin/passwd %u
dns proxy = no
netbios name = Linux
netbios aliases = Linux
server string = Linux
printing = cups
unix password sync = Yes
workgroup = Games
os level = 200
printcap name = /etc/printcap
security = share
max log size = 0

All my shares are:
writable=yes
public=yes
create mode = 777
directory mode = 777

and the dirs i share are already 777


 
Old 08-08-2003, 04:19 PM   #10
sorrodos
Member
 
Registered: Jul 2003
Location: Salt Lake City, UT and Spokane, WA
Distribution: Mandrake 10.0, Gentoo, FreeSBIE 1.0
Posts: 345

Rep: Reputation: 30
I really don't think you need to downgrade to 98se to do this. A lot of people on my college campus use XP home and can access shares on the domain. Its a little trickier, but it involves mapping a network drive in XP under Explorer.

lflores, make sure your samba users have SAMBA passwords assigned to them. If they are only setup for local access, then they cannot access shares. You have to give them samba passwords using the following command:
smbpasswd -a <username>

I also just read something about a toolset available for download that enables true domain connection for XP home. Try this site but be warned, I've never used this software before.
http://www.xteq.com/products/xset/

On the same site I found that link, I found this way to access domain shares without installing software, I am not sure if it works, but its worth a try.

Open the My Computer object, click the Tools menu, and then click Map Network Drive.
Select a folder on your network by clicking on the Browse button.
After selecting the folder, click on the different user name link on the page.
In the Connect As dialog box, for user name enter domainxxx\user (where domainxxx is the domain you want to connect to). Enter your domain user password and then click OK.
Check the Reconnect at login box and press Finish.
When you boot up in the morning, go to My Computer and double click on the networked drive. This causes XP to send the credentials to the Domain and opens the drive.
Now you will be able to access files and folders throughout the domain without having to reenter network credentials (user name and password)."

The discussion site I found this on is here:http://www.experts-exchange.com/Oper..._20646490.html

Hope this helps you lflores.
 
Old 08-09-2003, 06:42 PM   #11
Da_Quest
Member
 
Registered: Feb 2003
Posts: 49

Rep: Reputation: 15
Hello all,

Be easy on me because I am Da Noob. I read all through the info that was posted and did not see the answer to:

\\samba is not accessible. You might not have permissions to use this network resource. Contact the administrator of this server to find out if you have access permissions. network path not found.

I'm having the same problem. I'm running RH 9.0 and trying to connect to a Win XP box. I so new to RH I don't know how to ping another pc from RH or how to find out what the RH ip is. What do I need to set on the RH side to see my shared folders on my Xp box and what are the commands for the ping/ipconfig (in windows - ping IP, ipconfig to get IP).

I do see the RH computer in my Network Places under XP.


Please help

 
Old 08-09-2003, 10:18 PM   #12
linylion
LQ Newbie
 
Registered: Jul 2003
Location: Lahore (Pakistan)
Distribution: Red Hat Linux
Posts: 9

Rep: Reputation: 0
Hi Iflores!
Firewall software installed on Windows PCs may cause Samba to not function.
i think its the xp built in firewall that is causing problem...
go nd have a look on it, u need to disable it first.

In the Control Panel go through the Network and Internet Connections and then Network Connections menus.

Right click on your LAN connection icon and select Properties
Click on the Advanced tab.
Uncheck the Internet Connection Firewall box.

Another thing u may consider is a prameter in global configurations is "password server", experiment with it; uncomment it nd give a vlaue of net bios name of ur XP machine
if it works fine else gieve netbios name of ur samba machine.
But i m not sure of it's working...at least now.

c ur post soon
 
Old 08-11-2003, 11:54 AM   #13
lflores
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Lion,

All firewalls are off on the clients, but at this point I think I have hurt my conf file pretty bad. So Im looking around for a nother copy of the default conf and I will start with your suggestions on the password server. I can still see it when I do a net view from the one XP pro machine I have but even that pro machine will not connect any longer.
 
Old 08-11-2003, 01:15 PM   #14
daemon_14
Member
 
Registered: Jul 2003
Location: Mesa, AZ
Distribution: CentOS 5 (Cisco Apps), Ubuntu Server (8.10), Ubuntu Desktop (8.10)
Posts: 46

Rep: Reputation: 15
i see that you are adding users...but have you had them "emulate" windows usernames?
the way i got a share-access share working in 98 was to go into my smbusers file and add the line
"family = root" (or the opposite...i can't member which). family being my username on the 98 machine and root being the accout i want it to emulate. i tried to do this with the samba server GUI config...but it is less powerful than text.
if you are using your own username (one that you created, not a Linux default), make sure that you add the user to the "admin" group and that the user has read/write/execute access on the shared volume (if security isn't a big deal, and you don't mind using the root account, i would suggest it, less conflict being a superuser and all). also, if you are using multiple accounts, just have them all emulate the same user for ease.
you also might want to encrypt passwords. i guess windows automatically transmits passwords encrypted (go figure).
i hope this helps

daemon
 
Old 08-11-2003, 05:12 PM   #15
sorrodos
Member
 
Registered: Jul 2003
Location: Salt Lake City, UT and Spokane, WA
Distribution: Mandrake 10.0, Gentoo, FreeSBIE 1.0
Posts: 345

Rep: Reputation: 30
lflores, are you using a distro that uses rpms? If you are, just uninstall the samba packages, and reinstall them. That will give you the old smb.conf back.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba issues trebek Linux - Networking 3 04-28-2005 03:10 PM
samba issues cham0169 Linux - Software 1 04-11-2005 08:37 AM
Samba Issues jetfanroy Linux - Newbie 10 07-29-2003 08:25 AM
Samba Issues TheTrexx Linux - Networking 4 12-16-2002 12:30 PM
Samba issues chris Linux - General 4 11-22-2001 04:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration