LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-03-2005, 06:00 PM   #1
arew264
Member
 
Registered: Jul 2005
Distribution: Arch Linux / Debian Etch (soon) / have tried many others
Posts: 94

Rep: Reputation: 15
Samba in Fedora Core 4


OK, here's the deal. I have a network of 3 Windows XP comps, a Windows 98 comp, and my new linuxbox running FC4 (referred to as the Lagbox). I would like to run Samba on the lagbox so that the windows comps can read and write to a single shared folder in the home directory (/home/shared) without having to use a username and password (I am behind a router and don't have anything i valuable shared). Is there any easy way to do this? Is there a GUI for samba that I could use to set this up? I have tried and the lagbox simple doesn't appear on the network.


Also, the lagbox will not browse my network. Is the Fedora firewall blocking it? I can find no control panel for it, yet it was mentioned in the install.
 
Old 10-03-2005, 06:27 PM   #2
sixerjman
Member
 
Registered: Sep 2004
Distribution: Debian Testing / Unstable
Posts: 180
Blog Entries: 1

Rep: Reputation: 32
Hello! The GUI configuration and management tool for SAMBA is the Samba Web Application Tool aka SWAT. With SWAT you can create, delete and modify shares, restart the SAMBA daemons (SMBD and NMBD, the NetBIOS name service daemon) and view the config files. Check the SAMBA doc at www.samba.org for more information on SWAT.

If you already installed SWAT and still having trouble, here's a couple of gotchas I have encountered:

1. Win98 MUST login to Windows Network Neighborhood with an ID AND Password at startup. The ID / Password combination is sent to Linux/Samba the first time the Win98 machine attempts to view Linux shares. The ID should be present on the Linux machine, but if it isn't, SAMBA will map the ID to a "guest" account. FTP is a good candidate. Also, make sure the SAMBA global option "Encrypt Passwords" is set to "YES", as Win98 will send the password encrypted.

2. Printer sharing for WinXP: In CUPS you must specify an ID of guest@smb://Linuxhostname/printername, otherwise you get a WINNT logon failure or some such.

For debugging, set the log level to >0 in the SAMBA config (smb.conf).

Works for me, I've got 2 Win98s, 3 WinXPs and 1 Debian Linux w/SAMBA and each machine can read/write/print to any other machine.

Good luck! Cheers!
 
Old 10-24-2005, 06:31 PM   #3
sixerjman
Member
 
Registered: Sep 2004
Distribution: Debian Testing / Unstable
Posts: 180
Blog Entries: 1

Rep: Reputation: 32
Samba stuff

Check that printer device URI. The format should be as follows:

smb://guest@//hostname/printername
 
Old 10-26-2005, 11:15 AM   #4
Scheltes
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Rep: Reputation: 0
Hello,

How can I install Swat? I thought Swat comes with Samba, so when Samba has been installed so will swat. I'm puzzled! Swat is not in /etc/xinetd.d/, so I cannot edit swat.

I'v got Fedora core 4 installed. In the Fedora Linux 3 bible it says that the Swat service is by default off. To turn the service on , edit the /etc/xinetd.d/swat and change the disable = yes to disable = no. This makes the service available. Well since I have no swat in /etc/xinitd.d/ I cannot do that.

Can anyone tell me what to do to overcome this problem?
 
Old 10-26-2005, 12:48 PM   #5
Scheltes
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Rep: Reputation: 0
Reading the book I couldn't figure out how to get Swat installed.
Typing "rpm -qa | grep samba" resulted in:
"samba-common-3.0.14a-2
samba-client-3.0.14a-2
samba-3.0.14a-2
system-config-samba-1.2.31-1"

No samba-swat!
In a console I typed as root "yum install samba-swat". Indeed swat was being installed. But in order to turn on the swat service I typed as root in a console: "chkconfig swat on" with the following result: "bash: chkconfig: command not found".

I only did what the book says!

I'm pretty much puzzled.
 
Old 10-27-2005, 03:28 PM   #6
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
By default "PATH" settings for user accounts do not include the /sbin directory where key system utilities like chkconfig are kept. This means that you cannot accidently run a system-altering utility, you have to explicitly put the full path to trigger the tool. In other words:

/sbin/chkconfig --level 345 smb on

Don't use just "chkconfig smb on", because that turns on the service for runlevel 2, aka single-user mode (which is like Safe Mode in Windows). Only critical services should run when the system is in single-user mode.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
samba and fedora core 2 l32 Linux - Networking 5 08-28-2004 10:17 AM
Fedora Core 2 samba server eladla Linux - Networking 3 07-21-2004 01:57 PM
Samba on Fedora Core 2 problems danrfxz Linux - Networking 1 06-30-2004 02:47 PM
samba and fedora core icone Linux - Networking 3 06-15-2004 12:39 PM
Samba And Fedora Core 2 ikenbonnie Linux - Newbie 5 06-05-2004 10:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration