LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-17-2004, 10:06 PM   #1
levand
LQ Newbie
 
Registered: Nov 2004
Posts: 14

Rep: Reputation: 0
Samba host names - how?


Hi

I am using a samba client on a Linux box (Suse 9.1) and Samba server on
Mac OS X. If I turn off the Suse firewall, everything works well, I am
able to mount shares on my linux box using:

"mount -t smbfs -o username=name,passwd=password //mac-host/share /mnt

I have enabled pass-through on ports 137 138 and 139 in the Suse firewall,
and turned it on. But, there is a problem now:

I no longer can use "mac-host" in the above command. It complains, that it can not
resolve the name. If I use IP address instead of the "mac-host" - it works fine.

So, somehow name resolution is blocked. Is there another port I should turn on
in the firewall to enable it again?

I have used the GUI setup (from Yast) for the Suse firewall, and it does not mention
whether these ports refer to TCP or UDP. I assume that when I enter
a number it turns on both TCP and UDP, but I am not sure.
Does anyone know if this gui allows explicit statements, e.g., 139/UDP?

Thanks.
 
Old 11-17-2004, 11:53 PM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Not sure aobut YaST but you need to enable udp port 137 and 138, or just put it in /etc/hosts
 
Old 11-18-2004, 04:11 AM   #3
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,910

Rep: Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890
I think you must also open tcp port 445 (microsoft-ds)
 
Old 11-18-2004, 05:01 AM   #4
jmajor
Member
 
Registered: Nov 2004
Location: Australia
Distribution: Fedora, Ubuntu
Posts: 55
Blog Entries: 2

Rep: Reputation: 17
The name daemon (nmbd) uses some udp ports from that set (139 I think) and if you only enabled tcp ports through the firewall you would only be able to address your mac as //ip-address.

You might also considder a blanket accept for tcp / udp between the Mac's ip address and linux. That would depend on your level of paranoia and the amount of internet in between.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
multiple host names tux1982 Linux - Networking 3 06-08-2004 07:35 AM
Changing How Host Names are Looked Up civicsi Linux - Newbie 2 04-24-2004 08:18 AM
BIND 9 won't reslove host names jglazner Linux - Networking 4 02-23-2004 07:42 PM
SAMBA: display of share names is OK but files names are wrong superandrzej Linux - Software 5 02-02-2004 10:14 AM
host names??? jonfa Linux - Networking 1 05-28-2001 09:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration