-   Linux - Networking (
-   -   samba:home dir cache problem (

wiredX 01-23-2004 09:10 AM

samba:home dir cache problem

I am using Redhat 9 as a samba server. And I have 1 windows XP client with 6 users on it ,that connect to the server,very well.

In my smb.conf I have set the security flag to share... and users can get into their home directories.Now the problem is with the "home directory caching", when userA logs in to the server ,accessing files and his home directory and then loggin out... thats works out fine.

AND then when "userB" logs in to the server using his xp account (that is after userA has logged out from the XP machine letting userB use the machine), userB now sees userA home directory.

Now ... I don,t want that to happen ... I want whenever a user is logged in to the samba server to see only his home directory. And I know that is possible only when restarting a machine.

How can I fix that?

-Thanx in advance...

peter_robb 01-26-2004 10:02 AM

"Roaming Profiles" is one way, (only for XP Pro) and it's not too easy to setup, see

If you're using XP Home, the choices are even fewer..
coz the logged in computer name holds the share "username", you will have to share the directory above the actual user's shares and rely on directory permissions and passwords to stop access to other people's directories..

Another option could be to unmount the directories after they log off.
Place the user files in a separate directory, eg /files and mount them as /home/username when they access them after logging on.
It uses the pre-exec & post-exec commands like mounting/unmounting a cdrom share..

All times are GMT -5. The time now is 05:34 AM.