-   Linux - Networking (
-   -   samba frustration (

solar1951 07-13-2007 06:59 AM

samba frustration
Have looked through several threads but cant find solution to this problem

I have 2 machines running Ubuntu and 3 others on the network running Windows.
Machine number 1 running Ubuntu can access all the other shared folders on the network via samba
If I go to places/network servers/windows network/workgroup/ i have a list of all the machines on the network as expected.
If I select machine 1 on this network I see the shared folder "music" which has been set up to be the shared folder on that machine, but when I click on it I get the message that this "folder cannot be found - perhaps it has been deleted"

This is obviously not the case as I can get to it using nautilus.

How can I get samba to recognise this shared folder ?

My samba.conf looks OK

path = /home/bill/Music
available = yes
browsable = yes
public = yes
writable = yes

Any ideas as this is really bugging me

Simon Bridge 07-13-2007 07:44 AM

I see the shared folder "music"

path = /home/bill/Music

Linux is case sensitive...

solar1951 07-13-2007 09:36 AM


Originally Posted by Simon Bridge
I see the shared folder "music"

path = /home/bill/Music

Linux is case sensitive...

They are the same, just a typo in my post !

Simon Bridge 07-13-2007 10:01 PM

Perhaps security=user in /etc/samba/smb.conf ?

solar1951 07-14-2007 11:33 AM


Originally Posted by Simon Bridge
Perhaps security=user in /etc/samba/smb.conf ?

security=user is commented out
In fact the smb.conf file on machine 1 and machine 2 are identical and both running Ubuntu - 1 is running edgy and 2 is running feisty :confused:

Could it be related to size limitations within samba as the Music folder contains around 7 Gig ?

I think I will upgrade machine 1 to feisty and try again. I used to have Fedora 5 on this machine and overwrote that with Ubuntu could there be something left in my /home directory from SELinux that is screwing around ?

Thanks for your help anyway:cool:

Simon Bridge 07-14-2007 06:03 PM

perhaps the feisty machine dosn't have a samba users list, or the shared user isn't on the list? Perhaps the server has that machine on hosts.deny (or not on hosts.allow). Perhaps the server firewall is blocking you?

Note: if you kept your old /home from fedora, there may well be some local setting messing with things for you. You may need to eyeball hidden files for anything suspicious.

A quick way to eliminate this would be to create a new usec on the feisty box (set up to access your network and samba etc like everyone else) and try accessing the share. If you can, then you know it is the user, not the host. Otherwise, it must be the host.

solar1951 07-16-2007 08:11 AM

OK, have started to get somewhere.
Created a new user and a shared folder and was able to access with samba no problem, so I guess its something in my /home partition thats causing the problem.
Have had a quick glance but nothing stands out as a possible cause.Will do further digging.
Any hints ?

Thanks for your time from the other side of the world.
Am sitting in France waiting for the Rugby world cup in september - any ideas who maybe favorite ;)

Simon Bridge 07-16-2007 08:36 PM

So now, instead of a forbidden host, you have a forbidden user.
The simplest and fastest approach is to create a new user with the old username.

Move the users home directory first:

mv /home/username /home/username.old

(delete the user ... you'll want to do this from a root account, or an admin account.)

You can copy the files over.
The only drawback is going over customizing the settings again.

It is possible that this user has been forbidden (or not allowed) on the other servers.

solar1951 07-18-2007 02:11 AM

I think I will wait for Gutsy to become available in October and do a clean sweep of the /home directory then or I may set up NFS shares between the two linux machines.

Thanks for your input

Simon Bridge 07-18-2007 05:04 AM

hmmm... interestingly I learned linux networking before I learned it on windows. I have the opposite problems to everybody else!

Anyway, that user test should be very fast... if the username works then you get your shares up tomorrow.

All times are GMT -5. The time now is 05:16 PM.