LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Samba Failed to find entry for user (https://www.linuxquestions.org/questions/linux-networking-3/samba-failed-to-find-entry-for-user-50540/)

david_wliu 03-18-2003 08:51 PM

Samba Failed to find entry for user
 
I was trying to create a samba user using smbpasswd command as follows:

smbpasswd mySmbUser

After typing the New Password and Confirmed Password as prompted. I got the following errors:

Failed to find entry for user mySmbUser
Failed to modifi password entry for user mySmbUser

I even add mySmbUser to the linux account, but still have the same problem.

Any suggestions?

tangle 03-18-2003 08:56 PM

You need to add that user locually. Try:
useradd mySmbUser
Then:
smbpasswd -a mySmbUser

david_wliu 03-18-2003 10:14 PM

It works. The problem was the missing option -a in my previous attempts using smbpasswd command. Thanks alot.

tuewru 02-22-2010 11:31 AM

Quote:

Originally Posted by tangle (Post 252306)
You need to add that user locually. Try:
useradd mySmbUser
Then:
smbpasswd -a mySmbUser

thanks tangle
my problem solved
i lack -a option in command and it not work :|

twwwater 07-02-2010 12:28 PM

same problem, thanks !!!

f13dummy 09-15-2010 04:39 AM

thx
 
thx a lot, same problem, solved

hamidi2 12-18-2012 01:55 AM

does it add the user to Linux? i can't have a samba user which is not a Linux user?

achalfauzdar 05-16-2013 11:10 AM

Really thankyou it works for me

msalwa 12-14-2013 09:13 AM

Quote:

Originally Posted by david_wliu (Post 252296)
I was trying to create a samba user using smbpasswd command as follows:

smbpasswd mySmbUser

After typing the New Password and Confirmed Password as prompted. I got the following errors:

Failed to find entry for user mySmbUser
Failed to modifi password entry for user mySmbUser

I even add mySmbUser to the linux account, but still have the same problem.

Any suggestions?

Thank's a lot.

msalwa 12-14-2013 09:15 AM

Quote:

Originally Posted by tangle (Post 252306)
You need to add that user locually. Try:
useradd mySmbUser
Then:
smbpasswd -a mySmbUser

Thank's a lot.
Its work really.


All times are GMT -5. The time now is 04:49 PM.