LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-19-2004, 08:56 AM   #1
montylee
Member
 
Registered: May 2003
Location: India
Distribution: Ubuntu 7.04, Fedora Core 9
Posts: 168

Rep: Reputation: 30
Question Samba Configuration problem


Hi all,

I am facing a problem accessing my samba share from windows.

I have configured the samba server and it works properly.
I can see the windows network computers through LinNeighborHood.

I can see my samba server in Network Neighborhood in Windows but when i double click on it, it gives the following error:

"Network path not found"

I understand that i need to do some configuration in Windows but don't know what and how to do.

Please somebody help me!!!
 
Old 11-19-2004, 12:32 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Could you post the smb.conf for viewing? Have you created an account on the windows machine to match the *nix user and smb user? Are you running a firewall on either machine?
good luck.
 
Old 11-19-2004, 11:28 PM   #3
kyiydnlm
LQ Newbie
 
Registered: Nov 2004
Posts: 6

Rep: Reputation: 0
It might be a name resolution problem. Try the link on an IE window: \\192.168.*.* (your server's ip address), if it makes a correct connection, you need to configure your DNS server and WINS server.
 
Old 11-22-2004, 12:05 AM   #4
montylee
Member
 
Registered: May 2003
Location: India
Distribution: Ubuntu 7.04, Fedora Core 9
Posts: 168

Original Poster
Rep: Reputation: 30
I have configured samba and accessed the Linux shares in Windows earlier but now i am facing this problem.
I can ping the windows computers in Linux by using ip-address as well as computer-names. When i try to ping Linux computer in windows using ip-address it succeeds, when i try it using computer-name, it fails. So, i guess there is a problem with name resolution.
Still when i type \\ip-address on windows it displays the following error:

"The Network path was not found"

What i did is follows:
I wrote the samba configuration file, added a user using smbpasswd.
Restarted the /etc/init.d/smb service. Ran testparm. Added the same user in Windows with same password.
So, i guess i did everything i could do.
Here is the smb.conf file contents:

[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = mygroup

# server string is the equivalent of the NT Description field
server string = samba server
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
dns proxy = no

[raman]
comment = Raman's Home Directory
path = /home/ramandeeps
valid users = ramandeeps
browseable = yes
guest ok = yes
writeable = yes
printable = no

Background info:
We have a company network running a proxy-server, dns server etc.
This may be the cause of the problem...

Please help me ???
 
Old 11-22-2004, 07:01 AM   #5
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Try adding the netbios name option under global.
Code:
[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = mygroup
netbios name = your computer name
good luck.
 
Old 11-22-2004, 09:45 AM   #6
gani
Member
 
Registered: Jun 2004
Location: Metro Manila, Philippines
Distribution: OpenBSD, Slackware, XP
Posts: 347

Rep: Reputation: 31
Add in your [global] configurations:

hosts allow = your.class-C network.address.0/24 127.0.0.1
interfaces = your internal network NIC IP address
security = user
os level = 33 # if your windows are 2000/XP
;os level = 20 # uncomment if your windows are 95/98/ME

This will just equaled with your windows hosts the chanses of winning the browsing elections. Or if you wish you can raise this to 35 to force all your windows hosts to just allow your Samba server to become the master browser always. In this case try to add this also:

preferred master = yes

In your [raman] share try to add:

directory mode = 0775
create mode = 0775

This will prevent others/world permission to just 5 (r,x) only whenever directories or files are created. Or it is up to you to limit this further. Just change this and the permissions you will apply.

Test it using:

# smbclient -L localhost

This should show the shares in samba server box.

or before issuing this:

# testparm

To chk if there are some config error.

Since you put "valid users" string try to remove "guest ok = yes" coz this might bypass your valide users string.

You need to create "ramandeeps" user in Unix and as well as in /etc/samba/smbpasswd database and try to apply 775 permissions to ramandeeps directory (or your choice of permissions). It should be owned by root and ramandeeps users only.
 
Old 11-23-2004, 04:22 AM   #7
montylee
Member
 
Registered: May 2003
Location: India
Distribution: Ubuntu 7.04, Fedora Core 9
Posts: 168

Original Poster
Rep: Reputation: 30
I did all that u proposed but the error persists.
I can mount windows shares and log on to windows shares using samba but when i try to access samba shares from windows i get the error i mentioned earlier.
I can ping my Linux computer using ip-address from windows but when i try to ping using computer-name it fails.
I can ping windows computers from Linux using ip-address as well as computer-names.
Any suggestions
 
Old 11-23-2004, 06:56 AM   #8
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Could you post the current smb.conf, and have you added the proper user accounts on the windows machine?
good luck.
 
Old 11-23-2004, 10:14 PM   #9
montylee
Member
 
Registered: May 2003
Location: India
Distribution: Ubuntu 7.04, Fedora Core 9
Posts: 168

Original Poster
Rep: Reputation: 30
Hi,
I have added a user in windows with same name and password as the samba user in Linux.
Here is my smb.conf file:
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options (perhaps too
# many!) most of which are not shown in this example
#
# Any line which starts with a ; (semi-colon) or a # (hash)
# is a comment and is ignored. In this example we will use a #
# for commentry and a ; for parts of the config file that you
# may wish to enable
#
# NOTE: Whenever you modify this file you should run the command "testparm"
# to check that you have not made any basic syntactic errors.
#
#======================= Global Settings =====================================
[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = netcentric

# server string is the equivalent of the NT Description field
server string = samba server

# This option is important for security. It allows you to restrict
# connections to machines which are on your local network. The
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
; hosts allow = 192.168.1. 192.168.2. 127.

# if you want to automatically load your printer list rather
# than setting them up individually then you'll need this
printcap name = /etc/printcap
load printers = yes

# It should not be necessary to spell out the print system type unless
# yours is non-standard. Currently supported print systems include:
# bsd, sysv, plp, lprng, aix, hpux, qnx, cups
printing = cups

# Uncomment this if you want a guest account, you must add this to /etc/passwd
# otherwise the user "nobody" is used
; guest account = pcguest

# this tells Samba to use a separate log file for each machine
# that connects
log file = /var/log/samba/%m.log

# Put a capping on the size of the log files (in Kb).
max log size = 0

# Security mode. Most people will want user level security. See
# security_level.txt for details.

# Use password server option only with security = server
# The argument list may include:
# password server = My_PDC_Name [My_BDC_Name] [My_Next_BDC_Name]
# or to auto-locate the domain controller/s
# password server = *
; password server = <NT-Server-Name>

# Password Level allows matching of _n_ characters of the password for
# all combinations of upper and lower case.
; password level = 8
; username level = 8

# You may wish to use password encryption. Please read
# ENCRYPTION.txt, Win95.txt and WinNT.txt in the Samba documentation.
# Do not enable this option unless you have read those documents
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd

# The following is needed to keep smbclient from spouting spurious errors
# when Samba is built with support for SSL.
; ssl CA certFile = /usr/share/ssl/certs/ca-bundle.crt

# The following are needed to allow password changing from Windows to
# update the Linux system password also.
# NOTE: Use these with 'encrypt passwords' and 'smb passwd file' above.
# NOTE2: You do NOT need these to allow workstations to change only
# the encrypted SMB passwords. They allow the Unix password
# to be kept in sync with the SMB password.
unix password sync = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*

# You can use PAM's password change control flag for Samba. If
# enabled, then PAM will be used for password changes when requested
# by an SMB client instead of the program listed in passwd program.
# It should be possible to enable this without changing your passwd
# chat parameter for most setups.

pam password change = yes

# Unix users can map to different SMB User names
; username map = /etc/samba/smbusers

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
; include = /etc/samba/smb.conf.%m

# This parameter will control whether or not Samba should obey PAM's
# account and session management directives. The default behavior is
# to use PAM for clear text authentication only and to ignore any
# account or session management. Note that Samba always ignores PAM
# for authentication in the case of encrypt passwords = yes

obey pam restrictions = yes

# Most people will find that this option gives better performance.
# See speed.txt and the manual pages for details
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

# Configure Samba to use multiple interfaces
# If you have multiple network interfaces then you must list them
# here. See the man page for details.
; interfaces = 192.168.12.2/24 192.168.13.2/24

# Configure remote browse list synchronisation here
# request announcement to, or browse list sync from:
# a specific host or from / to a whole subnet (see below)
; remote browse sync = 192.168.3.25 192.168.5.255
# Cause this host to announce itself to local subnets here
; remote announce = 192.168.1.255 192.168.2.44

# Browser Control Options:
# set local master to no if you don't want Samba to become a master
# browser on your network. Otherwise the normal election rules apply
; local master = no

# OS Level determines the precedence of this server in master browser
# elections. The default value should be reasonable
; os level = 33

# Domain Master specifies Samba to be the Domain Master Browser. This
# allows Samba to collate browse lists between subnets. Don't use this
# if you already have a Windows NT domain controller doing this job
; domain master = yes

# Preferred Master causes Samba to force a local browser election on startup
# and gives it a slightly higher chance of winning the election
; preferred master = yes

# Enable this if you want Samba to be a domain logon server for
# Windows95 workstations.
; domain logons = yes

# if you enable domain logons then you may want a per-machine or
# per user logon script
# run a specific logon batch file per workstation (machine)
; logon script = %m.bat
# run a specific logon batch file per username
; logon script = %U.bat

# Where to store roving profiles (only for Win95 and WinNT)
# %L substitutes for this servers netbios name, %U is username
# You must uncomment the [Profiles] share below
; logon path = \\%L\Profiles\%U

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable it's WINS Server
wins support = yes

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
; wins server = w.x.y.z

# WINS Proxy - Tells Samba to answer name resolution queries on
# behalf of a non WINS capable client, for this to work there must be
# at least one WINS Server on the network. The default is NO.
; wins proxy = yes

# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
# via DNS nslookups. The built-in default for versions 1.9.17 is yes,
# this has been changed in version 1.9.18 to no.
username map = /etc/samba/smbusers
dns proxy = no

# Case Preservation can be handy - system default is _no_
# NOTE: These can be set on a per share basis
; preserve case = no
; short preserve case = no
# Default case is normally upper case for all DOS files
; default case = lower
# Be very careful with case sensitivity - it can break things!
; case sensitive = no

#============================ Share Definitions ==============================
[homes]
comment = Home Directories
browseable = no
writeable = yes
valid users = %S
create mode = 0664
directory mode = 0775
# If you want users samba doesn't recognize to be mapped to a guest user
; map to guest = bad user


# Un-comment the following and create the netlogon directory for Domain Logons
; [netlogon]
; comment = Network Logon Service
; path = /usr/local/samba/lib/netlogon
; guest ok = yes
; writable = no
; share modes = no


# Un-comment the following to provide a specific roving profile share
# the default is to use the user's home directory
;[Profiles]
; path = /usr/local/samba/profiles
; browseable = no
; guest ok = yes


# NOTE: If you have a BSD-style print system there is no need to
# specifically define each individual printer
[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
# Set public = yes to allow user 'guest account' to print
printable = yes

# This one is useful for people to share files
;[tmp]
; comment = Temporary file space
; path = /tmp
; read only = no
; public = yes

# A publicly accessible directory, but read only, except for people in
# the "staff" group
;[public]
; comment = Public Stuff
; path = /home/samba
; public = yes
; writable = yes
; printable = no
; write list = @staff

# Other examples.
#
# A private printer, usable only by fred. Spool data will be placed in fred's
# home directory. Note that fred must have write access to the spool directory,
# wherever it is.
;[fredsprn]
; comment = Fred's Printer
; valid users = fred
; path = /home/fred
; printer = freds_printer
; public = no
; writable = no
; printable = yes

# A private directory, usable only by fred. Note that fred requires write
# access to the directory.
[raman]
comment = Raman's Home Directory
path = /home/ramandeeps
valid users = ramandeeps
browseable = yes
guest ok = yes
writeable = yes
printable = no

# a service which has a different directory for each machine that connects
# this allows you to tailor configurations to incoming machines. You could
# also use the %U option to tailor it by user name.
# The %m gets replaced with the machine name that is connecting.
;[pchome]
; comment = PC Directories
; path = /usr/local/pc/%m
; public = no
; writable = yes

# A publicly accessible directory, read/write to all users. Note that all files
# created in the directory by users will be owned by the default user, so
# any user with access can delete any other user's files. Obviously this
# directory must be writable by the default user. Another user could of course
# be specified, in which case all files would be owned by that user instead.
;[public]
; path = /usr/somewhere/else/public
; public = yes
; only guest = yes
; writable = yes
; printable = no

# The following two entries demonstrate how to share a directory so that two
# users can place files there that will be owned by the specific users. In this
# setup, the directory should be writable by both users and should have the
# sticky bit set on it to prevent abuse. Obviously this could be extended to
# as many users as required.
;[myshare]
; comment = Mary's and Fred's stuff
; path = /usr/somewhere/shared
; valid users = mary fred
; public = no
; writable = yes
; printable = no
; create mask = 0765

I hope this helps!!!
 
Old 11-24-2004, 12:02 AM   #10
gani
Member
 
Registered: Jun 2004
Location: Metro Manila, Philippines
Distribution: OpenBSD, Slackware, XP
Posts: 347

Rep: Reputation: 31
Try these:

[global]

1. Uncomment the "hosts allow" and change the network IP according to your LAN. Loopback should always be here.

2. Uncomment the "interfaces" and change the IP to the IP of your NIC connected to your LAN. Leave just your NIC's IP.

3. Uncomment [tmp] share just to test if things are already working. Just comment it back later if your finished.

4. Put comment to wins support.

security = user
netbios name = your-samba-box hostname

I have successfully tested just simple file sharing without security (just "share") and even with (security = share) and NT domain. I did not require me to create on Windows clients my samba users.

If your using XP enable "Netbios Over TCP/IP" in the "Advance" settings of TCP/IP.

If you want your windows clients be able to ping others using hostname there should be "lmhosts" (just like the /etc/hosts) file in each box. But I don't anymore use this.

Are both daemons running - smbd and nmbd?

Check this out.
 
Old 11-24-2004, 12:08 AM   #11
gani
Member
 
Registered: Jun 2004
Location: Metro Manila, Philippines
Distribution: OpenBSD, Slackware, XP
Posts: 347

Rep: Reputation: 31
Don't forget that your Windows machines should all belong to your "netcentric" workgroup.
 
Old 11-24-2004, 01:08 AM   #12
montylee
Member
 
Registered: May 2003
Location: India
Distribution: Ubuntu 7.04, Fedora Core 9
Posts: 168

Original Poster
Rep: Reputation: 30
Talking

Hi all.
The problem is solved.


Only thing i did was to stop the iptables service.

# service iptables stop

and it worked.
I am so happy.

Thanks a lot to all of u for ur support.

Keep using GNU/Linux.........
 
Old 11-24-2004, 05:57 AM   #13
gani
Member
 
Registered: Jun 2004
Location: Metro Manila, Philippines
Distribution: OpenBSD, Slackware, XP
Posts: 347

Rep: Reputation: 31
May be your firewall is not allowing local traffic through ports 137 & 445.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba configuration problem Vijayasarathy Linux - General 3 03-09-2005 11:45 PM
Problem in Samba Configuration Ahmad Gurchani Linux - Networking 2 01-01-2005 08:48 AM
Samba configuration help Krenn Slackware 3 07-30-2004 07:22 PM
samba configuration problem (?) schbond Linux - Networking 3 06-13-2003 08:38 PM
samba configuration problem keirobyn Linux - Networking 3 03-19-2002 12:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration