LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Samba authentication issues: IP/Network name (https://www.linuxquestions.org/questions/linux-networking-3/samba-authentication-issues-ip-network-name-196826/)

juiced 06-23-2004 10:27 AM

Samba authentication issues: IP/Network name
 
Hi and thanks in advance for your help!!

Anyone had and resolved the following problem?:

Installed Samba 3.0.4 on Redhat 9 . Configured my smb.conf and joined my Win 2K domain by running 'net ads join -U my_user '

Join was successful and Redhat machine is visible in Network Places and I can ping it via it's name or IP. It is also visible in AD Users and Computers. So far so good. When I try to browse the machine from Win XP I get:


"\\my_redhat_machine is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

The account is not authorized to log in from this station."

If i type \\1.1.1.1 where 1.1.1.1 is my IP address, i can browse the Samba shares with all the read/write permissions I have requested in smb.conf. It's a bit of an annoyance as we have data stored on there that needs to be accessed via the machine name, not the IP. If anyone can help me out, i'd be eternally grateful.

jerryluis 06-23-2004 01:59 PM

Hi, I'm newbie of Samba, but this problem is known.
The solution is to set samba security as "user" no "share".
You can find better support from www.samba.org.
You can find very simple guide from documents, the first two guides in .pdf format can help you.
I downloaded them same days ago and now I'm trying to study it.
bye

juiced 06-24-2004 03:58 AM

Thanks for the reply but i have tried the solution you have proposed without any success previously.

andrewdodsworth 06-24-2004 04:36 AM

Could be no help at all because I only have Samba as a domain controller and have avoided AD thus far although I presume it's a bit like Novell NDS!

Presumably you define who can do what to whom on the Win2k box or however you manage AD. The Samba server stuff can control access to its shares but only if the relevant user/machine/container/whatever has been granted access wherever you grant that. I know this sounds very vague but what I'm trying to say is that I think it's a permissions problem that needs to be solved in AD rather than at the Samba end.

juiced 06-24-2004 05:28 AM

Cheers for the reply andrew. I've a feeling it is an Active Directory problem too but haven't been able to track it down. If i get the solution, i'll post it up anyway.

Thanks for everyone's help. Great forum this!!!

Finlay 07-12-2004 12:13 AM

You need to add users from AD as users or administrators on your windoze box


All times are GMT -5. The time now is 05:39 PM.