LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-30-2004, 09:52 AM   #1
Fordor
Member
 
Registered: Jun 2004
Location: Tallinn
Distribution: Slackware/Crux/SuSE
Posts: 84

Rep: Reputation: 15
Samba & XP stupid problem


I am trying to setup a home network based on a canyon router. Both PCs(one XP@1400MHz&256RAM second console only Slackware 10@166MHz&32RAM) can access the internet just fine, both can ping each other and connect to open services(FTP, SSH, Telnet), so the network itself works ok.
I am trying to setup a share on the Slack PC, but XP sees the shares, but tying to enter them give me an access denied error. I have read a lot of posts here about this and tried different configs, but nothing helped.

Here is my smb.conf:

[global]
workgroup = WORKGROUP
server string = Panzer
security = user
encrypt passwords = yes
smb passwd file = /etc/samba/private/smbpasswd

[homes]

[myshare]
path = /home/ftp
browseable = yes
public = yes
read only = no


####End of config#########

I really don't understand what am I missing.
By the way when starting samba in interactive move it displays an
api_fd_reply : INVALID PIPE HANDLE: 753f

Please tell me how to fix this problem, as I don't know what to do now.

Thank you
Dennis
 
Old 07-30-2004, 11:52 AM   #2
Vincent_Vega
Member
 
Registered: Nov 2003
Location: South Jersey
Distribution: Slackware, Raspbian, Manjaro
Posts: 826

Rep: Reputation: 31
You could try adding 'guest ok = yes' to your share options. Are you entering a username and password to access the share? Have you setup a password on the linux box using smbpasswd? I assume you have but just checking.
 
Old 07-30-2004, 01:21 PM   #3
Fordor
Member
 
Registered: Jun 2004
Location: Tallinn
Distribution: Slackware/Crux/SuSE
Posts: 84

Original Poster
Rep: Reputation: 15
I have tried adding the guest ok = yes option to the shared directory and added the passwords with smbpasswd, but the strange thing is that the password doen't get requested it just says access denied.
 
Old 07-30-2004, 07:14 PM   #4
Vincent_Vega
Member
 
Registered: Nov 2003
Location: South Jersey
Distribution: Slackware, Raspbian, Manjaro
Posts: 826

Rep: Reputation: 31
Can you mount it using the smbmount command including a username and password?
 
Old 07-31-2004, 01:31 AM   #5
Fordor
Member
 
Registered: Jun 2004
Location: Tallinn
Distribution: Slackware/Crux/SuSE
Posts: 84

Original Poster
Rep: Reputation: 15
No, I can't. There must be some config error in the smb.conf, but I don't know what is it.
 
Old 07-31-2004, 10:53 AM   #6
nitroid
Member
 
Registered: Jul 2004
Location: Finland
Distribution: Arch and Maemo (N900)
Posts: 32

Rep: Reputation: 15
This is from my smb.conf:

Code:
[homes]
browseable=No
comment=Home Directories
inherit permissions=Yes
read only=No
valid users=%S
That last line above may be what you're missing. Without that all the boxes on the workgroup can see the shares, but not access them.
 
Old 07-31-2004, 11:21 AM   #7
Fordor
Member
 
Registered: Jun 2004
Location: Tallinn
Distribution: Slackware/Crux/SuSE
Posts: 84

Original Poster
Rep: Reputation: 15
OK, I have copied this example as my smb.conf, so now I get a straight access denied message. I can see the capacity of the network drive even, but when I click on it windows can't access it.
There is some other thing : when I try to enter a login for the network drive windows first asks me for a drive and then shows the login box again with a disabled login name field which says 192.168.62.51\Guest
I don't know why it shows as guest, maybe that's why access is denied?

Hope you have some ideas about this.
 
Old 07-31-2004, 11:21 AM   #8
Fordor
Member
 
Registered: Jun 2004
Location: Tallinn
Distribution: Slackware/Crux/SuSE
Posts: 84

Original Poster
Rep: Reputation: 15
By the way, there is some stopped service winbindd , do I need to start that also?
 
Old 07-31-2004, 01:20 PM   #9
Vincent_Vega
Member
 
Registered: Nov 2003
Location: South Jersey
Distribution: Slackware, Raspbian, Manjaro
Posts: 826

Rep: Reputation: 31
can you change the username to a real account on the linux box and try using its password?
If you can't even do that, I would think that something went wrong with the Samba installation. You don't need winbindd. Just smbd and nmbd.
Do you have any type of firewall running that could be blocking it?
 
Old 07-31-2004, 01:45 PM   #10
Fordor
Member
 
Registered: Jun 2004
Location: Tallinn
Distribution: Slackware/Crux/SuSE
Posts: 84

Original Poster
Rep: Reputation: 15
I am already using the real username. My windows accounts are the same as linux ones(except for the built-in windows admin and root).
Why does windows sometimes show only the username when logginng in and sometimes the_host_address/username?

And I didn't install any firewall apps, so all ports are opened. I'm beginning to worry about this config problem.
 
Old 07-31-2004, 02:48 PM   #11
Vincent_Vega
Member
 
Registered: Nov 2003
Location: South Jersey
Distribution: Slackware, Raspbian, Manjaro
Posts: 826

Rep: Reputation: 31
I'm not on a linux computer right now so I can't really go too deep into this problem for you myself but I think I would suggest removing Samba and reinstalling.
Are you sure that you have SMB support in your kernel? That might be a dumb question since you can see the shares but I'm trying to think of anything I can.
 
Old 07-31-2004, 02:50 PM   #12
Vincent_Vega
Member
 
Registered: Nov 2003
Location: South Jersey
Distribution: Slackware, Raspbian, Manjaro
Posts: 826

Rep: Reputation: 31
Also, what are the permissions on the shared folder in linux? If you've set them to 700 or maybe even 770 you could be locked out by linux, not samba. Check that first.
 
Old 07-31-2004, 03:15 PM   #13
Fordor
Member
 
Registered: Jun 2004
Location: Tallinn
Distribution: Slackware/Crux/SuSE
Posts: 84

Original Poster
Rep: Reputation: 15
Yes, the permissions are ok, they are set to 777 for the directory that I am sharing, but I didn't have smb support, however the kernel compiler menu says that it is needed only for mounting windows shares and not the other way around. Should I compile it in anyway?
 
Old 07-31-2004, 04:18 PM   #14
Vincent_Vega
Member
 
Registered: Nov 2003
Location: South Jersey
Distribution: Slackware, Raspbian, Manjaro
Posts: 826

Rep: Reputation: 31
yes
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba & ms Office Problem Gavin Linux - Software 2 11-29-2005 05:21 PM
samba & netlogon problem CarLost Linux - Networking 8 09-15-2005 04:28 AM
Samba & LDAP problem barkers Linux - Networking 8 10-06-2004 04:18 AM
Samba & PDF problem craddy Linux - Software 7 01-26-2004 04:49 AM
Yet Another Stupid Samba Problem [SuSE 8.1] shassouneh Linux - Networking 15 02-06-2003 04:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration