-   Linux - Networking (
-   -   samba and permissions Problems (

cvc505 08-06-2004 03:31 PM

samba and permissions Problems
Greetings all, Some day I think I will write a book about how to set up samba.

I have two problem:
First, permissions, I have a vfat partition on my suse9.0 server that I am trying to share as a samba drive to my win2k work stations. My Fstab has the following line in it:

/dev/ida/c0d0p9 /dos vfat rw,user,umask=0000 00

When logged in as root I do the following chown command:

chown CAD:CAD -R /dos

I get a message the says: "operation not permitted"
The current owner is root and current group for /dos is root. I have also tried to do chmod 666/dos and get the same results.

The second problem related to the first somewhat; I have samba3 installed on this machine with the following smb.conf file:


read only=no

From my winXP machine I am not able to see the linux box in my network neighborhood but I came search for it and will find it. Although at one point in the setup I was able to see it in the network neighborhood. Since my permissions are wrong, I am able to read files stored in the /dos partition by root but am not able to save a file on this partition.

Anybody have any suggestions as to how to fix these issues?

jadermf 08-06-2004 03:40 PM

chown CAD.CAD -R /dos

cvc505 08-06-2004 04:09 PM

Samba and security
Nope: Tried that and still get the same operation note permitted. mesage.

JayCnrs 08-06-2004 05:15 PM

The 00 at the end needs a space in fstab, plus if you have a certain user you want to own or group put in after umask=0000,uid=(user id to be owned by),gid=(group you want to be registered). So from what I can see above you would need:

/dev/ida/c0d0p9 /dos vfat rw,user,umask=0000,uid=CAD,gid=CAD 0 0

HTH :)

All times are GMT -5. The time now is 05:47 PM.