LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-31-2003, 07:22 PM   #1
r1_97
LQ Newbie
 
Registered: Jul 2003
Location: san diego
Distribution: SusE 9.0
Posts: 10

Rep: Reputation: 0
samba - 1 way street


Red Hat 9 box can access Windows Xp (Home) share "C" drive but Windows cannot find Linux box in Network places. Both computers use the same password and user and workgroup names.

Is there some step by step instruction to test, fix, reinstall, whatever, the Windows side? Both computers are connected to the same 4 port router and work fine independently.

Here is smb.conf file:

# Date: 2003/07/25 17:18:37

# Global parameters
[global]
workgroup = ROSEN
server string = Samba Server
encrypt passwords = Yes
hosts allow = 192.168.1 127
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*al
l*authentication*tokens*updated*successfully*
unix password sync = Yes
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = No
username map = /etc/samba/smbusers
printing = cups

[homes]
comment = Home Directories
writeable = yes
create mask = 0664
directory mask = 0775

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[linux]
path = /tmp
writeable = yes
#this tells Samba to use a separate log file for each machine that connects
log file = /var/log/samba/%m.log
log level = 5
[root@linux samba]#
 
Old 07-31-2003, 07:40 PM   #2
dubman
Member
 
Registered: Jan 2003
Distribution: Redhat 9, Fedora Core 1, Suse 8
Posts: 188

Rep: Reputation: 30
instead of using network places, try mapping to the samba share.

You will need to configure your smb.conf located at /etc/samba/ to allow for this.

Make sure to restart the samba dameon
#service smd restart

You will also need to add a samba user
#smbadduser "username"

This user will also need a UNIX account on that system.

then configure the smbuser's password with
#smbpasswd "username"

If you want to be able to access the share from your windows box without any prompts, make sure to make the user names and passwords the same as the user account on the windows box.

--hope this helps

--dubman
 
Old 08-01-2003, 03:45 AM   #3
inet_man
LQ Newbie
 
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
Do you have iptables running? If so this may not be a samba problem at all.

I had the same problem, and found it was due to the iptables rules blocking netbios connections (used to access a samba share)

To check, run iptables --list if you get a set of rules it is on, to see if this is the problem you can try turning off the rules temporarily.

as root run iptables -F this will drop all rules.

try to access you shares and if it works you have found the problem.

[ you can turn your iptables rules back on afterwards using :

service iptables restart (always a good idea ]

if you can then access your shares from your windows box then check the following thread, and look at the reply #7 from born4linux on how to add the correct rules to your iptables setup:

http://www.linuxquestions.org/questi...threadid=68699

good luck
 
Old 08-01-2003, 12:50 PM   #4
r1_97
LQ Newbie
 
Registered: Jul 2003
Location: san diego
Distribution: SusE 9.0
Posts: 10

Original Poster
Rep: Reputation: 0
"nstead of using network places, try mapping to the samba share.

You will need to configure your smb.conf located at /etc/samba/ to allow for this.

Make sure to restart the samba dameon
#service smd restart

You will also need to add a samba user
#smbadduser "username"

This user will also need a UNIX account on that system.

then configure the smbuser's password with
#smbpasswd "username"

"If you want to be able to access the share from your windows box without any prompts, make sure to make the user names and passwords the same as the user account on the windows box.

--hope this helps

--dubman"

I tried to map user smr's home directory to Xp's "z" drive. \\linux\smr. User name and password are the same on both machines. smbservices restarted OK. Xp error message network path could not be found.
 
Old 08-01-2003, 01:09 PM   #5
dubman
Member
 
Registered: Jan 2003
Distribution: Redhat 9, Fedora Core 1, Suse 8
Posts: 188

Rep: Reputation: 30
If you can access your Linux share from windows, im not thinking iptables would be the culprit.

Its possible, but not likley. To make sure just do a
#service iptables stop
this will make set your default poilcy to ACCEPT

That is weird that you get network path can not be found though. Can you access it with wack wack?

from a run line on your windows box, type
\\Linux\share

if that dosen't work try
\\"Linux_IP_Address"\share

if this works it is an alias/netbios problem, you will need to configure your host file. Match up your "freindly" computer name to the local ip address.

if you get connectivity but access is denied to the share, you will have to mess with your user:group permissions of the share with chmod and chown.

also, if your smb.conf, you may want to comment out the "hosts allow" line. In my configuration, I disable this option and let iptables take care of security...

you may also want to add "security = user", or "security = share" under the global parameters.

If this dosen't work, I will post my samaba config script later tonight for you when i get home, so you can make a comparision.

-hope this helps more ;-)

-dubman
 
Old 08-01-2003, 01:31 PM   #6
r1_97
LQ Newbie
 
Registered: Jul 2003
Location: san diego
Distribution: SusE 9.0
Posts: 10

Original Poster
Rep: Reputation: 0
No, it's the other way around. I CAN access my Xp share from Linux but not the Linux share from Xp. There is no "linux" in my Xp network places. I tried to map to "z" drive both:
\\linux\share
\\linux\192.168.1.101

"linux" is the name of my linux box and 192.168.1.101 is the internal IP address. My user name, workgroup name and passwords are the same on both computers.

Xp still can't find network path to linux.

I use Home version of Xp and don't know how to define netbios name.

Steve
 
Old 08-01-2003, 01:36 PM   #7
dubman
Member
 
Registered: Jan 2003
Distribution: Redhat 9, Fedora Core 1, Suse 8
Posts: 188

Rep: Reputation: 30
sorry, i mis-worded. I ment it the other way around.

did you add a smaba user?
 
Old 08-01-2003, 01:39 PM   #8
dubman
Member
 
Registered: Jan 2003
Distribution: Redhat 9, Fedora Core 1, Suse 8
Posts: 188

Rep: Reputation: 30
did you try
START>>RUN...\\Linux_system_name\share
or
START>>RUN...\\LINUX_IP\share

mapping will only work if netbios isnt an issue..and its not the configs of the windows netbios name, its the Linux "freindly" name

--dubman
 
Old 08-01-2003, 01:50 PM   #9
r1_97
LQ Newbie
 
Registered: Jul 2003
Location: san diego
Distribution: SusE 9.0
Posts: 10

Original Poster
Rep: Reputation: 0
Yes, smr is a samba user and running from START;
\\linux\smr
\\linux\192.168.1.101

both result in network path not found.
 
Old 08-01-2003, 03:21 PM   #10
dubman
Member
 
Registered: Jan 2003
Distribution: Redhat 9, Fedora Core 1, Suse 8
Posts: 188

Rep: Reputation: 30
Yes, smr is a samba user and running from START;
\\linux\smr
\\linux\192.168.1.101

-----------------------------------
is "smr" the name on the folder that is shared out on the linux box, and is linux the name of your linux system?

\\linux\192.168.1.101 is the wrong syntax...it shoudl be:
\\192.168.1.101\smr - if smr is the name of the FOLDER that is specified in your smb.conf file

what is the ip address of the windows box? if your linux box is 192.168.1.101/24, your windows box would need to be in the same 192.168.1.x/24 network, unless you enabled routing at some point in your network and configured some static routes.
 
Old 08-02-2003, 12:56 PM   #11
r1_97
LQ Newbie
 
Registered: Jul 2003
Location: san diego
Distribution: SusE 9.0
Posts: 10

Original Poster
Rep: Reputation: 0
I tried \\192.168.1.101\smr but Xp couldn't find the network path. I use a 4 port router but use DHCP not static routing. The Xp box internal IP address is 192.168.1.100 and the linux box is 192.168.1.101.
The name of the folder to be shared on linux is, I assume, my home directory - /home/smr.
 
Old 08-04-2003, 01:48 AM   #12
inet_man
LQ Newbie
 
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
iptables rules with RH9

Hi, I just posted this because I couldn't find anything wrong with my samba config, I could see the shares in neighbourhood, and could map them, everything in the smb.conf file checked out (config worked fine before using RH9).

Only difference was that this workstation had been setup using Lokkit. (seems to be a default setting in RH9 ) - hence in this case the samba problem was fixed by editing local iptables rules.

Until I fixed the iptables rules viewing shares was as far as I got, once I had allowed the netbios authentication ports through, everything was fine.

I can now map shares with my Windows username, no trouble, and on other shares I get a username/pasword prompt, same as usual with a Windows box. Back to a normal samba setup.

This seems to be a feature of the medium and high security of Lokkit. I notice that the setup helpers do not include an option for samba.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Street Atlas / Street Finder clone for Linux? PowerMatt Linux - Software 4 08-06-2017 05:32 AM
Porlbem detecting router three feet away, but can connect to one down the street seanr Linux - Wireless Networking 6 09-22-2005 03:19 PM
No 2 way Street? arcturus Linux - Networking 6 06-05-2005 01:57 AM
true newb : how to run wine for a game called Street Legal NicholasWatkins Linux - Games 1 04-12-2004 04:42 PM
looking for news article RE: wall street firm(s) migrate to Linux jqpdev Linux - General 1 02-28-2003 03:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration