-   Linux - Networking (
-   -   rtnetlink answers file exists (

jai_nagarajan 11-24-2011 09:57 PM

rtnetlink answers file exists
Hi Guys,

I have strange problem in Centos. I installed CentOS 6 in VMware 8.0.1 workstation. I have restarted the network service once configured the IP address and I noticed eth0 is not found when applied the command ifconfig. Again I tried to start the network service it shown the error message "RTNETLINK answer : File Exists"

But the interface is showing eth0 at the time of system booting. The problem as persisting once restart the network service

It would be appreciate anyone give suggestion to solve the issue at the earliest

falcom 11-27-2011 06:27 PM

try with this
- first unplug network path
- after restart network service
service network restart
- ifconfig (show eth0)
- put again the network patch
it's all

wiren 02-16-2012 11:14 AM

[SOLVED?] Re: RTNETLINK answers: File exists


where $interface is your interface, i.e.: eth0, p3p1, etc.

Contains old MAC address of the interface, but the script file exists, therefore conflict in configuration.
ie.: Service tries to use detected setings, but ifcfg script exists, therefore "File exists" error.


Fix the MAC address in the script file, with MAC address from:

ifconfig $interface
--> If I find better solution, than fixing by hand, I may update this post.

All times are GMT -5. The time now is 10:12 PM.