-   Linux - Networking (
-   -   rsync: Timeout, server not responding (

mr_scary 01-24-2007 10:55 AM

rsync: Timeout, server not responding
I have several WinXP laptops which have been backing up to a FreeBSD 6.0 server via rsync for a good while now. Now one laptop is giving me grief. I am running cwRsync and invoking a remote rsync daemon via a shell command:

cmd /K "rsync.exe -avr --rsh=ssh --progress --stats --delete /cygdrive/d/"My Documents" user@server::user_data"

I get this error locally:


Timeout, server not responding
And on the server:


2007/01/24 11:46:18 [59320] connect from <FQDN> (
2007/01/24 11:46:18 [59320] rsync: connection unexpectedly closed (0 bytes received so far) [receiver]
2007/01/24 11:46:18 [59320] rsync error: error in rsync protocol data stream (code 12) at io.c(462) [receiver=2.6.9]
I have been troubleshooting with a test directory both locally and remotely (client and server). I have also upgraded rsync on the server as well as re-installed cwRsync on the laptop.

Any comments welcome,


MensaWater 01-24-2007 12:02 PM

Make sure no one enabled firewall on the Windoze machine. Maybe its initiating the outbound connection but complaining about the return.

mr_scary 01-24-2007 01:58 PM

Yeah, the Windows f/w is the first thing I checked. Off.

I can also SSH to the server no problem. I checked for any other Windows gizmo that might impede traffic. Nada. Well, there was SafeEyes but the user assured me that it is used to block pr0n websites and suchlike things.


MensaWater 01-24-2007 02:02 PM

You can force rsync to use ssh for transport. Since you say ssh works have you tried that to see if it works? If it does then it would tend to prove the issue is something blocking the port being used by default (873 for daemons).

Can you telnet to the machine at above port?

mr_scary 01-27-2007 07:27 PM

But I *am* using SSH. That is what the -rsh=ssh is for.


MensaWater 01-28-2007 08:26 AM

Sorry missed that.

Can you ssh directly to the server successfully?

Gethyn 01-28-2007 08:37 AM

I think the OP said that ssh was working correctly. I've never tried cwRsync, but would it be possible to try the Cygwin version of rsync? I'm not suggesting changing over, but if both versions of rsync fail that tells us something different to one version working and the other not working.

All times are GMT -5. The time now is 07:25 PM.