LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-13-2007, 06:50 AM   #1
Amdas
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Rep: Reputation: 0
Routing using Red Hat Enterprise 4 ES


I want my Linux (Red Hat Enterprise 4) PC to function as a router. The PC is fitted with two ethernet card eth0 and eth1.

I have started the zebra and ripd services and configured as given below.

[root@localhost ~]# vtysh
localhost.localdomain#

localhost.localdomain# sh running-config
Building configuration...

Current configuration:
!
hostname Router
password zebra
enable password zebra
log file /var/log/quagga/zebra.log
hostname ripd
log file /var/log/quagga/ripd.log
!
interface dummy0
ip address 10.0.2.1/24
ipv6 nd suppress-ra
!
interface eth0
ip address 10.7.100.34/28
ip rip receive version 2
ip rip send version 2
ipv6 nd suppress-ra
link-detect
!
interface eth1
ip address 10.7.100.66/28
ip rip receive version 2
ip rip send version 2
ipv6 nd suppress-ra
link-detect
!
interface lo
link-detect
!
interface sit0
ipv6 nd suppress-ra
!
router rip
network 10.0.0.0/8
network eth0
network eth1
neighbor 10.7.100.33
!
ip forwarding
!
line vty


These configuration files are saved in /etc/quagga/zebra.conf and /etc/quagga/ripd.conf . eth1 is connected to a PC having ip 10.7.100.65/28 and eth0 is connected to a port of CISCO router having ip 10.7.100.33/28. The CISCO router is configured as....
router rip
version 2
network 10.0.0.0

Static routing is working fine(without RIP configuration). But dynamic routing i.e. RIP is not working.

It will be very kind if any one can help me regarding RIP configuration.I want the basic steps of RIP configuration.

One thing is to be noted i.e. telnet 127.0.0.1 2601 ,2602 is not working. That-is-why I have used '[root@localhost ~]# vtysh '.
 
Old 07-13-2007, 07:43 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980
well you didn't specify version 2 on quagga if that matters, but this really isnt' about using linux. this is about cisco more than anything, as well as your understanding of routing protocols, somethign we, as a linux forum, are not best placed to answer. i would say you need to check some debugging on both devices to see what rip activity is going on...

and you already started one thread about this... please learn to reply to your existing threads, not just start new ones. this thread will be merged with the existing one soon.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Routing with Red Hat Enterprise 4 Amdas Linux - Networking 1 07-11-2007 02:50 PM
LXer: Red Hat to launch Red Hat Enterprise Linux 5 before March LXer Syndicated Linux News 0 12-30-2006 08:03 AM
Project made in Red Hat Enterprise 4 need to be able to run on Red Hat Enterprise 3 Elin Linux - Software 1 07-13-2006 12:22 PM
Project on Red Hat Enterprise 4 run on Enterprise 3? Elin Linux - Enterprise 1 07-12-2006 05:21 AM
Project on Red Hat Enterprise 4 run on Enterprise 3? Elin Linux - Newbie 1 07-12-2006 04:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration