-   Linux - Networking (
-   -   Routing problems (

luky2k 11-19-2003 11:57 PM

Routing problems
When I try to ping another machine, ping says destination host unreachable. But it is still possible to get the other machine's netbios name (so physical connection seems to be ok) Any ideas?

linuXBOX 11-20-2003 12:31 AM

Any software firewall programs running?
zonealarm? blackice? firewall?
Also check your router setup, and look to see if the machines are in the clients tables.

luky2k 11-20-2003 04:25 AM

Thx for replying. I'm running Shorewall, but I don't think that's the real cause. Check out my other post:

I've just installed a new ethernet board (via-rhine compatible) as eth2
I also have an rtl8029 at eth0 and a 8139too at eth1. Everything worked fine before installing the new board.. network, services, etc
The problem is that when my system starts up, eth1 appears to be dead.
I start a terminal as root and type:
# ifup eth1
Then eth1 starts working again, but eth2 stops. If I run:
# ifup eth2
Then eth2 starts, and eth1 stops. And so on...
There are no problems with eth0 (connected to a dsl modem)
I don't know either is this a hardware conflict, or a firewall issue (I had always run Shorewall without problems).
Running ifconfig, it seems that eth1 and eth2 are using different IO ports and IRQ numbers.
I have noticed that both via-rhine and 8139too share the same kernel module, named 'mii' ... Does it mean something?
I really don't know what's going on. everything works fine with both boards, but one at the time. Sorry for my bad english.

carstenson 11-20-2003 08:23 AM

I *think* "host unreachable" means that there is a dns problem. Try the ping using an ip address. You probably need to check your routing table with "netstat -r". You are trying to ping from this machine to an internal or external computer?

luky2k 11-20-2003 09:35 AM

I could fix the problem!
My previous network configuration was
eth1 ip=
eth2 ip=

eth1 ip=
eth2 ip=

Nevertheless I still don't understand why I can't put two NICs in the same subnet

carstenson 11-20-2003 09:59 AM

What subnet mask were you using? You may have been trying to define them network. I am not sure what linux would do in that case, or if it is even a problem. I seems like it would definitely cause some routing confusion at least.

luky2k 11-20-2003 06:14 PM

Netmask = for all interfaces.
Is that wrong? thanks!

carstenson 11-21-2003 08:21 AM

That is what I would expect it to be. This means it should split your two nics to two separate networks. Routing should work fine. Sorry I can't be of more help.

All times are GMT -5. The time now is 09:03 AM.