-   Linux - Networking (
-   -   Router keeps kicking me off... (

Akiva 07-04-2005 05:02 AM

Router keeps kicking me off...
Dear All,

My wireless network at home has seemed to have run into some problems lately. My connection to my ISP would be fine for an hour or two, but then the connection would just be randomly lost. I'm quite bad at all the networking lingo, so please forgive me if I call something wrong.

Here is the situation:


ADSL wall socket
Router (or just random grey box which establishes connection)
Wireless router w/ WPA personal (AirPort Extreme to be precise)
/ \
iMac G4 -- Ubuntu Hoary Laptop


Upon asking the wireless router it told me that there was nothing connected to it. There was though, so I moved on. My router said there was something wrong with the connection

I tried to leave out the wireless router and use an ethernet cable with the router thing. Now that resulted in the problem, ergo the wireless is fine, router thing the dunce.

Now the real problem: does that mean there is something wrong with my ISP, or the router? I could change ISP or even the grey box thingy.

Thanks in advance (and for listening!),


Edit: My router is really old... could it just be getting mouldy inside? If so, anyone got a particular recommendation?

camorri 07-04-2005 08:24 AM


My router is really old... could it just be getting mouldy inside? If so, anyone got a particular recommendation?
Mouldy??? I don't think so. What I would recommend is to have a google search for the manufacturer or your router and see if there are any updates to the fireware on the router. Many of the older routers have updates. If you can not find the data yourself, post back the make and model information on your router, and someone here may be able to help you out.

Other than that, it seems you have done most of the correct things. Check the physical stuff, and eliminate what you can. Things such as connecting cables, wall plugs etc.

Akiva 07-04-2005 09:33 AM


I don't think that it's a router! Sorry!

Reading off the box, it is a NEC ATU-R200 ADSL Modem. I couldn't find any sort of firmware update, and it does seem odd to get a firmware update for a modem. Sorry about the confusion.

On the other hand, I didn't literally mean mouldy. More like the age and the battering it's taken has taken some bit off the sockets and hence is a bit loose...


michaelk 07-04-2005 10:12 AM

It is possible that your modem is failing or something might be wrong with the telephone lines. Might want to check with your ISP.

camorri 07-04-2005 10:45 AM

Looking back through your original post, it appears you have a ADSL modem, (connected to the phone line) - model NEC ATU-R200 ADSL Modem connected to a wireless access point,

Wireless router w/ WPA personal (AirPort Extreme to be precise)
connected to two PC's, one iMac G4 and one laptop running Ubuntu.

Is the wireless access point a separate device? Do you loose connectivity to both PC's at the same time when it fails?

On the ADSL modem, are there any error lights? Mine shows a red led (light) when I loose physical connectivity from the phone system. It is probably worth the time to try and swap out the ADSL modem if you think the connectors are in bad enough shape to cause a disconnect. You can do a little experimenting, disconnect the ADSL phone connection and see if you get error lights. I would expect you should. Then you will know when it is failing what lights to expect if you are loosing the signal.

Hope these thoughts help.

Akiva 07-05-2005 01:41 AM

Cliff and michaelk,

Thanks for your replies. Sorry I haven't been able to reply to them sooner; I have to run to an internet cafe to do it.

I haven't got the best ISP, but it is quite big and should be decent. I doubt my ISP has a problem. The most likely is that (agreeing with michaelk) my lines are a bit dodgy. My ADSL modem probably is past its sell by date. I'll get a nicer one, inspect my lines and see what happens.

I don't think my wireless router is the problem. When I lose my connection to the internet and the modem starts flashing red I still have my PCs networked and the printer shared.

I'll post back on the results, and thanks so much for the help so far.


J_K9 07-06-2005 06:29 AM

Have you tried ringing up your ISP? They may have a problem which doesn't affect other users of their Internet service, for example a corruption in your login details or something odd. If I were you I'd give them a call and ask them to help you - I did that a few days ago only to find that my ISP's server had caught a virus! :eek: !! lol. Nice to see you Akiva.


Akiva 07-06-2005 10:28 PM

My ISP finally got someon to come and have a look at my setup. He said that apparently lots of people have had problems with their access recently because many bits of kit got blown up (not literally. Burnt up, more like.) Maybe even a thunderstorm did it. I just got a new modem free of charge and that's that.

Interesting thought J_K9, a corruption in login details. Possible I suppose, but like I said my access was before on and off before my modem kept showing a warning light with no internet access.

Well, there's a thunderstorm coming right now, according to the weather station. Fingers crossed :D

Thanks a lot for all the response!


All times are GMT -5. The time now is 05:14 PM.