LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   route to alcatel modem/router: LAN & internet (https://www.linuxquestions.org/questions/linux-networking-3/route-to-alcatel-modem-router-lan-and-internet-65021/)

HerrBee 06-11-2003 02:16 PM

route to alcatel modem/router: LAN & internet
 
Hi there!

I've just installed debian woody 2.4.18-bf2.4 and am trying to set up my internet connection and network connection.

hardware:
  • alcatel speedtouch home adsl modem --> upgraded to pro version with router capabilities
  • onboard lan chip: via vt-6103
  • southbridge: via vt8235
  • a hub for connecting multiple PC's to the alcatel modem/router

what i've done and tried so far:
  • installed rhinefet.o driver for ethernet interface (seems successful)
  • *** untarred driver file into temp directory
  • *** used command make install
  • *** added alias 'alias eth0 rhinefet' in file /etc/modutils/aliases
  • *** added driver reference for loading at boot 'rhinefet' in file /etc/modules
  • tried to use DHCP server on alcatel modem/router (didn't work)
  • *** permanent connection ICS is up and working: connection is made by setting up alcatel modem/router
  • *** DHCP server setup:
  • *** addresses: 10.0.0.1 through 10.0.0.254
  • *** subnet mask: 255.0.0.0
  • *** lease time: 7200
  • *** default gateway: 10.0.0.138
  • *** dns server: 212.83.68.130
  • *** DHCP client setup: used network utility 'etherconf' which I think is using 'dhclient' --> the program quits without errors but doesn't get a lease from the server
  • used 'ifconfig' and 'route' to set up ethernet device by giving following commands:
  • *** ifconfig eth0 10.0.0.5 netmask 255.0.0.0 up
  • *** route add default gw 10.0.0.138
  • *** route add -net 10.0.0.0 netmask 255.0.0.0 eth0
  • modified some files:
  • *** in file /etc/resolv.conf: added 'nameserver 10.0.0.138' and '212.83.68.130'
  • *** in file /etc/host.conf: 'order hosts,bind' and 'multi on'

'ping' commands to 'localhost', '10.0.0.0', '10.0.0.5' work, but that seems obvious; to '10.0.0.138' it doesn't work, nor to any machine on the LAN or internet

My questions are:
  • how do I know I am using the right driver for my ethernet device?
  • how can I get a DHCP connection to the modem/router and setup a gateway to the internet and my LAN

There must be something i've forgotten or don't know about yet, so please help me. Maybe another 'route' ???

Greetzzz


All times are GMT -5. The time now is 05:20 PM.