-   Linux - Networking (
-   -   Rosewill RNX-N250PC2 (Atheros AR9287) Wireless N Card Hangs Entire System (

ZeroDaHero 06-08-2012 10:32 AM

Rosewill RNX-N250PC2 (Atheros AR9287) Wireless N Card Hangs Entire System
After about two days of googling and futzing around, I think I have found the fix to this problem, and want to share it with others.

I got the Rosewill Wireless N PCI Adapter (RNX-N250PC2) card for my desktop after moving in to my new apartment. I didn't feel like wiring the ethernet all the way across the place just for my computer (everything else is wireless), so I got this card off of Newegg. The main reason: it was cheap.

So, when I installed and booted this puppy up, I was pleased (read: pissed like nothing else) that the entire system would hang after connecting to my router.

Lots of googling, lots of messing & etc later, I followed an obscure link on a similar sounding AR9287 issue and changed my router's WPA2 encryption.

Apparently, there seems to be a bug, or a configuration issue that makes the very essence of this wireless card lose all meaning in its existence so as to hang itself and the entire system with it.

So, the fix (at least for me):

Make sure that you're using the latest compat-wireless drivers (we're up to 3.4 at the time of writing), then, if you're using WPA encryption on your router, make sure that it's either WPA or WPA2, not mixed mode (wasn't an issue for me, but that was the suggestion on the forum that lead me to my solution). Then, my specific fix was to changes the encryption to AES, not TKIP or AES & TKIP.

I hope this helps someone else, or at least saves someone a day and a half of frustration/googling.

EricTRA 06-09-2012 03:44 AM


Thanks for sharing what worked for you. I'm sure it'll be useful to someone along the way. Off the Zero Reply List.

Kind regards,


evo2rex 07-14-2012 12:03 PM

Just ordered the same card, Rosewill RNX-N250PC2, from newegg after some research. Can't wait to test it out on my only 64-bit box (the other 2 are 32-bit and don't seem to like any distro I've tried).
Thank you, OP, for the insightful post.

All times are GMT -5. The time now is 04:13 AM.