LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-02-2003, 05:39 PM   #1
Ju Deddo Koinu
Member
 
Registered: Apr 2003
Location: Austin, TX
Distribution: RedHat 9 w/ KDE
Posts: 86

Rep: Reputation: 15
Risking Death: Connecting to M$ Workgroup


Is it possible for me to get my Linux box to show up on a Winblows network?
 
Old 05-02-2003, 05:40 PM   #2
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
www.samba.org
 
Old 05-02-2003, 05:41 PM   #3
Ju Deddo Koinu
Member
 
Registered: Apr 2003
Location: Austin, TX
Distribution: RedHat 9 w/ KDE
Posts: 86

Original Poster
Rep: Reputation: 15
thanks, will check it out
 
Old 05-02-2003, 11:43 PM   #4
Ju Deddo Koinu
Member
 
Registered: Apr 2003
Location: Austin, TX
Distribution: RedHat 9 w/ KDE
Posts: 86

Original Poster
Rep: Reputation: 15
Okay... So is Samba a server or a client? I gathered that it was a server for domain/workgroups... I downloaded a GUI configurator for it, because it seems a little foggy in some areas when it comes to the documentation. I already had it installed on my system (even though I have not checked yet to determine if it is running and configured - will do this later).

Now, to describe my physical setup, to maybe shed some light on what I want to do...

I have a M$Winblows computer with Internet Connection Sharing installed, along with the Personal Web Server installed. It works fine for both local and remote HTTP sessions as is. The problem is that I'm only running this other computer as a gateway at the moment (until I finally figure out how to get my Linux setup for IP Masquerading or whatever). Because of this, I have only a small hard drive installed in the M$ Box. I want to be able to store my web content on my Linux Box, which is located in the subnet of my LAN.

The Internet Gateway (M$) box is hooked up to the internet by way of a cable modem (w/cat5 cable and a 10/100 nic). It's other nic is connected to a 16-port hub I have.

From the hub, I have a M$ Xbox and 2 other computers hooked up (all three need to be on the net). One computer is a M$ Box, and then there is my personal workstation, the RH9 Linux Box. Network configuration on the M$ Boxes was simple enough (I'm very proficient with them - Recently became a Linux user - I have always loved it much more, but have never been good at working with them), and in their "network neighborhood", they list each other, and both can be on the internet, as well as the xbox...

The system that I am using, the RH9 Linux Box, is on the network as well, and auto-configured itself to use the M$ Box's Internet Connection Sharing, but does not show up when you search through the network neighborhood on the M$ Boxes. (I had this problem with a friend's Macintosh a while back, when he brought it over and wanted to share some files, but we could never figure it out, even though he could use the internet)

The M$ boxes can access the HTTP site I am hosting on my RH9 Box, by using the local IP address of it. I can even ping back and forth from each machine to each other, but the RH9 Box just hasn't joined the M$ Workgroup...

After reading http://www.samba.org I had a headache, and only partially understood what it was for, and what it does.

From what I gather, it acts as a domain or workgroup controller/server, and allows the M$ Boxes to connect to the M$ "compatible" workgroup that Samba creates?

And if this is the case, Can I still use a computer that is not the domain controller as my internet gateway?

And how simple is this process? I installed a Samba configurator, and have been searchign for hours to figure out where it put itself when it installed, because I can't find it *smiles* I've run a whereis on the package name prefix, and tried typing in various "should be" names of the actual program... Anyhow... I'm worried that I might be doing something that I don't have to do in order to accomplish what I want to.
 
Old 05-03-2003, 12:17 AM   #5
Ju Deddo Koinu
Member
 
Registered: Apr 2003
Location: Austin, TX
Distribution: RedHat 9 w/ KDE
Posts: 86

Original Poster
Rep: Reputation: 15
Ok, just found out that the smb service had stopped itself somehow, so I started it and added a script to start every time I boot now.

"Localhost" shows up in the M$ workgroup now....

But I can't access it.

M$ Network Neighborhood displays the following error:

"\\Localhost is not accessible. The computer or sharename could not be found. Make sure you typed it correctly, and try again."

I'm looking into further smb configuration options to see if this works out.
 
Old 05-03-2003, 12:33 AM   #6
Ju Deddo Koinu
Member
 
Registered: Apr 2003
Location: Austin, TX
Distribution: RedHat 9 w/ KDE
Posts: 86

Original Poster
Rep: Reputation: 15
So, I thought it might have something to do with the dot notation that my Linux Box was using by default (the hostname defaulted to localhost.localdomain)

So, I changed the hostname in the network file to what I wanted it to be (simba1), and sent the service network restart command... I even restarted the smb server as well, and checked my shared folder to make sure it was still shared...

Now, my Linux Box has disappeared from the M$ workgroup! How quaint.
 
Old 05-03-2003, 12:53 AM   #7
Ju Deddo Koinu
Member
 
Registered: Apr 2003
Location: Austin, TX
Distribution: RedHat 9 w/ KDE
Posts: 86

Original Poster
Rep: Reputation: 15
Ok, it has shown back up - after a fifteen minute lapse in coverage...

But still gives me the error "cannot access \\simba1"
 
Old 05-03-2003, 12:57 AM   #8
Ju Deddo Koinu
Member
 
Registered: Apr 2003
Location: Austin, TX
Distribution: RedHat 9 w/ KDE
Posts: 86

Original Poster
Rep: Reputation: 15
well, even though it shows up in what appears to be the M$ workgroup, i don't know how to find this information on my Linux Box to confirm...

Also, in the properties for the systems on the M$ gateway, it gives the workgroup, user, and logon domain for the M$ machines, and no information on the Linux Box's icon - although it is present in the network neighborhood, but claimed to not exist *laughs* I'm confused quite a bit.

*continues working on the problem until it is solved*
 
Old 05-03-2003, 01:10 AM   #9
green_dragon37
Member
 
Registered: Oct 2002
Location: Lower Alabama
Distribution: Slackware, OpenBSD 3.9
Posts: 344

Rep: Reputation: 31
I can't say for sure, but I believe the problem may lie in your firewall.

The default Samba configuration will allow it to be a local master over only win95 & 98 boxes, your XP box will be the local master which your linux box identifies itself to, and is then listed in the browse lists. Since you are listed, but cannot be connected to, I think that your firewall is allowing samba to id to the XP box, but rejecting any attempt to connect from any other box. You may need to open ports 137, 138, and 139 to allow for connects to your linux box.

HTH
Ian

Last edited by green_dragon37; 05-03-2003 at 01:23 AM.
 
Old 05-03-2003, 03:28 AM   #10
Ju Deddo Koinu
Member
 
Registered: Apr 2003
Location: Austin, TX
Distribution: RedHat 9 w/ KDE
Posts: 86

Original Poster
Rep: Reputation: 15
This is changed in the /etc/sysconfig/iptables correct? After changing, I have to restart the network and smb services?

I did so, and no luck yet. I've been fiddling with the /etc/samba/smb.conf file (have backup to resort to), and have been able to make my Linux box show up and disappear at will now - if I have share level workgroup access on the Linux box, then it shows up, if the security mode is 'user' or 'server', then i disappear. Uncommenting any other options regarding Domain Serving also make my Linux box disappear.

Oh, and the M$ computer is a 98 box, as well as the secondary M$ box.
 
Old 05-03-2003, 03:33 AM   #11
Ju Deddo Koinu
Member
 
Registered: Apr 2003
Location: Austin, TX
Distribution: RedHat 9 w/ KDE
Posts: 86

Original Poster
Rep: Reputation: 15
-A input -s 0/0 192.168.0.2 137 -i eth0 -p 6 -j ACCEPT
-A input -s 0/0 192.168.0.2 138 -i eth0 -p 6 -j ACCEPT
-A input -s 0/0 192.168.0.2 139 -i eth0 -p 6 -j ACCEPT
 
Old 05-03-2003, 03:40 AM   #12
Ju Deddo Koinu
Member
 
Registered: Apr 2003
Location: Austin, TX
Distribution: RedHat 9 w/ KDE
Posts: 86

Original Poster
Rep: Reputation: 15
pardon that mistake... I put the following in /etc/sysconfig/iptables And performed the following commands.

code:
-----
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 137 --syn -j ACCEPT
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 138 --syn -j ACCEPT
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 139 --syn -j ACCEPT
-----

code:
-----
[root@simba1 root]# /etc/rc.d/init.d/iptables restart
Flushing all current rules and user defined chains: [ OK ]
Clearing all current rules and user defined chains: [ OK ]
Applying iptables firewall rules: [ OK ]
[root@simba1 root]# service network restart
Shutting down interface eth0: [ OK ]
Shutting down loopback interface: [ OK ]
Disabling IPv4 packet forwarding: [ OK ]
Setting network parameters: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface eth0: [ OK ]
Bringing up interface eth1: [ OK ]
[root@simba1 root]# service smb restart
Shutting down SMB services: [ OK ]
Shutting down NMB services: [ OK ]
Starting SMB services: [ OK ]
Starting NMB services: [ OK ]
-----
 
Old 05-03-2003, 12:01 PM   #13
green_dragon37
Member
 
Registered: Oct 2002
Location: Lower Alabama
Distribution: Slackware, OpenBSD 3.9
Posts: 344

Rep: Reputation: 31
You need to allow udp traffic on those ports as well. Also, does iptables -L show your rules, I only ask because i have never used that method for my firewall.

I was sure i saw XP somewhere, but I was kinda tired then

HTH

Ian
 
Old 05-03-2003, 04:19 PM   #14
Ju Deddo Koinu
Member
 
Registered: Apr 2003
Location: Austin, TX
Distribution: RedHat 9 w/ KDE
Posts: 86

Original Poster
Rep: Reputation: 15
well, i'm not sure what it was... i turned the firewall down to "medium" with my firewall editor and added those ports (137-139). Now, it lets me access the shared folder list from winblows.

One more thing, however. I list 3 directories on the linux box through the M$ computer's network neighborhood.

One folder "linuxshared" is the folder I manually shared (through konquerer)
Another folder "netlogon" i have not heard of before
And "simba", which is the folder I mapped the M$ user too.

I know the permissions for linuxshared was 'public' 'rwx' style permissions, like everyone could access it, but i can't access from the M$ machine, nor can I access this "netlogon" folder

"Network resource is not accessible. The share name was not found."

But, at least for now, I can actually access the folder I mapped to the M$ user. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
workgroup rstmn957 Mandriva 3 02-05-2006 06:47 AM
Can't see workgroup? mrurmil Linux - Networking 2 02-03-2005 09:16 PM
Workgroup rstmn957 Linux - Newbie 2 08-23-2003 09:17 AM
connecting to windows workgroup using samba? linoob Linux - Newbie 7 10-23-2002 09:17 PM
Death of Be goneaway General 2 03-05-2002 11:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration