LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-22-2008, 01:50 AM   #1
korexmohan
LQ Newbie
 
Registered: Nov 2008
Posts: 17

Rep: Reputation: 0
Unhappy RHEL5.2 eth1 inactive when network restarts


Hi,
I just installed RHEL 5.2 for proxy server. eth0 connected to WAN and eth1 connected to LAN. After assigning the ip address for eth1 if i restart the network services eth1 goes inactive.

eth0: RTL8139, SMC EZ card - 10.0.0.37
eth1: RTL8101E PCI Express - 192.168.1.66

Network Status
Configured device
lo eth0 eth1
Currently active devices
lo peth0 virbr0 vif0.0 eth0 xenbr0

Kindly help...

Last edited by korexmohan; 11-22-2008 at 01:53 AM.
 
Old 11-22-2008, 01:56 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,540

Rep: Reputation: 101Reputation: 101
If you open a terminal and do

#/sbin/ifconfig

what do you see? Can you post the output?
 
Old 11-22-2008, 02:23 AM   #3
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
It would help to have that ifconfig, however I am gunna suggest also you check /etc/sysconfig/network-scripts/ifcfg-eth1 and look for the onboot line. I suspect simply this is set to no, it needs to be set to yes for eth1 to be started automatically. You can either restart the network or run ifup (within the same directory) to bring eth1 up. If ifup brings up an error message then their is likely a configuration problem.

Last edited by r3sistance; 11-22-2008 at 02:25 AM.
 
Old 11-22-2008, 02:35 AM   #4
korexmohan
LQ Newbie
 
Registered: Nov 2008
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rylan76 View Post
If you open a terminal and do

#/sbin/ifconfig

what do you see? Can you post the output?
[root@localhost ~]# /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:BA:5A:C3:65
inet addr:10.0.0.37 Bcast:10.255.255.255 Mask:255.0.0.0
inet6 addr: fe80::250:baff:fe5a:c365/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:460 errors:0 dropped:0 overruns:0 frame:0
TX packets:425 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:389592 (380.4 KiB) TX bytes:71479 (69.8 KiB)

eth1 Link encap:Ethernet HWaddr 00:1E:90:7D:A6:5D
inet addr:192.168.1.66 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::21e:90ff:fe7d:a65d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1325 errors:0 dropped:0 overruns:0 frame:0
TX packets:578 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:212229 (207.2 KiB) TX bytes:156106 (152.4 KiB)
Interrupt:16 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5100 errors:0 dropped:0 overruns:0 frame:0
TX packets:5100 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4911346 (4.6 MiB) TX bytes:4911346 (4.6 MiB)

peth0 Link encap:Ethernet HWaddr FE:FF:FF:FF:FF:FF
inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
UP BROADCAST RUNNING NOARP MTU:1500 Metric:1
RX packets:2075 errors:0 dropped:0 overruns:0 frame:0
TX packets:931 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:549089 (536.2 KiB) TX bytes:222252 (217.0 KiB)
Interrupt:19 Base address:0xec00

vif0.0 Link encap:Ethernet HWaddr FE:FF:FF:FF:FF:FF
inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
UP BROADCAST RUNNING NOARP MTU:1500 Metric:1
RX packets:957 errors:0 dropped:0 overruns:0 frame:0
TX packets:2075 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:229645 (224.2 KiB) TX bytes:549089 (536.2 KiB)

virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:8779 (8.5 KiB)

xenbr0 Link encap:Ethernet HWaddr FE:FF:FF:FF:FF:FF
UP BROADCAST RUNNING NOARP MTU:1500 Metric:1
RX packets:2134 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:296281 (289.3 KiB) TX bytes:0 (0.0 b)

You have mail in /var/spool/mail/root

Here is the output. Now this problem has been solved. Restarted the server once and now eth0 & eth1 are up.

Now facing a diff problem with internet browsing. If i set G/W for LAN not able to browse the internet. If i left blank for G/W internet is working fine in the server.
 
Old 11-22-2008, 02:51 AM   #5
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
I am guessing your gateway is 192.168.1.1? Maybe the output to /sbin/route might help here or more information, there isn't enough here to really help with.
 
Old 11-22-2008, 02:59 AM   #6
korexmohan
LQ Newbie
 
Registered: Nov 2008
Posts: 17

Original Poster
Rep: Reputation: 0
Unhappy

Quote:
Originally Posted by r3sistance View Post
I am guessing your gateway is 192.168.1.1? Maybe the output to /sbin/route might help here or more information, there isn't enough here to really help with.
Yes you are right. 192.168.1.1 is my G/W.
[root@localhost ~]# /sbin/route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
192.168.122.0 * 255.255.255.0 U 0 0 0 virbr0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth1
10.0.0.0 * 255.0.0.0 U 0 0 0 eth0
default SpeedTouch.lan 0.0.0.0 UG 0 0 0 eth0

Here is the output.
 
Old 11-22-2008, 03:15 AM   #7
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
Looks to me like you have no default gateway on eth1 but have one on eth0, unfortantly I don't know enough about route to really fix that one but I suspect all you need is a default gateway set-up for eth1. Hopefully somebody else will know better then me .
 
Old 11-22-2008, 04:41 AM   #8
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You only need one default - it's where addresses other than those covered on other defaults are routed.

Korexmohan, is SpeedTouch.lan a reasonable default gateway? By this I mean, any requests that aren't to 198.168.1.0/24, 192.168.122.0/24 and 10.0.0.0/8 are going via that IP on eth0

If SpeedTouch.lan is your gateway, then it's a good default.

Edit r3 - You may find this interesting http://linux-ip.net/html/routing-intro.html

Last edited by billymayday; 11-22-2008 at 04:46 AM.
 
Old 11-23-2008, 03:02 AM   #9
korexmohan
LQ Newbie
 
Registered: Nov 2008
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by billymayday View Post
You only need one default - it's where addresses other than those covered on other defaults are routed.

Korexmohan, is SpeedTouch.lan a reasonable default gateway? By this I mean, any requests that aren't to 198.168.1.0/24, 192.168.122.0/24 and 10.0.0.0/8 are going via that IP on eth0

If SpeedTouch.lan is your gateway, then it's a good default.

Edit r3 - You may find this interesting http://linux-ip.net/html/routing-intro.html
Hi Billy,
Here is my conf is. WAN 10.0.0.37 G/W 10.0.0.136 and LAN 192.168.1.66 g/w -Nil-. With this conf my proxy is working well. Whether any changes need to be made or i can continue with this......
 
Old 11-23-2008, 03:11 AM   #10
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
What's the IP of SpeedTouch.lan though? Should that be your default gateway?
 
Old 11-23-2008, 03:52 AM   #11
korexmohan
LQ Newbie
 
Registered: Nov 2008
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by billymayday View Post
What's the IP of SpeedTouch.lan though? Should that be your default gateway?
Ip for SpeedTouch.lan:10.0.0.136 its my internet gateway. Is it possible to change that to 192.168.1.1 (My LAN g/w)
 
Old 11-23-2008, 04:04 AM   #12
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
The default gateway is where everything that isn't specifically routed goes. If you tried to contact (say ping) an address, say 333.333.333.333, the request would go via the default gateway since it isn't covered by the address ranges in the first 4 lines of the route output you showed earlier.

I suspect what you have is the correct setting.

Is everything working with this route setup? I'm a bit lost. If not, what's the current problem?
 
Old 11-25-2008, 09:19 AM   #13
hasanatizaz
Member
 
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 317
Blog Entries: 1

Rep: Reputation: 35
it could be the problem of profiles, you need to add both of them in a same profile and set ONBOOT=yes
 
Old 11-26-2008, 12:30 AM   #14
korexmohan
LQ Newbie
 
Registered: Nov 2008
Posts: 17

Original Poster
Rep: Reputation: 0
Its working

Thanks pals...Now my proxy is working fine....

Thx for your help
 
Old 01-08-2009, 05:18 PM   #15
aserogp
LQ Newbie
 
Registered: Jan 2009
Posts: 1

Rep: Reputation: 0
I searched for eth1 won't stay active;
r3sistance solved the problem for me with post #3.
onboot=no needs to be set to yes.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Displaying inactive network cards Wiggy Slackware 8 10-21-2008 10:29 PM
Fedora 4 Inactive Network Card problem dominus85 Linux - Networking 0 02-14-2006 04:28 AM
Inactive Network card mheymann Linux - Networking 1 11-04-2005 07:00 AM
Network goes inactive beza Linux - Networking 7 10-15-2003 05:02 PM
Network goes inactive... docman Linux - Networking 1 04-29-2003 02:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration