-   Linux - Networking (
-   -   RH9 on VMWare Eth0 "No Link Present" (

GGSpike 05-13-2004 02:52 PM

RH9 on VMWare Eth0 "No Link Present"

I am not able to setup my eth0 on RH linux 9 installed on a vmware GSX server 3.

I recieve the error message : Determining IP information for eth0... Failed! no link present. Check Cable.

- I use Bridged networking
- Card detected : AMD PCnet 32 Lance
- Driver : AMD PCnet 32

Can someone help???



TheOther1 05-13-2004 03:06 PM

When you ran, (you did run that didn't you?) did you go through the networking section and answer no to NAT and no to Host-only? Also it looks as if RH9 is trying to get a DHCP address...

GGSpike 05-14-2004 09:33 AM

I did run the but i didn't see the NAT part! but i can say that it is configured to get the IP adress with DHCP.

Is there an option to the script to force the config to pass by the networking section?

TheOther1 05-14-2004 09:48 AM

Not that I am aware.

You can run the script again and when prompted about skipping over networking and keep existing settings, answer NO and then use wizard, answer no to NAT and NO to Host-Only and you should be all set for Bridged mode.

I'm not sure how bridged mode would get an IP through DHCP unless the host was providing that service. I'm not sure it could get outside the host for that. Sorry, I have all ststic IPs configured here so I can't even test since I don't have a DHCP server.

GGSpike 05-14-2004 10:40 AM

When I run the script it doesn't ask me for networking, it just asking about the screen resolution! :(

Thanks for your help so far!


TheOther1 05-14-2004 02:18 PM

I'm talking about the script on the host, where GSX is running, not on the guest where your RH9 is running without an IP... There are no resolution settings in the file, only networking, remote ports, location of vmware machines, serial number, etc.

GGSpike 05-14-2004 02:29 PM

The host is a win2k machine and i don't see a file???

TheOther1 05-14-2004 02:50 PM

Oh! Sorry, I was assuming your host was Linux.

I found this on VMware's site:

Getting a DHCP Address in a Red Hat Linux 9.0 Virtual Machine

When a Red Hat Linux 9.0 guest operating system tries to get a DHCP address, the attempt may fail with an error message that states the link is down. On ESX Server, this happens only if you are using the vlance driver for your network connection.

To work around this problem, become root (su -) and use a text editor to edit the following files in the guest operating system. If only one of these files exist, make the change for that file only.



In both cases, [n] is the number of the Ethernet adapter for example, eth0.

Add the following section to each of these two files:

check_link_down () {

return 1;


Then run the command ifup eth[n] (where [n] is the number of the Ethernet adapter) or restart the guest operating system.

GGSpike 05-14-2004 03:36 PM

Good! I was able to activate my eth0 :)

I'm now fighting to get the internet working!!!!

Thanks for your help, GG!

JordanH 12-17-2004 12:39 PM

Thanks, TheOther1.

For future reference for the next guy that runs into this problem,

Host: WinXP Pro with VMWare 4.5.2

Error message when bringing up ethernet adapter contained the phrase, "no link present... check cable?"

The solution is/was as above.

aks_k1 12-28-2007 09:22 AM

Good solution

thanks a lot for this solution.. it helped me get out of the same error as above..

I've got RHL9.0 on WinXP using VMware server 1.0.4.



thekillerbean 04-01-2008 07:32 AM

Interestingly enough, I too was able to resolve this issue by following above solution. Was getting the same error on a RHEL3 AS Guest on Windows Vista Ultimate and VMware Server 1.0.4


All times are GMT -5. The time now is 02:25 AM.