Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 12-14-2002, 11:32 AM   #1
LQ Newbie
Registered: Dec 2002
Posts: 8

Rep: Reputation: 0
Question RH8.0 can't use ISP's DNS through DHCP over DSL behind NetGear

After finding related threads while googling but not getting useful responses, I thought I'd summarize here in the appropriate forum and ask again for help.

I had RH7.2 running and it worked fine getting to the Internet - I can't remember having to do any settings other than specifying using DHCP. I upgraded (not uninstall + install, just upgraded) to RH8.0 and it fails. I can ping valid IPs on my LAN or the Internet but named entries always gives "unknown host". DNS continues to work fine for my non-Linux computers on my LAN, or I wouldn't be able to post this question.

I've gone so far as to use the neat utility and set the DNS Primary and Secondary servers entries myself - I can ping those by IP just fine. It seems, though, that I have to turn off the "Automatically obtain IP information from provider" or it resets Primary to the incorrect entry of (my NetGear) and blanks the Secondary. So when that's unchecked, I've entered the DNS IPs and I
/etc/init.d/network restart
or reboot it still can't resolve a DNS name. Pinging localhost works fine all the time. Hopefully some of this information is useful to anyone who could have a solution.

I'll whine and say this was supposed to be an automatic operation as in RH7.2, why did RH8.0 mess it up?

But what I really want is a 2 minute solution. And if you don't have that, what other questions can I answer to get ANY solution?

Old 12-14-2002, 02:49 PM   #2
LQ Newbie
Registered: Nov 2002
Posts: 9

Rep: Reputation: 0
I'm pretty convinced that it has something to do with your name servers not being correct. Normally, the dhcp should get the name servers. I would check /etc/resolve.conf and make sure it has the correct primary and secondary address in there.

If they aren't correct, go ahead and manually add them in there and see if dig works.

If that fixes it, you'll probably have to make a more permanent change to your network scripts.

Let us know what happens.
Old 12-15-2002, 09:12 AM   #3
LQ Newbie
Registered: Dec 2002
Posts: 8

Original Poster
Rep: Reputation: 0
After I'd used neat to specify the primary and secondary, I'd rebooted and looked at resolv.conf - and the 2 IPs I'd set in neat were listed there at the top (used to have domain then nameserver then search, now nameserver (twice), domain and search). I hope this correctly addresses what you suggested.

I really didn't want to have to start editing the files by hand, but I'm open to almost anything at this point.
Old 12-15-2002, 03:38 PM   #4
LQ Newbie
Registered: Nov 2002
Posts: 9

Rep: Reputation: 0 mentioned that you had to disable the "obtain IP information from provider." when you enabled dns.

Is your computer automatically getting asigned an ip address now?

Can you provide the contents of resolv.conf and /etc/hosts files, as that should give us a good starting point to figure out what's wrong.
Old 12-16-2002, 12:17 AM   #5
LQ Newbie
Registered: Dec 2002
Location: Silicon Valley, California
Distribution: Fedora
Posts: 7

Rep: Reputation: 0
solved a similar problem here - ipchains was the culprit

I was helping a friend with a problem that sounded very similar to this. He could ping the nameserver but couldn't resolve any addresses, just as you described. We found your problem description here before we found our solution. I'll post it in case it helps you.

For us the problem was ipchains. Prior to the RH8 upgrade, he had selected IP firewalling with ipchains. RedHat 8 didn't upgrade that feature correctly. It preserved the ipchains settings in place which deny inbound UDP packets, but not the code in /etc/sysconfig/network-scripts/ifup-post which was adding a hole in the firewall for the nameservers listed in /etc/resolv.conf.

There are several ways to solve this. I couldn't find a GUI tool to modify ipchains (which I think may only be available during RH installation or disappeared in RH8) so I used the ipchains command line utilities. The HOWTO is at . You need to enable UDP Port 53 (DNS) packets to come into your machine, at least from your nameserver if not the whole Net.

As root, add a line like this to /etc/sysconfig/ipchains before the REJECT lines.

-A input -s 53:53 -d 1025:65535 -p 17 -j ACCEPT

and then run "/sbin/service ipchains start"

There may be a GUI-based solution we hadn't considered. But this got the job done for us.
Old 12-16-2002, 09:27 PM   #6
LQ Newbie
Registered: Dec 2002
Posts: 8

Original Poster
Rep: Reputation: 0

ikluft - you are apparently correct! Of course the whole system knew I was onto a solution so it took a few minutes for emacs to start up just so I could try it (and no, emacs usually blinks into existence as fast as anything on my machine).

I added the line (above the REJECT line which includes udp), did the command, and I could immediately ping using DNS.

Thanks much!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
forward dns from dhcp to dhcp Fark Linux - Networking 3 03-31-2004 10:40 AM
DSL modem Netgear DG814 & Mandrake 9.1 Ligius Linux - Networking 0 05-22-2003 06:30 AM
RH8.0 & Netgear MA401 card headaches kurtisw Linux - Networking 6 05-01-2003 07:45 PM
RH8 and Netgear MA311 LUCiFER06 Linux - Networking 1 03-24-2003 03:13 PM
Help DHCP and DNS on RH8 cojo Linux - Networking 14 02-07-2003 10:04 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:16 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration