LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-02-2004, 07:44 AM   #1
metalyric
LQ Newbie
 
Registered: Jun 2003
Location: Istanbul - Turkey
Posts: 8

Rep: Reputation: 0
resolv.conf is not updated automatically


hello all.

first, I have a strange problem with my fedora core 2 with kernel 2.6.6. at first, the problem was simply not to open any web site after connecting the internet. as soon as typed the address and pressed enter, mozilla gave the error "... could not be found" as if i am not online.

i asked this in general forum, and got no reply. then tried to connect to the internet using knoppix, and yep, i got it. I have the internet with knoppix.

I checked /etc/resolv.conf after booting knoppix, and it was nothing except a comment line. but right after connecting to my ISS, it automatically updated to:

Code:
nameserver 213.243.0.40

nameserver 213.243.0.42
and my conglusion was "this file should be updated automatically somehow." I noted down the server adresses there.

Now, I booted my system normally to fedora core 2, connected to the internet and checked the /etc/resolv.conf. OK, we have found the real problem; it is not updated... It always stays the same: nothing except the comment line, no nameservers defined there. I edited the file, and added the server addresses I noted down when connected to the net on knoppix, and OK, I can do it now.

now, anyone has any idea? why does this happen? how can I overcome this? do I have to edit the resolv.conf file every time I connect to the net?

your help will be greatly appriciated.

Last edited by metalyric; 06-02-2004 at 08:21 AM.
 
Old 06-02-2004, 08:04 AM   #2
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Rep: Reputation: 15
You don't say how you're getting your Internet connection.

Whatever programme you use to make the Internet connection, you need to set its option "use DNS server provided by ISP". I'm guessing that whatever you are using is set up not to do this.

Tell us more about your configuration and we'll see if we can help.

Cheers
 
Old 06-02-2004, 08:19 AM   #3
metalyric
LQ Newbie
 
Registered: Jun 2003
Location: Istanbul - Turkey
Posts: 8

Original Poster
Rep: Reputation: 0
dear kbcnetau, first of all thank you for your response.

I use a dial-up connection with a standard 56K external modem, and -as you can guess- kppp is the dial-up tool I use.

I sought for any options of kppp as you said something like "use DNS server provided by ISP", but I couldn't get one. does it have such an option? or should I seek it anywhere else?

Last edited by metalyric; 06-02-2004 at 08:20 AM.
 
Old 06-02-2004, 11:28 AM   #4
camelrider
Member
 
Registered: Apr 2003
Location: Juneau, Alaska
Posts: 250

Rep: Reputation: 32
Although it's been quite a while since I used KPPP I do remember it having a place to enter your DNS servers.
 
Old 06-02-2004, 08:44 PM   #5
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Rep: Reputation: 15
* Start kppp and make sure that the account you are using is selected.

* Select Setup.

* With the account you are using highlighted, select Edit.

* You should see a tab labelled "DNS" - you can either set this to "Automatic" (recommended) or, if it does not work, you can select "Manual" and enter the IP addresses of your DNS servers.

This information is based on the kppp 2.1.2 which I have on my machine.

Hope this helps.
 
Old 06-03-2004, 02:43 AM   #6
Mr_C
Member
 
Registered: Jan 2004
Location: Trinidad & Tobago
Distribution: Slackware
Posts: 317

Rep: Reputation: 30
go to networking (used to be redhat-config-network)

OK I KNOW you are using dial up (like me) however select your ETH0 and click edit. Somewhere around there is a radio butteon that goes something like 'resolve dns names...' make sure its checked.
Its located below the dhcp and above static ip options.

Yes again I know your on dial up but this allows the dns/nameserver to edit the /etc/resolv.conf as needed....

A buddy of mine showed me this and it worked on fc2
 
Old 06-03-2004, 08:39 AM   #7
metalyric
LQ Newbie
 
Registered: Jun 2003
Location: Istanbul - Turkey
Posts: 8

Original Poster
Rep: Reputation: 0
doesn't work

Mr_C, i tried it.

I have an onboard ethernet card, but it was deactivated by bios' default settings. to do what you said i activated it, and kudzu configured it on startup.

then i did what you said, but it didn't work either. (the checkbox you mentioned was "Automatically obtain DNS information from provider") i also tried to restart the system, nop.

any other ideas?

Last edited by metalyric; 06-03-2004 at 08:43 AM.
 
Old 06-03-2004, 07:03 PM   #8
Mr_C
Member
 
Registered: Jan 2004
Location: Trinidad & Tobago
Distribution: Slackware
Posts: 317

Rep: Reputation: 30
but but I worked for me!
I don't really know where else to look
 
Old 06-03-2004, 08:23 PM   #9
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Rep: Reputation: 15
Ask you ISP for the nameservers that you should be using - try setting these manually in kppp (see post #5 in this thread).
 
Old 06-04-2004, 05:51 AM   #10
metalyric
LQ Newbie
 
Registered: Jun 2003
Location: Istanbul - Turkey
Posts: 8

Original Poster
Rep: Reputation: 0
thank you all guys.

i just wanted to have a solution to have the changes done automatically. I already edited resolv.conf manually. but this is not the matter. i am unsatisfied because i couldn't find the why, and couldn't solve this problem.

anyways, thank you very much again!

PS: if you have new suggestions about this, i will be waiting
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
resolv.conf Snump Mandriva 54 10-31-2004 04:16 PM
/etc/resolv.conf Pedroski Linux - Networking 1 06-22-2004 10:03 AM
resolv.conf?? wrat Linux - Newbie 3 06-14-2004 04:37 PM
resolv.conf dnsbum Linux - Networking 1 10-21-2003 12:00 PM
Resolv.conf tristan_vdv Linux - Networking 2 11-20-2001 06:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration