LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-08-2004, 05:35 PM   #1
roggs
LQ Newbie
 
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0
Require assistance setting up PPPoe with firewall (2 NIC's)


I am running Mandrake 9.2. I have tried several methods to connect to my DSL via PPPoe. I have been successful connecting and surfing the net with only one network card installed. I just used the network wizard and configured eth0 and to start at boot up. After successfully connecting via PPPoe I shut down my system and rebooted and tested. After successful tests I shut down and inserted a second NIC. For some reason the PPPoe connection is no longer made and I end up with a 10.x.x.x address on eth0. I re-run the network wizard to connect via PPPoe but no luck, the system does not connect to my ISP. My ultimate goal is to build a linux firewall and have eth0 on the outside via PPPoe and eth1 with a static IP for my LAN running DNAT. If I could get etho0 to connect via pppoe I can proceed with installing and configuring my firewall. Any assistance would be greatly appreciated .

Thank you in advance.
 
Old 12-09-2004, 05:58 AM   #2
maxut
Senior Member
 
Registered: May 2003
Location: istanbul
Distribution: debian - redhat - others
Posts: 1,188

Rep: Reputation: 50
im not similiar to your distro.
i have redhat distro works as a firewall. my ADSL modem-router works in bridge mode. and i use rp-pppoe on linux side.
fisrt, make sure that NICs are configured correctly,
check /etc/modules.conf (or /etc/modprobe.conf for 2.6 kernels)
there must be some lines like that:
alias eth0 $driver_module_of_eth0
alias eth1 $driver_module_of_eth1

if u have installed rp-pppoe packet first remove it. (rpm -e rp-pppoe)
and download http://www.roaringpenguin.com/pengui...poe-3.5.tar.gz . etcract it, and read the docs of it.

good luck.
 
Old 12-09-2004, 07:27 AM   #3
metalick
Member
 
Registered: Apr 2004
Location: Zagreb, Croatia
Distribution: SuSE 9.0
Posts: 44

Rep: Reputation: 15
rp-pppoe is the way to go.
plus squid ( www.squid-cache.org ) with some iptebles firewalling ( www.netfilter.org )
 
Old 12-09-2004, 01:48 PM   #4
camelrider
Member
 
Registered: Apr 2003
Location: Juneau, Alaska
Posts: 250

Rep: Reputation: 32
It's possible that your sytstem is recognizing your second NIC as eth0.
the output of /sbin/ifconfig -a might shed some light.

You may also want to check the contents of the relavent files in
/etc/sysconfig/network-scripts/

Example:
Code:
less /etc/sysconfig/network-scripts/ifconfig-eth0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need assistance mounting paritions in Ubuntu and setting password cajunaggie Linux - Software 4 01-08-2005 04:14 PM
Firewall/Router/pppoe/dhcp Beetle B. Linux - Networking 3 09-15-2003 03:07 PM
I require assistance plz CTBengoechea Linux - Newbie 16 10-13-2002 06:06 AM
Problem setting up two NIC's Ryan_Sutton Linux - Networking 1 05-29-2002 08:43 AM
Need assistance on setting up a server wa03 Linux - Networking 1 09-04-2000 04:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration