-   Linux - Networking (
-   -   REDHAT ES Server 4 --- Samba 3 PDC (

treedstang 03-15-2005 08:53 PM

REDHAT ES Server 4 --- Samba 3 PDC
I'm currently Redhat ES 4 Server with Samba version samba-3.0.10-1.4E as a PDC with the tdbsam backend

I'm having problems trying to join my Windows XP Pro workstations to the Domain. I thought I read somewhere that there is a issue using the the add machine script in the smb.conf that creates the machine account with a $ at the end of the of the machine account name.

I've even ran a test trying create the user account manually but I got the error below
The strange is it works fine in Suse 9.2 and Mandrake 10.1.. Any info on the items below would be deeply appreciated

[root@rhat4 samba]# useradd -s /bin/false/ -d /dev/null winxp2005$
useradd: invalid user name 'winxp2005$'

below is a copy of my smb.conf


# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = AGGEO
netbios name = RHAT4
# server string is the equivalent of the NT Description field
server string = File Print Server

# than setting them up individually then you'll need this
printcap name = /etc/printcap
load printers = yes
; printing = cups

# This option tells cups that the data has already been rasterized
cups options = raw
# that connects
log file = /var/log/samba/%m.log
# all log information in one file
# log file = /var/log/samba/smbd.log

# Put a capping on the size of the log files (in Kb).
max log size = 50

security = user
# Do not enable this option unless you have read those documents
# encrypt passwords = yes
# smb passwd file = /etc/samba/smbpasswd

passdb backend = tdbsam

add user script = /usr/sbin/useradd -m %u
delete user script = /usr/sbin/userdel -r %u
add group script = /usr/sbin/groupadd %g
delete group script = /usr/sbin/groupdel %g
add user to group script = /usr/sbin/usermod -G %g %u
# add machine script = /usr/sbin/useradd -s /bin/false -d /dev/null -g machines %u
# add machine script = /usr/sbin/useradd -s /bin/false -d /dev/null %u
# add machine script = /usr/sbin/useradd -d /dev/null -g machines -c 'Machine Account' -s /bin/false -M '%u'
add machine script = useradd -g machines -d /dev/null -s /bin/false %m

# Unix users can map to different SMB User names
username map = /etc/samba/smbusers

; include = /etc/samba/smb.conf.%m
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

local master = no

os level = 33
domain master = yes

preferred master = yes

domain logons = yes

# run a specific logon batch file per username
; logon script = %U.bat

logon script = logon.bat
logon drive = I:

# WINS Support - Tells the NMBD component of Samba to enable it's WINS Server
wins support = yes

# this has been changed in version 1.9.18 to no.
dns proxy = no

david_ross 03-30-2005 12:59 PM

Take a look at this:

amitsharma_26 12-16-2005 12:29 PM


Originally Posted by treedstang
[root@rhat4 samba]# useradd -s /bin/false/ -d /dev/null winxp2005$
useradd: invalid user name 'winxp2005$'

useradd -s /bin/false/ -d /dev/null winxp2005

Later on in /etc/passwd & in /etc/shadow

add a "$" sign next to your user name in the first column manually.

Thats it. It will work.


All times are GMT -5. The time now is 05:19 AM.