LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Redhat Enterprise 3 NForce2 ethernet Problems (https://www.linuxquestions.org/questions/linux-networking-3/redhat-enterprise-3-nforce2-ethernet-problems-206037/)

emig647 07-16-2004 06:50 PM

Redhat Enterprise 3 NForce2 ethernet Problems
 
This was my last resort. For over a month I have been trying to get this to work. I have scoured the internet in search of any information I can find.

I know this has been asked repeatedly but I have yet to find the correct solution.

I can not get my ethernet port to be recognized by Redhat enterprise 3 AS. Therefore, I can't get internet access on that machine unless i'm under a different OS.

I have tried installing different versions of the driver from NVidia but they don't match the kernel correctly. I also do not know how to recompile the kernel to configure it if that is what needs to be done. My modules.conf shows the correct information (alias eth0 nvnet). But it is still not recognized at all. Do I need to upgrade the kernel? The current kernel version is "2.4.21_4.EL". What else is there to do short of buying a new ethernet card?

I have to test on 3 different distros. Redhat 3 AS, Redhat 9, and Suse 9.1.

I need the internet in all of them for the new tests. Redhat 9 finally works with the NVidia drivers since they had that kernel version there. Suse 9.1 works right off of the bat flawlessly.

Thank you for any help

emig647 07-18-2004 08:02 PM

Do I need to recompile a module in the kernel? If so how do I do that?

emig647 07-28-2004 02:23 AM

Thanks for all the help!!

Glad this forum works.... I wouldn't screwed without all of the help I got. Man... what a great crowd.

Any ways I finally got it to work. I spent close to 20 hours trying to get this to work. Found out the errors I was getting with the generic driver from NVidia was because I didn't have all of the developer tools installed to build the driver. If you have had this problem make sure that isn't hte case.


All times are GMT -5. The time now is 12:25 PM.